Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040379
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-03-14 12:112019-03-21 10:04
ReporterngarciaView Statuspublic 
Assigned Tomigueldejuana 
PriorityurgentResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revisionee4b1581f4ed
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040379: Two cash ups in local storage if the backoffice session is closed during the cash up

DescriptionTwo cash ups in local storage if the backoffice session is closed during the cash up. It causes the following orders to go to Errors While Importing POS Data with the following error as the JSON has the two cash up identifiers:

javax.persistence.EntityNotFoundException: No row with the given identifier exists: [OBPOS_App_Cashup#...]
Steps To ReproduceLink a terminal
Log in
Open Till
Do some orders
Open backoffice in the same browser (Back Office menu entry in the POS)
Return to POS
Do the Cash up but do not complete the Step 4
Log out in the backoffice
Return to POS
Post, print and close
Check the following error message is shown:

"The connection was restored. However, in the meantime, your session timed out. You must login again now to ensure proper synchronization. Your pending tickets will be saved."

Click on Log in again
Open Till again
Do some orders

Check the go to Errors While Importing POS Data

If you check the cashup table in browser's local storage, you could observe there are two records
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0040387RR19Q1.2 closedmigueldejuana Two cash ups in local storage if the backoffice session is closed during the cash up 
depends on backport 0040388RR18Q4.3 closedmigueldejuana Two cash ups in local storage if the backoffice session is closed during the cash up 

-  Notes
(0110449)
hgbot (developer)
2019-03-15 08:01

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: f88298391cd54416523404d8fc4cd12a1d359a7b
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Thu Mar 14 19:00:34 2019 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f88298391cd54416523404d8fc4cd12a1d359a7b [^]

Fixed issue 0040379: Two cash ups in local storage if the backoffice session is closed during the cash up

- If we do not synchronize the cashup during cashup process (because we lost the session and we need to login again), the cashup is processed when we login again. If we have to synchronize a Cashup during the login we will create 2 new cashups. One because the login process creates one if there is not a Cashup not processed and another one created by the postProcessFunction which creates a new cashup after synchronizing a cashup.
Just avoid to create a new Cashup in postProcessFunction if we already habe created a new one.

---
M web/org.openbravo.retail.posterminal/js/login/model/login-model.js
---
(0110517)
hgbot (developer)
2019-03-20 16:59

Repository: erp/pmods/org.openbravo.retail.sessions
Changeset: 47f0e1cebf4fcbf04a82a5d31a6f1b4b9db0d6e7
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Wed Mar 20 16:59:10 2019 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/47f0e1cebf4fcbf04a82a5d31a6f1b4b9db0d6e7 [^]

Fixed issue 0040379: Two cash ups in local storage if the backoffice session is closed during the cash up

- Add a hook to be able to close till when synchronizing the cashup in the login process

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M web/org.openbravo.retail.sessions/js/components/loginhook.js
---
(0110520)
hgbot (developer)
2019-03-21 07:18

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 4e2ea81efa1de46562b8be4255d130654f515c91
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Wed Mar 20 16:58:43 2019 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/4e2ea81efa1de46562b8be4255d130654f515c91 [^]

Fixed issue 0040379: Two cash ups in local storage if the backoffice session is closed during the cash up

- Add a hook to be able to close till when synchronizing the cashup in the login process

---
M web/org.openbravo.retail.posterminal/js/login/model/login-model.js
---
(0110521)
hgbot (developer)
2019-03-21 07:18

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: ee4b1581f4ed55d8b6cf1b03166dbb4c6ed188e6
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Thu Mar 21 07:18:20 2019 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/ee4b1581f4ed55d8b6cf1b03166dbb4c6ed188e6 [^]

Fixed issue 0040379: Two cash ups in local storage if the backoffice session is closed during the cash up

- JSBeautifier

---
M web/org.openbravo.retail.posterminal/js/login/model/login-model.js
---

- Issue History
Date Modified Username Field Change
2019-03-14 12:11 ngarcia New Issue
2019-03-14 12:11 ngarcia Assigned To => Retail
2019-03-14 12:11 ngarcia Triggers an Emergency Pack => No
2019-03-14 12:11 ngarcia Issue Monitored: networkb
2019-03-14 22:00 rafaroda Issue Monitored: rafaroda
2019-03-15 08:01 hgbot Checkin
2019-03-15 08:01 hgbot Note Added: 0110449
2019-03-15 08:01 hgbot Status new => resolved
2019-03-15 08:01 hgbot Resolution open => fixed
2019-03-15 08:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f88298391cd54416523404d8fc4cd12a1d359a7b [^]
2019-03-15 08:29 migueldejuana Category Sessions => Web POS
2019-03-15 08:29 migueldejuana Assigned To Retail => migueldejuana
2019-03-15 08:29 migueldejuana Status resolved => new
2019-03-15 08:29 migueldejuana Resolution fixed => open
2019-03-15 08:31 migueldejuana Status new => scheduled
2019-03-15 08:31 migueldejuana Status scheduled => resolved
2019-03-15 08:31 migueldejuana Resolution open => fixed
2019-03-15 08:56 migueldejuana Status resolved => new
2019-03-15 08:56 migueldejuana Resolution fixed => open
2019-03-15 08:57 migueldejuana Status new => scheduled
2019-03-15 08:57 migueldejuana Status scheduled => resolved
2019-03-15 08:57 migueldejuana Resolution open => fixed
2019-03-15 11:32 guilleaer Review Assigned To => guilleaer
2019-03-15 11:32 guilleaer Status resolved => closed
2019-03-15 11:32 guilleaer Fixed in Version => RR19Q2
2019-03-20 16:59 hgbot Checkin
2019-03-20 16:59 hgbot Note Added: 0110517
2019-03-20 16:59 hgbot Status closed => resolved
2019-03-20 16:59 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f88298391cd54416523404d8fc4cd12a1d359a7b [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/47f0e1cebf4fcbf04a82a5d31a6f1b4b9db0d6e7 [^]
2019-03-21 07:18 hgbot Checkin
2019-03-21 07:18 hgbot Note Added: 0110520
2019-03-21 07:18 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/47f0e1cebf4fcbf04a82a5d31a6f1b4b9db0d6e7 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/4e2ea81efa1de46562b8be4255d130654f515c91 [^]
2019-03-21 07:18 hgbot Checkin
2019-03-21 07:18 hgbot Note Added: 0110521
2019-03-21 07:18 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/4e2ea81efa1de46562b8be4255d130654f515c91 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/ee4b1581f4ed55d8b6cf1b03166dbb4c6ed188e6 [^]
2019-03-21 10:04 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker