Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040388
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSmajoralways2019-03-14 12:112019-04-10 15:27
ReporterngarciaView Statuspublic 
Assigned Tomigueldejuana 
PriorityurgentResolutionfixedFixed in VersionRR18Q4.3
StatusclosedFix in branchFixed in SCM revisiond916a7d1a145
ProjectionnoneETAnoneTarget VersionRR18Q4.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040388: Two cash ups in local storage if the backoffice session is closed during the cash up

DescriptionTwo cash ups in local storage if the backoffice session is closed during the cash up. It causes the following orders to go to Errors While Importing POS Data with the following error as the JSON has the two cash up identifiers:

javax.persistence.EntityNotFoundException: No row with the given identifier exists: [OBPOS_App_Cashup#...]
Steps To ReproduceLink a terminal
Log in
Open Till
Do some orders
Open backoffice in the same browser (Back Office menu entry in the POS)
Return to POS
Do the Cash up but do not complete the Step 4
Log out in the backoffice
Return to POS
Post, print and close
Check the following error message is shown:

"The connection was restored. However, in the meantime, your session timed out. You must login again now to ensure proper synchronization. Your pending tickets will be saved."

Click on Log in again
Open Till again
Do some orders

Check the go to Errors While Importing POS Data

If you check the cashup table in browser's local storage, you could observe there are two records
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0040379 closedmigueldejuana Two cash ups in local storage if the backoffice session is closed during the cash up 

-  Notes
(0110962)
hgbot (developer)
2019-04-02 10:22

Repository: retail/backports/3.0RR18Q4.3/org.openbravo.retail.posterminal
Changeset: d916a7d1a145bd2ade4f93640a1f944df645396c
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Tue Apr 02 10:21:33 2019 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR18Q4.3/org.openbravo.retail.posterminal/rev/d916a7d1a145bd2ade4f93640a1f944df645396c [^]

Fixed issue 0040388: Two cash ups in local storage if the backoffice session is closed during the cash up

- If we do not synchronize the cashup during cashup process (because we lost the session and we need to login again), the cashup is processed when we login again. If we have to synchronize a Cashup during the login we will create 2 new cashups. One because the login process creates one if there is not a Cashup not processed and another one created by the postProcessFunction which creates a new cashup after synchronizing a cashup.
Just avoid to create a new Cashup in postProcessFunction if we already habe created a new one.
- Add a hook to be able to close till when synchronizing the cashup in the login process

---
M web/org.openbravo.retail.posterminal/js/login/model/login-model.js
---

- Issue History
Date Modified Username Field Change
2019-03-15 08:31 migueldejuana Type defect => backport
2019-03-15 08:31 migueldejuana Target Version => RR18Q4.3
2019-04-02 10:22 hgbot Checkin
2019-04-02 10:22 hgbot Note Added: 0110962
2019-04-02 10:22 hgbot Status scheduled => resolved
2019-04-02 10:22 hgbot Resolution open => fixed
2019-04-02 10:22 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f88298391cd54416523404d8fc4cd12a1d359a7b [^] => http://code.openbravo.com/retail/backports/3.0RR18Q4.3/org.openbravo.retail.posterminal/rev/d916a7d1a145bd2ade4f93640a1f944df645396c [^]
2019-04-10 15:27 marvintm Review Assigned To => marvintm
2019-04-10 15:27 marvintm Status resolved => closed
2019-04-10 15:27 marvintm Fixed in Version => RR18Q4.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker