Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039620
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] Z. Othersminoralways2018-11-13 17:252018-11-16 09:54
ReportercaristuView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0PR18Q3.3
StatusclosedFix in branchFixed in SCM revisionab71c6a06243
ProjectionnoneETAnoneTarget Version3.0PR18Q3.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-02-02
Regression introduced in release3.0PR18Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/18388657f3c0f155490eeed4ab39b431492b2dc0 [^]
Triggers an Emergency PackNo
Summary

0039620: Display logic in Product window does not work properly while opening as a tab from another window

DescriptionDisplay logic in Product window does not work properly while opening as a tab from another window
Steps To ReproduceLogin in the backend
Go to Windows, tabs adn fields window as System Admin
Select Product window and Price tab
Set display logic = @AD_Role_ID@='D615084948E046E3A439915008F464A6'
Login As 'F&B International Group Admin' and go to Product window
    See that Price tab is hidden
Go to sales order window, select a line and open the product on a tab
    See that Price tab is now shown
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0039405 closedAugustoMauch Display logic in Product window does not work properly while opening as a tab from another window 

-  Notes
(0107896)
hgbot (developer)
2018-11-14 09:23

Repository: erp/backports/3.0PR18Q3.3
Changeset: ab71c6a062430606e417aaded43c81610e583a9d
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Nov 14 09:22:19 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR18Q3.3/rev/ab71c6a062430606e417aaded43c81610e583a9d [^]

Fixes issue 39620: Tab display logic works when direct opening a header tab

Before this change, when a window was opened by clicking on a column title, the display logic of the
tabs of the window were not evaluated. This was done because if the tab opened was a subtab, that tab
should be visible, regardless of that tab's display logic.

But there is no need to enforce that logic when the tab opened is a header tab. This changeset evaluates
the display logics of the tabs if the tab opened directly is a header tab.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0107944)
caristu (developer)
2018-11-16 09:54

Code reviewed + tested OK.

- Issue History
Date Modified Username Field Change
2018-11-13 17:25 caristu New Issue
2018-11-13 17:25 caristu Assigned To => AugustoMauch
2018-11-13 17:25 caristu Modules => Core
2018-11-13 17:25 caristu Regression level => Production - Confirmed Stable
2018-11-13 17:25 caristu Regression date => 2018-02-02
2018-11-13 17:25 caristu Regression introduced in release => 3.0PR18Q2
2018-11-13 17:25 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/18388657f3c0f155490eeed4ab39b431492b2dc0 [^]
2018-11-13 17:25 caristu Triggers an Emergency Pack => No
2018-11-13 17:25 caristu Issue generated from 0039405
2018-11-13 17:25 caristu Relationship added blocks 0039405
2018-11-13 17:26 caristu Type defect => backport
2018-11-14 09:22 AugustoMauch Review Assigned To => caristu
2018-11-14 09:23 hgbot Checkin
2018-11-14 09:23 hgbot Note Added: 0107896
2018-11-14 09:23 hgbot Status new => resolved
2018-11-14 09:23 hgbot Resolution open => fixed
2018-11-14 09:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR18Q3.3/rev/ab71c6a062430606e417aaded43c81610e583a9d [^]
2018-11-16 09:54 caristu Note Added: 0107944
2018-11-16 09:54 caristu Status resolved => closed
2018-11-16 09:54 caristu Fixed in Version => 3.0PR18Q3.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker