Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039405
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2018-10-04 15:402018-12-11 20:22
ReporteranderarangurenView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revisionade8b8bcc3e7
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039405: Display logic in Product window does not work properly while opening as a tab from another window

DescriptionDisplay logic in Product window does not work properly while opening as a tab from another window
Steps To ReproduceLogin in the backend
Go to Windows, tabs adn fields window as System Admin
Select Product window and Price tab
Set display logic = @AD_Role_ID@='D615084948E046E3A439915008F464A6'
Login As 'F&B International Group Admin' and go to Product window
    See that Price tab is hidden
Go to sales order window, select a line and open the product on a tab
    See that Price tab is now shown
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00396203.0PR18Q3.3 closedAugustoMauch Display logic in Product window does not work properly while opening as a tab from another window 
depends on backport 00396213.0PR18Q4 closedAugustoMauch Display logic in Product window does not work properly while opening as a tab from another window 
caused by defect 0037587 closedjarmendariz Open on tab does not work on Tree type windows when using auxiliary inputs in display logic 

-  Notes
(0107643)
hgbot (developer)
2018-10-29 17:40

Repository: erp/devel/pi
Changeset: 06c4eb6200c10c432e95dc1921d914a726db8d67
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Oct 29 17:39:15 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/06c4eb6200c10c432e95dc1921d914a726db8d67 [^]

Fixes issue 39405: Tab display logic works when direct opening a header tab

Before this change, when a window was opened by clicking on a column title, the display logic of the
tabs of the window were not evaluated. This was done because if the tab opened was a subtab, that tab
should be visible, regardless of that tab's display logic.

But there is no need to enforce that logic when the tab opened is a header tab. This changeset evaluates
the display logics of the tabs if the tab opened directly is a header tab.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0107651)
hgbot (developer)
2018-10-30 10:39

Repository: erp/devel/pi
Changeset: ade8b8bcc3e770959b1e43e8fd10261e5fbe3d4d
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Oct 30 10:39:35 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ade8b8bcc3e770959b1e43e8fd10261e5fbe3d4d [^]

Fixes issue 39405: Parent view preference is called parentView, not parentTab

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0107812)
caristu (developer)
2018-11-08 19:20

Code reviewed + tested OK.
(0108447)
hudsonbot (developer)
2018-12-11 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/470e3cd384c5 [^]
Maturity status: Test
(0108448)
hudsonbot (developer)
2018-12-11 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/470e3cd384c5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-10-04 15:40 anderaranguren New Issue
2018-10-04 15:40 anderaranguren Assigned To => Triage Finance
2018-10-04 15:40 anderaranguren Modules => Core
2018-10-04 15:40 anderaranguren Triggers an Emergency Pack => No
2018-10-04 17:45 Sandrahuguet Assigned To Triage Finance => AtulOpenbravo
2018-10-22 11:52 dmiguelez Assigned To AtulOpenbravo => caristu
2018-10-29 10:24 AugustoMauch Assigned To caristu => AugustoMauch
2018-10-29 17:40 AugustoMauch Review Assigned To => caristu
2018-10-29 17:40 hgbot Checkin
2018-10-29 17:40 hgbot Note Added: 0107643
2018-10-29 17:40 hgbot Status new => resolved
2018-10-29 17:40 hgbot Resolution open => fixed
2018-10-29 17:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/06c4eb6200c10c432e95dc1921d914a726db8d67 [^]
2018-10-29 18:11 caristu Relationship added related to 0037587
2018-10-30 10:39 hgbot Checkin
2018-10-30 10:39 hgbot Note Added: 0107651
2018-10-30 10:39 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/06c4eb6200c10c432e95dc1921d914a726db8d67 [^] => http://code.openbravo.com/erp/devel/pi/rev/ade8b8bcc3e770959b1e43e8fd10261e5fbe3d4d [^]
2018-11-08 19:20 caristu Note Added: 0107812
2018-11-08 19:20 caristu Status resolved => closed
2018-11-08 19:20 caristu Fixed in Version => 3.0PR19Q1
2018-11-13 17:21 caristu Relationship deleted related to 0037587
2018-11-13 17:21 caristu Relationship added caused by 0037587
2018-11-13 17:25 caristu Issue cloned 0039620
2018-11-13 17:25 caristu Relationship added depends on 0039620
2018-11-13 17:27 caristu Issue cloned 0039621
2018-11-13 17:28 caristu Relationship added depends on 0039621
2018-12-11 20:22 hudsonbot Checkin
2018-12-11 20:22 hudsonbot Note Added: 0108447
2018-12-11 20:22 hudsonbot Checkin
2018-12-11 20:22 hudsonbot Note Added: 0108448


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker