Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038037
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2018-03-05 08:332018-03-08 16:32
ReportercaristuView Statuspublic 
Assigned Tojarmendariz 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revisionaf87e97a3a53
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2018-02-02
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/18388657f3c0f155490eeed4ab39b431492b2dc0 [^]
Triggers an Emergency PackNo
Summary

0038037: Display logic on tab not properly applied in form view

DescriptionDisplay logic on tab is not being properly applied in form view
Steps To Reproduce1) Go to the [Tables and Windows] window.
2) In the header, select any table that is not a tree, for example the AD_Alert. Notice that the "Table Tree Category" sub-tab is not shown. --> OK
3) Enter in form view on that very same record. The "Table Tree Category" is displayed. --> ERROR
Proposed SolutionThe fix for issue 0037587 is avoiding the computation of the display logic for tabs when entering in form view --> look for another way to difference the direct accessing of a record against entering in form view.
TagsNo tags attached.
Attached Filespatch file icon bug-38037.patch [^] (1,150 bytes) 2018-03-05 16:52 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0037587 closedjarmendariz Open on tab does not work on Tree type windows when using auxiliary inputs in display logic 

-  Notes
(0102986)
hgbot (developer)
2018-03-05 17:08

Repository: erp/devel/pi
Changeset: af87e97a3a5316f70fcee5a185699bcecd757d79
Author: Javier Armendáriz <javier.armendariz <at> openbravo.com>
Date: Mon Mar 05 17:07:21 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/af87e97a3a5316f70fcee5a185699bcecd757d79 [^]

Fixed bug 38037: Display logic on tab not applied in form view.

Changed logic to determine whether a subtab is called from a direct link call
to avoid skipping the display logic when entering form view. The directTabInfo
property is set when we are in direct link mode, so it seems fit for this feature.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0102997)
hudsonbot (developer)
2018-03-05 23:45

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ae235ad7fcda [^]
Maturity status: Test
(0103052)
jarmendariz (developer)
2018-03-07 08:53

Added the following tests to check this bug is not happening again:

https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10871 [^]

https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10872 [^]
(0103092)
caristu (developer)
2018-03-08 16:32

Code reviewed + tested OK.

Tested also following the steps to reproduce issue 0037587.

- Issue History
Date Modified Username Field Change
2018-03-05 08:33 caristu New Issue
2018-03-05 08:33 caristu Assigned To => platform
2018-03-05 08:33 caristu Modules => Core
2018-03-05 08:33 caristu Triggers an Emergency Pack => No
2018-03-05 08:33 caristu Relationship added caused by 0037587
2018-03-05 08:34 caristu Regression level => Pre packaging ( pi )
2018-03-05 08:34 caristu Regression date => 2018-02-02
2018-03-05 08:34 caristu Regression introduced in release => pi
2018-03-05 08:34 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/18388657f3c0f155490eeed4ab39b431492b2dc0 [^]
2018-03-05 08:34 caristu Assigned To platform => jarmendariz
2018-03-05 09:09 jarmendariz Status new => scheduled
2018-03-05 13:51 jarmendariz File Added: bug-38037.patch
2018-03-05 13:52 jarmendariz Review Assigned To => caristu
2018-03-05 16:52 jarmendariz File Deleted: bug-38037.patch
2018-03-05 16:52 jarmendariz File Added: bug-38037.patch
2018-03-05 17:08 hgbot Checkin
2018-03-05 17:08 hgbot Note Added: 0102986
2018-03-05 17:08 hgbot Status scheduled => resolved
2018-03-05 17:08 hgbot Resolution open => fixed
2018-03-05 17:08 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/af87e97a3a5316f70fcee5a185699bcecd757d79 [^]
2018-03-05 23:45 hudsonbot Checkin
2018-03-05 23:45 hudsonbot Note Added: 0102997
2018-03-07 08:53 jarmendariz Note Added: 0103052
2018-03-08 16:32 caristu Note Added: 0103092
2018-03-08 16:32 caristu Status resolved => closed
2018-03-08 16:32 caristu Fixed in Version => 3.0PR18Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker