Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039373
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajoralways2018-09-28 11:222018-12-11 20:22
Reporterneil_smithView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revision874862309622
ProjectionnoneETAnoneTarget Version
OSAnyDatabase@0@Java version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browserMozilla Firefox
ModulesUser Interface Application
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039373: Quantities replaced by line number (only displayed in window, not in database)

DescriptionWhen editing a record with a line number (orderline, inoviceline, inoutline), if the quantity is updated and click on the header (without changing field), the line numer is displayed in the updated quantity.
Steps To Reproduce1. Go to the sales order window, double click on a sale order to go into form view
2. Double click on a sale order line to go in form view
3. Update the quantity on the sale order line and stay on field (no tab or clicking on another field)
4. Click in the sale order header

It saves the quantity and displays the line numer in the updated quantity.

If you change field (tab or click else where) or are not in form view on the header when you click on it, it does not do this.

If you refresh the data, it displays the quantity with what you entered, the information in the database is correct.

The problem is if you go back to the line and change something else and save, the wrong quantity is saved in the database!!!

For me, it does not work on the orders, shipments and invoices (sales and purchases). I didn't try other windows where there is a line number...

It has the same comportment in creation if the last field you enter is the quantity, don't change fields and click on the header (always in form view).

This is a big issue as the quantity can be saved wrong in certain conditions!
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00394123.0PR18Q4 closedAugustoMauch Quantities replaced by line numer (only displayed in window, not in database) 
depends on backport 00394133.0PR18Q3.2 closedAugustoMauch Quantities replaced by line numer (only displayed in window, not in database) 
depends on backport 00394143.0PR18Q2.3 closedAugustoMauch Quantities replaced by line numer (only displayed in window, not in database) 

-  Notes
(0107064)
neil_smith (reporter)
2018-09-28 11:31

I hoticed that it takes the 1st field in the window and displays it in the quantity field.
With the orders, the line number is the first field, so it uses that one.
(0107067)
alostale (developer)
2018-09-28 11:56

I couldn't reproduce it nor in current developement branch nor in 17Q2.4.

Can you reproduce it here [1] (credentials: Openbravo/openbravo) which is a 172.4? If so it would be very helpful if you add more details to the steps to reproduce it and, if possible, to record a screencast reproducing it.

[1] https://livebuilds.openbravo.com/retail_mp_3.0RR17Q2.4 [^]
(0107074)
neil_smith (reporter)
2018-09-28 14:10

I don't have access to the sales or purchase windows with that user
(0107084)
alostale (developer)
2018-10-01 10:03

Change role to Group Admin (it defaults to System Admin)
(0107127)
neil_smith (reporter)
2018-10-03 08:03

I managed to reproduce it with the link you gave me, by following exactly the same steps as described...
I will upload a screencast later on.
(0107140)
neil_smith (reporter)
2018-10-03 14:13

I can't upload the screencast as a joint file, so here is the link to get it from our cloud
https://cloud.d-factos.ch/s/Y33oibWrGwRF9kA [^]
You can download the file from there

Thanks for your time
Regards
(0107166)
alostale (developer)
2018-10-05 08:15

I can reproduce it in Firefox but I can't in Chrome.
(0107174)
neil_smith (reporter)
2018-10-05 11:05

Same here, can't reproduce in Chrome.
We only use Firefox.
(0107211)
hgbot (developer)
2018-10-08 13:03

Repository: erp/devel/pi
Changeset: 874862309622981d2104f74b4352cd8c9373c1eb
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Oct 05 11:41:53 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/874862309622981d2104f74b4352cd8c9373c1eb [^]

Fixes issue 39373: Prevents unintended formitem value change if focus changes

There was a problem in this redraw function [1]. It did the following:
1) Get the value of the focused item (this.getFocusItem().getValue())
2) Redraw the form (this.Super('redraw', arguments);)
3) Restore the value of the focused item if the value changed during the redraw (this.getFocusItem().setElementValue(focusItemValue);)

The problem was that under some circumstances the focusedItem itself changed during the redraw, so the form items returned by this.getFocusItem()
in steps 1) and 3) are different, and the value from one form item was copied into another form item.

This problem has been fixed by storing in a variable the focused form item before the step 1), and the use that reference in the rest of the
function instead of reinvoking this.getFocusItem()

[1] https://code.openbravo.com/erp/devel/pi/file/tip/modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js#l2157 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0107321)
caristu (developer)
2018-10-16 10:54

Code reviewed + tested OK.
(0108422)
hudsonbot (developer)
2018-12-11 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/470e3cd384c5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-09-28 11:22 neil_smith New Issue
2018-09-28 11:22 neil_smith Assigned To => platform
2018-09-28 11:22 neil_smith Modules => User Interface Application
2018-09-28 11:22 neil_smith Triggers an Emergency Pack => No
2018-09-28 11:31 neil_smith Note Added: 0107064
2018-09-28 11:56 alostale Note Added: 0107067
2018-09-28 11:56 alostale Status new => feedback
2018-09-28 14:10 neil_smith Note Added: 0107074
2018-10-01 10:03 alostale Note Added: 0107084
2018-10-03 08:03 neil_smith Note Added: 0107127
2018-10-03 14:13 neil_smith Note Added: 0107140
2018-10-05 08:15 alostale Web browser => Mozilla Firefox
2018-10-05 08:15 alostale Note Added: 0107166
2018-10-05 08:15 alostale Severity critical => major
2018-10-05 08:15 alostale OS 30 =>
2018-10-05 08:15 alostale OS Version Openbravo Appliance 14.04 =>
2018-10-05 08:15 alostale version 3.0PR17Q2.4 =>
2018-10-05 08:16 alostale Web browser Mozilla Firefox => Mozilla Firefox
2018-10-05 08:16 alostale OS 0 => 5
2018-10-05 09:49 alostale Status feedback => new
2018-10-05 09:49 alostale Status new => acknowledged
2018-10-05 11:05 neil_smith Note Added: 0107174
2018-10-05 11:36 AugustoMauch Status acknowledged => scheduled
2018-10-05 11:36 AugustoMauch Assigned To platform => AugustoMauch
2018-10-05 11:36 AugustoMauch Web browser Mozilla Firefox => Mozilla Firefox
2018-10-05 11:36 AugustoMauch Summary Quantities replaced by line numer (only displayed in window, not in database) => Quantities replaced by line number (only displayed in window, not in database)
2018-10-08 13:03 hgbot Checkin
2018-10-08 13:03 hgbot Note Added: 0107211
2018-10-08 13:03 hgbot Status scheduled => resolved
2018-10-08 13:03 hgbot Resolution open => fixed
2018-10-08 13:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/874862309622981d2104f74b4352cd8c9373c1eb [^]
2018-10-08 14:56 AugustoMauch Review Assigned To => caristu
2018-10-08 14:56 AugustoMauch Web browser Mozilla Firefox => Mozilla Firefox
2018-10-16 10:54 caristu Note Added: 0107321
2018-10-16 10:54 caristu Status resolved => closed
2018-10-16 10:54 caristu Fixed in Version => 3.0PR19Q1
2018-12-11 20:22 hudsonbot Checkin
2018-12-11 20:22 hudsonbot Note Added: 0108422


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker