Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038189
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2018-03-21 11:312018-03-29 13:07
ReporterJONHMView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revision9b1581758f9f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-11-08
Regression introduced in release3.0PR18Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/a87ba8a293e6224273bd2c70d0fcbb54d9ac8cf6 [^]
Triggers an Emergency PackNo
Summary

0038189: OBUISEL_Selector references are not displayed properly in tabs that shows 2.50 forms

DescriptionOBUISEL_Selector references are not displayed properly in tabs that shows 2.50 forms
Steps To Reproduce0) Install the org.openbravo.module.remittance module
1) Open 'Settle / Process Remittances' window
2) Notice that Business Partner selector is missing

-> The selector is shown up to 16Q2
TagsNo tags attached.
Attached Filespng file icon 16q2.png [^] (51,857 bytes) 2018-03-21 11:31


png file icon pi.png [^] (49,843 bytes) 2018-03-21 11:31

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037303 closedcaristu Sales Order selector in Generate Invoice process does not wok properly 
depends on backport 00382363.0PR18Q1.2 closedcaristu Update Business Partner Selector of 'Settle / Process Remittances' process 
depends on backport 00382413.0PR17Q4.3 closedcaristu Update Business Partner Selector of 'Settle / Process Remittances' process 
caused by defect 0037259 closedcaristu Some labels are not properly translated after switching the language 

-  Notes
(0103592)
hgbot (developer)
2018-03-28 08:26

Repository: erp/devel/pi
Changeset: 9b1581758f9f658032470095236061e508683510
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Mar 27 19:16:16 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9b1581758f9f658032470095236061e508683510 [^]

fixes bug 38189: OBUISEL_Selector not displayed in tabs that shows 2.50 forms

  In 2.50 forms displayed inside 3.0 windows, a request to load the JS static resources is done but the SessionDynamic request is not. As a result, the OB object was generated partially. This caused JS errors when referencing to the missing data (for example when trying to get a label from the OB.I18N object).

  This issue was fixed partially on issue 0037303. The problem here is still reproducible because when opening a 2.50 form inside a tab, the window.LayoutMDI_windowObj has not being initialized because the getFrame('LayoutMDI') is not being invoked.

  To fix the problem, now we are directly invoking getFrame('LayoutMDI') to get the OB object.

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/templates/application-js.ftl
---
(0103618)
alostale (developer)
2018-03-28 17:23

reviewed
(0103637)
hudsonbot (developer)
2018-03-29 13:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ead4656f507e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-03-21 11:31 JONHM New Issue
2018-03-21 11:31 JONHM Assigned To => Triage Finance
2018-03-21 11:31 JONHM File Added: 16q2.png
2018-03-21 11:31 JONHM Resolution time => 1523397600
2018-03-21 11:31 JONHM File Added: pi.png
2018-03-21 11:33 Practics Issue Monitored: Practics
2018-03-22 17:39 dmiguelez Assigned To Triage Finance => markmm82
2018-03-22 18:00 markmm82 Status new => acknowledged
2018-03-27 10:05 dmiguelez Assigned To markmm82 => platform
2018-03-27 17:27 caristu Relationship added related to 0037303
2018-03-27 17:27 caristu Assigned To platform => caristu
2018-03-27 17:27 caristu Status acknowledged => scheduled
2018-03-27 17:31 caristu Project Modules => Openbravo ERP
2018-03-27 17:31 caristu Modules => Core
2018-03-27 17:31 caristu Triggers an Emergency Pack => No
2018-03-27 17:31 caristu Category Remittance => A. Platform
2018-03-27 17:34 caristu Regression level => Production - QA Approved
2018-03-27 17:34 caristu Regression date => 2017-11-08
2018-03-27 17:34 caristu Regression introduced in release => 3.0PR18Q1
2018-03-27 17:34 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/a87ba8a293e6224273bd2c70d0fcbb54d9ac8cf6 [^]
2018-03-27 17:34 caristu Relationship added caused by 0037259
2018-03-27 17:35 caristu Status scheduled => acknowledged
2018-03-27 17:36 caristu Status acknowledged => scheduled
2018-03-27 19:15 caristu Summary Update Business Partner Selector of 'Settle / Process Remittances' process => OBUISEL_Selector references are not displayed properly in tabs that shows 2.50 forms
2018-03-27 19:15 caristu Description Updated View Revisions
2018-03-27 19:15 caristu Steps to Reproduce Updated View Revisions
2018-03-28 08:26 hgbot Checkin
2018-03-28 08:26 hgbot Note Added: 0103592
2018-03-28 08:26 hgbot Status scheduled => resolved
2018-03-28 08:26 hgbot Resolution open => fixed
2018-03-28 08:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9b1581758f9f658032470095236061e508683510 [^]
2018-03-28 08:27 caristu Review Assigned To => alostale
2018-03-28 08:35 caristu Relationship added depends on 0038241
2018-03-28 08:40 caristu Regression level Production - QA Approved => Production - Confirmed Stable
2018-03-28 09:44 ngarcia Issue Monitored: ngarcia
2018-03-28 17:23 alostale Note Added: 0103618
2018-03-28 17:23 alostale Status resolved => closed
2018-03-28 17:23 alostale Fixed in Version => 3.0PR18Q2
2018-03-29 13:07 hudsonbot Checkin
2018-03-29 13:07 hudsonbot Note Added: 0103637


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker