Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037303
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajorhave not tried2017-11-16 10:162018-01-03 12:39
ReporterAtulOpenbravoView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revisiona9882672a5ea
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2017-11-08
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/a87ba8a293e6224273bd2c70d0fcbb54d9ac8cf6 [^]
Triggers an Emergency PackNo
Summary

0037303: Sales Order selector in Generate Invoice process does not wok properly

DescriptionSales Order selector based on OB UI Selector reference in Generate Invoices process does not wok properly. It is not visible.
Steps To Reproduce- Login as F&B International Group Admin
- Navigate to Generate Invoices process (Sales Management | Transaction | Generate Invoices)
- Realize that no selector appears in front of Label Sales Order.
TagsNo tags attached.
Attached Filespng file icon RelatedIssue_GenerateInvoices.png [^] (37,234 bytes) 2017-11-16 10:16

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00373113.0PR17Q4 closedcaristu Sales Order selector in Generate Invoice process does not wok properly 
depends on backport 00373123.0PR17Q3.2 closedcaristu Sales Order selector in Generate Invoice process does not wok properly 
caused by defect 0037259 closedcaristu Some labels are not properly translated after switching the language 
related to defect 0038189 closedcaristu OBUISEL_Selector references are not displayed properly in tabs that shows 2.50 forms 

-  Notes
(0100566)
hgbot (developer)
2017-11-17 09:03

Repository: erp/devel/pi
Changeset: a9882672a5ea18b556fac0a80fc3bb7e0fbd24b3
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Nov 17 08:48:06 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a9882672a5ea18b556fac0a80fc3bb7e0fbd24b3 [^]

fixes bug 37303: Sales Order selector in Generate Invoices process is not shown

  With the changes introduced on issue 0035553, the OB object is generated in two stages: it is initialized when the JS static resources are loaded and secondly additional session data is included with the SessionDynamic request.

  In old processes inside 3.0 windows, a request to load the JS static resources is done but the SessionDynamic request is not. As a result, the OB object was generated partially. This caused JS errors when referencing to the missing data like it was happening when loading the sales order selector on the Generate Invoices process.

  To fix this issue, now when we are in an old process loaded inside a 3.0 window, instead of generating the OB object from scratch, it is cloned from the main OB object of the application which is generated right after logging in.

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/templates/application-js.ftl
---
(0100590)
hgbot (developer)
2017-11-17 14:56

Repository: erp/devel/pi
Changeset: 52f2ecf45578704a4c44d71cba55758a460ce2bc
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Nov 17 14:55:38 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/52f2ecf45578704a4c44d71cba55758a460ce2bc [^]

related to issue 37303: Add comment

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/templates/application-js.ftl
---
(0100727)
alostale (developer)
2017-11-27 10:22

reviewed + tested
(0101431)
hudsonbot (developer)
2018-01-03 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101437)
hudsonbot (developer)
2018-01-03 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-11-16 10:16 AtulOpenbravo New Issue
2017-11-16 10:16 AtulOpenbravo Assigned To => platform
2017-11-16 10:16 AtulOpenbravo File Added: RelatedIssue_GenerateInvoices.png
2017-11-16 10:16 AtulOpenbravo Modules => Core
2017-11-16 10:16 AtulOpenbravo Triggers an Emergency Pack => No
2017-11-16 11:01 alostale Regression level => Pre packaging ( pi )
2017-11-16 11:01 alostale Regression introduced in release => pi
2017-11-16 11:01 alostale Priority normal => immediate
2017-11-16 16:32 caristu Assigned To platform => caristu
2017-11-16 16:41 caristu Regression date => 2017-11-08
2017-11-16 16:41 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/a87ba8a293e6224273bd2c70d0fcbb54d9ac8cf6 [^]
2017-11-16 16:42 caristu Relationship added caused by 0037259
2017-11-16 16:44 caristu Status new => scheduled
2017-11-17 09:03 hgbot Checkin
2017-11-17 09:03 hgbot Note Added: 0100566
2017-11-17 09:03 hgbot Status scheduled => resolved
2017-11-17 09:03 hgbot Resolution open => fixed
2017-11-17 09:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a9882672a5ea18b556fac0a80fc3bb7e0fbd24b3 [^]
2017-11-17 14:56 hgbot Checkin
2017-11-17 14:56 hgbot Note Added: 0100590
2017-11-17 14:56 caristu Review Assigned To => alostale
2017-11-27 10:22 alostale Note Added: 0100727
2017-11-27 10:22 alostale Status resolved => closed
2017-11-27 10:22 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:39 hudsonbot Checkin
2018-01-03 12:39 hudsonbot Note Added: 0101431
2018-01-03 12:39 hudsonbot Checkin
2018-01-03 12:39 hudsonbot Note Added: 0101437
2018-03-27 17:27 caristu Relationship added related to 0038189


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker