Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037259
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2017-11-08 11:572018-03-27 19:04
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revisiona87ba8a293e6
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2017-05-08
Regression introduced in release3.0PR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/554d8c055ea2e7cb078c405634e41c14079bd61e [^]
Triggers an Emergency PackNo
Summary

0037259: Some labels are not properly translated after switching the language

DescriptionSome labels are not properly translated after switching the language. This can be reproduced when there are not modules in "in development" status because in that case the labels are being cached in the client since the changes introduced with the issue 0035852
Steps To Reproduce1) Install the Spanish Localization pack
2) Ensure that there are not modules in "in development" status
3) Log-in as F&B International Group (it has English language by default)
4) Switch to the Spanish language
5) Note that some labels do no appear translated: in the toolbar, profile widget or in the workspace (see attached image).
TagsNo tags attached.
Attached Filespng file icon image.png [^] (99,634 bytes) 2017-11-08 11:57

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00372613.0PR17Q4 closedcaristu Some labels are not properly translated after switching the language 
depends on backport 00372623.0PR17Q3.2 closedcaristu Some labels are not properly translated after switching the language 
caused by feature request 0035852 closedcaristu Add a mechanism to cache the static resources 
related to defect 0037266 closedcaristu API Change required for I18NComponent class 
causes defect 0037303 closedcaristu Sales Order selector in Generate Invoice process does not wok properly 
causes defect 0038189 closedcaristu OBUISEL_Selector references are not displayed properly in tabs that shows 2.50 forms 

-  Notes
(0100351)
hgbot (developer)
2017-11-08 14:20

Repository: erp/devel/pi
Changeset: a87ba8a293e6224273bd2c70d0fcbb54d9ac8cf6
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Nov 08 14:15:30 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a87ba8a293e6224273bd2c70d0fcbb54d9ac8cf6 [^]

fixes bug 37259: Some labels are not translated after switching the language

  After the changes introduced on issue 0035852 the labels were being cached together with the rest of the static javascript code. Thus, being in an environment not in "in development" status, the labels were being cached in the language of the first login avoiding the translation when switching to another language afterwards.

  To fix the problem now the component responsible of collecting the labels has been defined as a session dynamic component. This way the labels will be retrieved on every login. And to avoid querying to the database on each login request, the labels are now being cached in the server per language.

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/I18NComponent.java
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/KernelComponentProvider.java
---
(0100352)
hgbot (developer)
2017-11-08 14:35

Repository: erp/devel/pi
Changeset: 577cf6624b2a571d7c5bd79db668a4597ab7ca9d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Nov 08 14:34:38 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/577cf6624b2a571d7c5bd79db668a4597ab7ca9d [^]

related to issue 37259: adapt test case to the new component's definition

---
M modules/org.openbravo.client.kernel/src-test/org/openbravo/client/kernel/freemarker/test/LabelTest.java
---
(0100357)
hgbot (developer)
2017-11-08 16:12

Repository: erp/devel/pi
Changeset: 04e362ada9264c4b190ecf3f76d7fb24bb220dea
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Nov 08 16:11:50 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/04e362ada9264c4b190ecf3f76d7fb24bb220dea [^]

related to issue 37259: adapt test case to the new component's definition

---
M modules/org.openbravo.client.kernel/src-test/org/openbravo/client/kernel/freemarker/test/GenerateComponentTest.java
---
(0100358)
hgbot (developer)
2017-11-08 17:49

Repository: erp/devel/pi
Changeset: 8968fc3eb9fe23b14ba06627cb42aa1676cef597
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Nov 08 17:46:31 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/8968fc3eb9fe23b14ba06627cb42aa1676cef597 [^]

related to issue 37259: minor code improvements
  - Removed testLabels() test from GenerateComponentTest as the generation of the I18NComponent component is already covered with the LabelTest class
  - Use the log to print the result of the component generation instead of the standard error output
  - Generate the I18NComponent using its generate method. This is how it is generated by the SessionDynamicResourceComponent

---
M modules/org.openbravo.client.kernel/src-test/org/openbravo/client/kernel/freemarker/test/GenerateComponentTest.java
M modules/org.openbravo.client.kernel/src-test/org/openbravo/client/kernel/freemarker/test/LabelTest.java
---
(0100424)
alostale (developer)
2017-11-10 13:03

reviewed + tested
(0101381)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101382)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101383)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101384)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-11-08 11:57 caristu New Issue
2017-11-08 11:57 caristu Assigned To => platform
2017-11-08 11:57 caristu File Added: image.png
2017-11-08 11:57 caristu Modules => Core
2017-11-08 11:57 caristu Triggers an Emergency Pack => No
2017-11-08 11:58 caristu Assigned To platform => caristu
2017-11-08 11:58 caristu Relationship added caused by 0035852
2017-11-08 12:22 caristu Regression level => Production - QA Approved
2017-11-08 12:22 caristu Regression date => 2017-05-08
2017-11-08 12:22 caristu Regression introduced in release => 3.0PR17Q3
2017-11-08 12:22 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/554d8c055ea2e7cb078c405634e41c14079bd61e [^]
2017-11-08 12:28 caristu Status new => acknowledged
2017-11-08 12:29 caristu Status acknowledged => scheduled
2017-11-08 14:20 hgbot Checkin
2017-11-08 14:20 hgbot Note Added: 0100351
2017-11-08 14:20 hgbot Status scheduled => resolved
2017-11-08 14:20 hgbot Resolution open => fixed
2017-11-08 14:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a87ba8a293e6224273bd2c70d0fcbb54d9ac8cf6 [^]
2017-11-08 14:35 hgbot Checkin
2017-11-08 14:35 hgbot Note Added: 0100352
2017-11-08 16:12 hgbot Checkin
2017-11-08 16:12 hgbot Note Added: 0100357
2017-11-08 17:49 hgbot Checkin
2017-11-08 17:49 hgbot Note Added: 0100358
2017-11-08 17:50 caristu Review Assigned To => alostale
2017-11-08 18:38 caristu Relationship added related to 0037266
2017-11-08 19:04 caristu Relationship added related to 0037267
2017-11-08 19:04 caristu Relationship deleted related to 0037267
2017-11-10 13:03 alostale Note Added: 0100424
2017-11-10 13:03 alostale Status resolved => closed
2017-11-10 13:03 alostale Fixed in Version => 3.0PR18Q1
2017-11-16 16:42 caristu Relationship added causes 0037303
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101381
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101382
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101383
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101384
2018-03-27 17:34 caristu Relationship added causes 0038189
2018-03-27 19:04 Practics Issue Monitored: Practics


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker