Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038236
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajoralways2018-03-21 11:312018-03-28 17:24
ReporterJONHMView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q1.2
StatusclosedFix in branchFixed in SCM revision21633aa9f482
ProjectionnoneETAnoneTarget Version3.0PR18Q1.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-11-08
Regression introduced in release3.0PR18Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/a87ba8a293e6224273bd2c70d0fcbb54d9ac8cf6 [^]
Triggers an Emergency PackNo
Summary

0038236: Update Business Partner Selector of 'Settle / Process Remittances' process

DescriptionThe 'Settle / Process Remittances' process contains an old selector which does not work in new versions of Core
Steps To ReproduceOpen 'Settle / Process Remittances' window
Notice that Business Partner selector is missing

-> The selector is shown up to 16Q2
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0038189 closedcaristu OBUISEL_Selector references are not displayed properly in tabs that shows 2.50 forms 

-  Notes
(0103598)
hgbot (developer)
2018-03-28 09:44

Repository: erp/backports/3.0PR18Q1.2
Changeset: 21633aa9f482a61e1c83204bbc21839fe97c67d3
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Mar 27 19:16:16 2018 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR18Q1.2/rev/21633aa9f482a61e1c83204bbc21839fe97c67d3 [^]

fixes bug 38236: OBUISEL_Selector not displayed in tabs that shows 2.50 forms

  In 2.50 forms displayed inside 3.0 windows, a request to load the JS static resources is done but the SessionDynamic request is not. As a result, the OB object was generated partially. This caused JS errors when referencing to the missing data (for example when trying to get a label from the OB.I18N object).

  This issue was fixed partially on issue 0037303. The problem here is still reproducible because when opening a 2.50 form inside a tab, the window.LayoutMDI_windowObj has not being initialized because the getFrame('LayoutMDI') is not being invoked.

  To fix the problem, now we are directly invoking getFrame('LayoutMDI') to get the OB object.

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/templates/application-js.ftl
---
(0103619)
alostale (developer)
2018-03-28 17:24

reviewed

- Issue History
Date Modified Username Field Change
2018-03-27 17:36 caristu Type defect => backport
2018-03-27 17:36 caristu Target Version => 3.0PR18Q1.2
2018-03-27 17:37 caristu Target Version 3.0PR18Q1.2 => 3.0PR18Q1.1
2018-03-28 08:34 caristu Issue cloned 0038241
2018-03-28 08:40 caristu Regression level Production - QA Approved => Production - Confirmed Stable
2018-03-28 09:44 hgbot Checkin
2018-03-28 09:44 hgbot Note Added: 0103598
2018-03-28 09:44 hgbot Status scheduled => resolved
2018-03-28 09:44 hgbot Resolution open => fixed
2018-03-28 09:44 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR18Q1.2/rev/21633aa9f482a61e1c83204bbc21839fe97c67d3 [^]
2018-03-28 09:44 caristu Review Assigned To => alostale
2018-03-28 09:44 caristu Target Version 3.0PR18Q1.1 => 3.0PR18Q1.2
2018-03-28 17:24 alostale Note Added: 0103619
2018-03-28 17:24 alostale Status resolved => closed
2018-03-28 17:24 alostale Fixed in Version => 3.0PR18Q1.2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker