Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036876
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Y. DBSourceManagerminorhave not tried2017-09-18 13:232017-09-22 10:10
ReporterinigosanchezView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision978ab9933a04
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036876: Some methods in DBSMOBUtil class are not used anymore.

DescriptionThis issue is related with code clean up task of the DBSM sources. In this case, DBSMOBUtil has 2 methods that should be removed if it is possible. It should be checked. The methods are:
- public void generateIndustryTemplateTree() {
- private void recursiveTemplateLoader(String idDepTemplate) {
* It should be checked other potential candidates related with the issue.

These methods were used before this issue was fixed (0030489), since the fix was introduced into the distribution, this methods seems that are not used anymore.
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0030489 closedinigosanchez configScript(retail.pack) seems not applied when doing install.source 

-  Notes
(0099222)
hgbot (developer)
2017-09-21 16:31

Repository: erp/devel/dbsm-main
Changeset: abe3e5949c243ecdead3b1aa3ecb887ae7222399
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Sep 21 16:11:25 2017 +0200
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/abe3e5949c243ecdead3b1aa3ecb887ae7222399 [^]

Fixed issue 36876: Some methods in DBSMOBUtil class are not used anymore.

It is removed two methods from DBSMOBUtil class:
- The recursiveTemplateLoader method is private and it is not used in the class, so no problem to remove it.
- This fix introduced also an API change because a public method is removed: generateIndustryTemplateTree. This method is not used in our code (Neither pi+all_modules nor dbsm) since this fix was introduced 0030489. Removed it.

---
M src/org/openbravo/ddlutils/util/DBSMOBUtil.java
---
(0099223)
hgbot (developer)
2017-09-21 16:35

Repository: erp/devel/pi
Changeset: 978ab9933a04d8bbd995578e20cc61aa579e1aaf
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Sep 21 16:13:58 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/978ab9933a04d8bbd995578e20cc61aa579e1aaf [^]

Fixed issue 36876: Some methods in DBSMOBUtil class are not used anymore.

It is removed two methods from DBSMOBUtil class:
- The recursiveTemplateLoader method is private and it is not used in the class, so no problem to remove it.
- This fix introduced also an API change because a public method is removed: generateIndustryTemplateTree. This
method is not used in our code (Neither pi+all_modules nor dbsm) since this fix was introduced 0030489. Removed it.

---
M src-db/database/lib/dbsourcemanager.jar
---
(0099452)
hudsonbot (developer)
2017-09-22 03:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/79f756868bba [^]
Maturity status: Test
(0099463)
alostale (developer)
2017-09-22 10:10

reviewed

- Issue History
Date Modified Username Field Change
2017-09-18 13:23 inigosanchez New Issue
2017-09-18 13:23 inigosanchez Assigned To => platform
2017-09-18 13:23 inigosanchez Modules => Core
2017-09-18 13:23 inigosanchez Triggers an Emergency Pack => No
2017-09-18 13:24 inigosanchez Description Updated View Revisions
2017-09-18 13:25 inigosanchez Relationship added related to 0030489
2017-09-21 16:08 inigosanchez Review Assigned To => alostale
2017-09-21 16:08 inigosanchez Assigned To platform => inigosanchez
2017-09-21 16:08 inigosanchez Status new => scheduled
2017-09-21 16:31 hgbot Checkin
2017-09-21 16:31 hgbot Note Added: 0099222
2017-09-21 16:31 hgbot Status scheduled => resolved
2017-09-21 16:31 hgbot Resolution open => fixed
2017-09-21 16:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/dbsm-main/rev/abe3e5949c243ecdead3b1aa3ecb887ae7222399 [^]
2017-09-21 16:35 hgbot Checkin
2017-09-21 16:35 hgbot Note Added: 0099223
2017-09-21 16:35 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/dbsm-main/rev/abe3e5949c243ecdead3b1aa3ecb887ae7222399 [^] => http://code.openbravo.com/erp/devel/pi/rev/978ab9933a04d8bbd995578e20cc61aa579e1aaf [^]
2017-09-22 03:19 hudsonbot Checkin
2017-09-22 03:19 hudsonbot Note Added: 0099452
2017-09-22 10:10 alostale Note Added: 0099463
2017-09-22 10:10 alostale Status resolved => closed
2017-09-22 10:10 alostale Fixed in Version => 3.0PR17Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker