Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030489
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-08-04 10:072017-09-22 10:10
ReportermigueldejuanaView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision3e1419720b7a
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030489: configScript(retail.pack) seems not applied when doing install.source

DescriptionIn an enviroment with Web POS. When I do an install.source and then, I try to export.database, I get this error:

BUILD FAILED
/home/openbravo/workspaces/openbravo/erp/devel/pi/webposPack/build.xml:771: The following error occurred while executing this line:
/home/openbravo/workspaces/openbravo/erp/devel/pi/webposPack/src-db/database/build.xml:157: Reversing the change [AD_TAB.ISACTIVE <N->Y> PK: 800222] in configuration script for template org.openbravo.retail.pack couldn't be applied, and therefore, the export.database couldn't be completed. Fix (or remove) the configuration script, and then try the export again.


But, if I do an install.source and then update.database, I don't get the error.

I saw in the database that after install.source, for PK: 800222, AD_TAB.ISACTIVE was 'N' and after update.database AD_TAB.ISACTIVE was 'Y'.
Steps To Reproduce- Install retail modules
- install.source
- Put Core, mobile.core, retail.posterminal in development
- export.database
ERROR
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00120072.50MP11 closedmarvintm When having several nested Templates, configuration scripts can be executed in wrong order 
has duplicate defect 0028846 closedalostale You can not export database with core in development 
related to defect 0036137 closedinigosanchez [SER-QA 2918] Config script removeCheckChange are not applied on install.source 
related to defect 0036876 closedinigosanchez Some methods in DBSMOBUtil class are not used anymore. 

-  Notes
(0099107)
inigosanchez (developer)
2017-09-18 13:36

When this fix will be introduce into the distribution, some methods should be removed or deprecated in DBSMOBUtil class because it is not used anymore:
- public void generateIndustryTemplateTree() {
- private void recursiveTemplateLoader(String idDepTemplate) {
* It should be checked other potential candidates related with the issue.

One of them are public and for this reason, this issue should be posppone to take into account into the code (DBSM sources) clean up task. See issue 0036876
(0099135)
hgbot (developer)
2017-09-19 10:09

Repository: erp/devel/dbsm-main
Changeset: 8d6dbb0556036d8f6a667a1cf433a309e1536def
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Tue Sep 19 09:50:23 2017 +0200
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/8d6dbb0556036d8f6a667a1cf433a309e1536def [^]

Fixed issue 30489: Templates hierarchy are not applied as expected

The problem was that hierarchy was calculated wrongly when it should be applied the
configScript files. The generateTemplatesTree generate a wrongly list of templates
in terms of sorting. It means that templates were properly located but applied in
the wrong order.

In order to fix this problem, getSortedTemplates method is used to retrieves the
sorted template list. Now, the configScript files are applied properly, it means,
the hierarchy is applied as expected. For example, the changes defined in the
configScript file of the retail pack are applied after the core ones.

---
M src/org/openbravo/ddlutils/task/CreateDatabase.java
---
(0099136)
hgbot (developer)
2017-09-19 10:11

Repository: erp/devel/pi
Changeset: 3e1419720b7af8072a58907bcb588a6bb42a32c9
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Tue Sep 19 10:10:32 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3e1419720b7af8072a58907bcb588a6bb42a32c9 [^]

Fixed issue 30489: Templates hierarchy are not applied as expected

The problem was that hierarchy was calculated wrongly when it should be applied the
configScript files. The generateTemplatesTree generate a wrongly list of templates
in terms of sorting. It means that templates were properly located but applied in
the wrong order.

In order to fix this problem, getSortedTemplates method is used to retrieves the
sorted template list. Now, the configScript files are applied properly, it means,
the hierarchy is applied as expected. For example, the changes defined in the
configScript file of the retail pack are applied after the core ones.

---
M src-db/database/lib/dbsourcemanager.jar
---
(0099414)
hudsonbot (developer)
2017-09-21 16:50

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test
(0099461)
alostale (developer)
2017-09-22 10:10

reviewed + tested

- Issue History
Date Modified Username Field Change
2015-08-04 10:07 migueldejuana New Issue
2015-08-04 10:07 migueldejuana Assigned To => platform
2015-08-04 10:07 migueldejuana Modules => Core
2015-08-04 10:07 migueldejuana Triggers an Emergency Pack => No
2015-08-04 10:22 alostale Relationship added related to 0028846
2015-08-04 10:45 migueldejuana Steps to Reproduce Updated View Revisions
2015-08-04 10:58 alostale Status new => acknowledged
2015-08-04 10:58 alostale Relationship replaced has duplicate 0028846
2017-09-07 12:37 alostale Relationship added related to 0036137
2017-09-18 11:48 inigosanchez Assigned To platform => inigosanchez
2017-09-18 11:48 inigosanchez Status acknowledged => scheduled
2017-09-18 11:48 inigosanchez Relationship added related to 0012007
2017-09-18 13:25 inigosanchez Relationship added related to 0036876
2017-09-18 13:36 inigosanchez Note Added: 0099107
2017-09-19 09:59 inigosanchez Review Assigned To => alostale
2017-09-19 10:09 hgbot Checkin
2017-09-19 10:09 hgbot Note Added: 0099135
2017-09-19 10:09 hgbot Status scheduled => resolved
2017-09-19 10:09 hgbot Resolution open => fixed
2017-09-19 10:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/dbsm-main/rev/8d6dbb0556036d8f6a667a1cf433a309e1536def [^]
2017-09-19 10:11 hgbot Checkin
2017-09-19 10:11 hgbot Note Added: 0099136
2017-09-19 10:11 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/dbsm-main/rev/8d6dbb0556036d8f6a667a1cf433a309e1536def [^] => http://code.openbravo.com/erp/devel/pi/rev/3e1419720b7af8072a58907bcb588a6bb42a32c9 [^]
2017-09-21 16:50 hudsonbot Checkin
2017-09-21 16:50 hudsonbot Note Added: 0099414
2017-09-22 10:10 alostale Note Added: 0099461
2017-09-22 10:10 alostale Status resolved => closed
2017-09-22 10:10 alostale Fixed in Version => 3.0PR17Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker