Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036074
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2017-05-23 16:302017-05-29 17:43
ReporterngarciaView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revision42059137939c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-10-14
Regression introduced in release3.0PR17Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/89f0eb718711 [^]
Triggers an Emergency PackNo
Summary

0036074: inconsistent process (ad_process) configuration generates invalid web.xml

DescriptionHaving defined an inconsistent/incorrect configuration for a process (ad_process) can generate an invalid web.xml which stops Tomcat to be started.

Example of incorrect definition:
  * Report = 'N'
  * UI Pattern = Standard
  * record in AD_MODEL_OBJECT_MAPPING with object_type = 'S'
Steps To ReproduceAs System Admin role:
   1. Set Core In Development
   2. Go to Report and Process Window and select 'Print Requisition' report
   3. Set it as Report = 'N'
   4. Make any change in the Process Class tab and undo it in order the update the updated column (thus the web.xml file will be generated again)
   5. Execute in DB: update ad_model_object set object_type = 'S' where ad_model_object_id = '1004400018'
   6. Compile
   7. Try to restart Tomcat and check the following error is raised:
      Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/openbravo]]
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:162)
    ... 6 more
Caused by: java.lang.IllegalArgumentException: Servlet mapping specifies an unknown servlet name R1004400018
    at org.apache.catalina.core.StandardContext.addServletMapping(StandardContext.java:3425)

      Check in build/javasqlc/src/web.xml file that there is an <servlet-mapping> entry for the 1004400018 ad_model_object but there is not the <servlet-class> entry
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00360793.0PR17Q2.1 closedcaristu inconsistent process (ad_process) configuration generates invalid web.xml 
depends on backport 00360803.0PR17Q1.2 closedalostale inconsistent process (ad_process) configuration generates invalid web.xml 
caused by feature request 00325123.0PR17Q1 closedalostale support WildFly 10 

-  Notes
(0096748)
hgbot (developer)
2017-05-24 10:40

Repository: erp/devel/pi
Changeset: 42059137939cc613bd94145ea7dc8eeb7fa73e55
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed May 24 10:39:33 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/42059137939cc613bd94145ea7dc8eeb7fa73e55 [^]

fixed bug 36074: inconsistent ad_process generates invalid web.xml

  Some invalid defintions of ad_process generated invalid web.xml because mapping
  was included referencing to a class that was filtered out, causing Tomcat to
  refuse to start.

  It has been fixed by adding to the query that retrieves mappings the same restrictions
  already added to the query looking for classes, so mappings will be obtained
  only if class is present.

---
M src-wad/src/org/openbravo/wad/Wad_data.xsql
---
(0096777)
caristu (developer)
2017-05-25 09:56

Code reviewed + testing OK
(0096983)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-05-23 16:30 ngarcia New Issue
2017-05-23 16:30 ngarcia Assigned To => platform
2017-05-23 16:30 ngarcia Modules => Core
2017-05-23 16:30 ngarcia Triggers an Emergency Pack => No
2017-05-23 16:30 ngarcia Issue Monitored: networkb
2017-05-24 10:20 alostale Relationship added caused by 0032512
2017-05-24 10:26 alostale Review Assigned To => caristu
2017-05-24 10:26 alostale Regression level => Production - Confirmed Stable
2017-05-24 10:26 alostale Regression date => 2016-10-14
2017-05-24 10:26 alostale Regression introduced in release => 3.0PR17Q1
2017-05-24 10:26 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/89f0eb718711 [^]
2017-05-24 10:26 alostale Priority urgent => immediate
2017-05-24 10:26 alostale Severity major => minor
2017-05-24 10:26 alostale Summary Cannot start Tomcat if a report is defined with Report = 'N', UI Pattern = Standard and has a record in AD_MODEL_OBJECT_MAPPING => inconsistent process (ad_process) configuration generates invalid web.xml
2017-05-24 10:26 alostale Description Updated View Revisions
2017-05-24 10:26 alostale Steps to Reproduce Updated View Revisions
2017-05-24 10:28 alostale Status new => scheduled
2017-05-24 10:35 alostale Assigned To platform => alostale
2017-05-24 10:40 hgbot Checkin
2017-05-24 10:40 hgbot Note Added: 0096748
2017-05-24 10:40 hgbot Status scheduled => resolved
2017-05-24 10:40 hgbot Resolution open => fixed
2017-05-24 10:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/42059137939cc613bd94145ea7dc8eeb7fa73e55 [^]
2017-05-25 09:56 caristu Note Added: 0096777
2017-05-25 09:56 caristu Status resolved => closed
2017-05-25 09:56 caristu Fixed in Version => 3.0PR17Q3
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096983


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker