Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036079
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2017-05-23 16:302017-06-15 14:29
ReporterngarciaView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2.1
StatusclosedFix in branchFixed in SCM revision977e2c53bf1e
ProjectionnoneETAnoneTarget Version3.0PR17Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-10-14
Regression introduced in release3.0PR17Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/89f0eb718711 [^]
Triggers an Emergency PackNo
Summary

0036079: inconsistent process (ad_process) configuration generates invalid web.xml

DescriptionHaving defined an inconsistent/incorrect configuration for a process (ad_process) can generate an invalid web.xml which stops Tomcat to be started.

Example of incorrect definition:
  * Report = 'N'
  * UI Pattern = Standard
  * record in AD_MODEL_OBJECT_MAPPING with object_type = 'S'
Steps To ReproduceAs System Admin role:
   1. Set Core In Development
   2. Go to Report and Process Window and select 'Print Requisition' report
   3. Set it as Report = 'N'
   4. Make any change in the Process Class tab and undo it in order the update the updated column (thus the web.xml file will be generated again)
   5. Execute in DB: update ad_model_object set object_type = 'S' where ad_model_object_id = '1004400018'
   6. Compile
   7. Try to restart Tomcat and check the following error is raised:
      Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/openbravo]]
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:162)
    ... 6 more
Caused by: java.lang.IllegalArgumentException: Servlet mapping specifies an unknown servlet name R1004400018
    at org.apache.catalina.core.StandardContext.addServletMapping(StandardContext.java:3425)

      Check in build/javasqlc/src/web.xml file that there is an <servlet-mapping> entry for the 1004400018 ad_model_object but there is not the <servlet-class> entry
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0036074 closedalostale inconsistent process (ad_process) configuration generates invalid web.xml 

-  Notes
(0097415)
hgbot (developer)
2017-06-15 11:24

Repository: erp/backports/3.0PR17Q2.1
Changeset: 977e2c53bf1e9c9cb84ed4619934b56cebd46f37
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jun 15 11:24:17 2017 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR17Q2.1/rev/977e2c53bf1e9c9cb84ed4619934b56cebd46f37 [^]

fixed bug 36079: inconsistent ad_process generates invalid web.xml

  Some invalid defintions of ad_process generated invalid web.xml because mapping
  was included referencing to a class that was filtered out, causing Tomcat to
  refuse to start.

  It has been fixed by adding to the query that retrieves mappings the same restrictions
  already added to the query looking for classes, so mappings will be obtained
  only if class is present.

---
M src-wad/src/org/openbravo/wad/Wad_data.xsql
---
(0097421)
AugustoMauch (developer)
2017-06-15 14:29

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2017-05-24 10:28 alostale Type defect => backport
2017-05-24 10:28 alostale Target Version => 3.0PR17Q2
2017-05-24 10:35 alostale Assigned To platform => alostale
2017-05-24 16:14 alostale Target Version 3.0PR17Q2 => 3.0PR17Q2.1
2017-06-15 11:24 hgbot Checkin
2017-06-15 11:24 hgbot Note Added: 0097415
2017-06-15 11:24 hgbot Status scheduled => resolved
2017-06-15 11:24 hgbot Resolution open => fixed
2017-06-15 11:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q2.1/rev/977e2c53bf1e9c9cb84ed4619934b56cebd46f37 [^]
2017-06-15 11:24 caristu Assigned To alostale => caristu
2017-06-15 11:25 caristu Review Assigned To caristu => AugustoMauch
2017-06-15 14:29 AugustoMauch Note Added: 0097421
2017-06-15 14:29 AugustoMauch Status resolved => closed
2017-06-15 14:29 AugustoMauch Fixed in Version => 3.0PR17Q2.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker