Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035772
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2017-04-12 14:042017-05-29 17:43
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revisionda58b93b6302
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2017-03-12
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/9df1ba7871bb [^]
Triggers an Emergency PackNo
Summary

0035772: Orders with Invoice Terms different from Customer Schedule After Delivery cannot be invoiced if the bp has an invoice schedule

DescriptionSales Orders with Invoice Terms different from Customer Schedule After Delivery (Immediate, After Delivery, After Order Delivered) cannot be invoiced if the business partner has an invoice schedule defined and the order does not fill its requirement

The problem is that the order is not returned by the C_INVOICE_CANDIDATE_V view, the following two changes were wrong

AND (o.invoicerule IN ('I', 'O', 'D', 'S'))

OR (si.invoicefrequency IN ('D', 'W', 'T'))
Steps To ReproduceAs group admin role:
   Create a new Invoice Schedule
   Configure it in order a sales order with today's date not to be automatically invoiced. Example being today 12-04-2017
      Day of The Month: 15
      Invoice Cut-Off Day: 13
   Set the Customer Schedule After Delivery Invoice Terms to a customer
   Create a Sales Order to that customer and set its Invoice Terms as Immediate
   Check the order does not appear in the Create Invoices From Orders process
   Create a sales invoice header and check the order is not shown in the Create lines From process
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00357833.0PR17Q2 closedmarkmm82 Orders with Invoice Terms different from Customer Schedule After Delivery cannot be invoiced if the bp has an invoice schedule 
depends on backport 00357843.0PR17Q1.1 closedmarkmm82 Orders with Invoice Terms different from Customer Schedule After Delivery cannot be invoiced if the bp has an invoice schedule 
caused by defect 0035341 closedmcobas Wrong orders shown in "Create Invoices From Orders" window 

-  Notes
(0096034)
markmm82 (developer)
2017-04-12 20:55

Test Plan 1:
As group admin role:
   Go to Invoice Schedule window and create a new one.
    Configure it in order a sales order with today's date not to be automatically invoiced.
      Example being today 12-04-2017
      Invoice Frequency: Weekly
      Day of The Month: Friday (15-04-2017)
      Invoice Cut-Off Day: Thursday (15-04-2017)
   Go to Business Partner window and create a new vendor.
      Name: BBCustomer1
      Business Partner Category: Customer - Tier 1
   Go to Customer tab and define as:
      Price List: Tarifa de ventas
      Payment method: Transferencia
      Financial account: Cuenta de banco
      Invoice Terms: Customer Schedule After Delivery
      Invoice Schedule: Select previously created invoice schedule.
   Go to Location/Address tab and create a new one for Spain.
   Go to Sales Order window and create a new header.
      Business Partner: BBCustomer1
      Invoice Terms: Immediate
   Go to lines tab and add a line with any product.
   Book the Sales order.
   
   Run Create Invoices From Orders process
   Check the order appears in the list.
  
   Create a sales invoice header for previously created BP.
   Run the Create lines From process and check the order is shown there.


Test Plan 2 (Related to issue 35341):
- Create a new Sales Order:
  - Transaction Document: POS Order
  - Business Partner: Alimentos y Supermercados
  - Invoice Terms: Immediate
- Create a new line for the Sales Order (Cerveza ale 0'5L).
- Book the Sales Order.
- Open the new invoice created from the previously created Order.
  - Reactivate the invoice and delete a line.
  - Then complete the invoice.
- Go to the window [Create Invoices From Orders].
  - Notice that the POS Order is not show there.

Test cases related to issue 34205:
Test Plan 3
- Go to F&B International Group Admin.
- Create an Invoice Schedule with name Daily and frequency as Daily.
- For business partner "Hoteles Buenas Noches, S.A.", in Customer Tab using invoice term as "Customer Schedule After Delivery" set Invoice Schedule as Daily.
- Keeping Invoice Schedule as Daily set invoice term as blank.
- Create an Order for business partner "Hoteles Buenas Noches, S.A." with Immediate Invoice Term. Add Line/s to it. Complete it.
- Create a Sales Invoice Header. Using Create Lines From, try to select above order.
- Above order appears in the drop down list.
- Run Create Invoices From Orders process and notice that the Order is show there.

Test Plan 4
- Create a Order for Alimentos y Supermercados, S.A bp, with invoice term 'Do Not Invoice'. Add line and Complete it.
- Create a Shipment for above order. Complete the shipment.
- Create a Sales Invoice Header and using Create Lines From, check Order Combo and previously order does not appear in drop down list.
- Run Create Invoices From Orders process and notice that the Order is not shown there.
- Check Shipment combo, above shipment does not appear in drop down list.

Test Plan 5
- Create Sales Order for Restaurantes Luna Llena, S.A. bp, with Invoice Term as "Do Not Invoice". Add line/s to it. Book it.
- Create a Sales invoice Header, using Create Lines From button process check Order combo.
- Above order does not appear in the list.
- Go to Create Invoices From Order process.
- Try to search above order, it wont appear in the grid.
- Run Create Shipments from Order process, select above Order. Notice a new shipment is created from the order.
- Go to Create Invoices From Order process.
- Try to search above order, it wont appear in the grid.
- Go to Sales Invoice created above, using Create Lines From button process check Order combo.
- Above order does not appear in the list.
- Check Shipment combo, above created shipment does not appear in the list.
(0096163)
hgbot (developer)
2017-04-25 17:35

Repository: erp/devel/pi
Changeset: da58b93b63023423cb40ffe3101732865454f93b
Author: Mark <markmm82 <at> gmail.com>
Date: Wed Apr 12 12:53:42 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/da58b93b63023423cb40ffe3101732865454f93b [^]

Fixes issue 35772: Orders with Invoice Terms different from Customer Schedule
After Delivery cannot be invoiced if the bp has an invoice schedule

Sales Orders with Invoice Terms different from Customer Schedule After Delivery
(Immediate, After Delivery, After Order Delivered) cannot be invoiced if the business
partner has an invoice schedule defined and the order does not fill its requirement

The problem is that the order is not returned by the C_INVOICE_CANDIDATE_V view.
To avoid it was fixed the condition that takes into account the invoice rule of
the order and the sales invoice frequency.

---
M src-db/database/model/views/C_INVOICE_CANDIDATE_V.xml
---
(0096175)
hgbot (developer)
2017-04-25 18:56

Repository: erp/devel/pi
Changeset: 8e0ecc5d2ef50e6271f4cb73885282eee0efc717
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Apr 25 18:26:55 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8e0ecc5d2ef50e6271f4cb73885282eee0efc717 [^]

Related to issue 35772: Fix dbcons failure

---
M src-db/database/model/views/C_INVOICE_CANDIDATE_V.xml
---
(0096177)
aferraz (developer)
2017-04-25 19:00

Code review + Testing OK
(0096907)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test
(0096909)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-04-12 14:04 ngarcia New Issue
2017-04-12 14:04 ngarcia Assigned To => Triage Finance
2017-04-12 14:04 ngarcia Modules => Core
2017-04-12 14:04 ngarcia Triggers an Emergency Pack => No
2017-04-12 14:04 ngarcia Issue Monitored: networkb
2017-04-12 14:04 ngarcia Relationship added caused by 0035341
2017-04-12 14:29 aferraz Assigned To Triage Finance => markmm82
2017-04-12 14:51 heccam Issue Monitored: heccam
2017-04-12 16:37 markmm82 Status new => acknowledged
2017-04-12 18:58 markmm82 Regression level => Production - Confirmed Stable
2017-04-12 18:58 markmm82 Regression date => 2017-12-03
2017-04-12 18:58 markmm82 Regression introduced in release => 3.0PR17Q1
2017-04-12 18:58 markmm82 Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/9df1ba7871bb [^]
2017-04-12 18:59 markmm82 Status acknowledged => scheduled
2017-04-12 20:55 markmm82 Note Added: 0096034
2017-04-24 13:05 aferraz Regression level Production - Confirmed Stable => Production - QA Approved
2017-04-24 13:05 aferraz Regression date 2017-12-03 => 2017-03-12
2017-04-24 13:05 aferraz Regression introduced in release 3.0PR17Q1 => main
2017-04-25 17:35 hgbot Checkin
2017-04-25 17:35 hgbot Note Added: 0096163
2017-04-25 17:35 hgbot Status scheduled => resolved
2017-04-25 17:35 hgbot Resolution open => fixed
2017-04-25 17:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/da58b93b63023423cb40ffe3101732865454f93b [^]
2017-04-25 17:44 aferraz Review Assigned To => aferraz
2017-04-25 17:44 aferraz Note Added: 0096165
2017-04-25 17:44 aferraz Status resolved => closed
2017-04-25 17:44 aferraz Fixed in Version => 3.0PR17Q3
2017-04-25 18:56 hgbot Checkin
2017-04-25 18:56 hgbot Note Added: 0096175
2017-04-25 19:00 aferraz Note Deleted: 0096165
2017-04-25 19:00 aferraz Note Added: 0096177
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096907
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096909


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker