Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035784
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 07. Sales managementmajoralways2017-04-12 14:042017-04-25 19:01
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q1.1
StatusclosedFix in branchFixed in SCM revision46c32862b234
ProjectionnoneETAnoneTarget Version3.0PR17Q1.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-12-03
Regression introduced in release3.0PR17Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/9df1ba7871bb [^]
Triggers an Emergency PackNo
Summary

0035784: Orders with Invoice Terms different from Customer Schedule After Delivery cannot be invoiced if the bp has an invoice schedule

DescriptionSales Orders with Invoice Terms different from Customer Schedule After Delivery (Immediate, After Delivery, After Order Delivered) cannot be invoiced if the business partner has an invoice schedule defined and the order does not fill its requirement

The problem is that the order is not returned by the C_INVOICE_CANDIDATE_V view, the following two changes were wrong

AND (o.invoicerule IN ('I', 'O', 'D', 'S'))

OR (si.invoicefrequency IN ('D', 'W', 'T'))
Steps To ReproduceAs group admin role:
   Create a new Invoice Schedule
   Configure it in order a sales order with today's date not to be automatically invoiced. Example being today 12-04-2017
      Day of The Month: 15
      Invoice Cut-Off Day: 13
   Set the Customer Schedule After Delivery Invoice Terms to a customer
   Create a Sales Order to that customer and set its Invoice Terms as Immediate
   Check the order does not appear in the Create Invoices From Orders process
   Create a sales invoice header and check the order is not shown in the Create lines From process
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0035772 closedmarkmm82 Orders with Invoice Terms different from Customer Schedule After Delivery cannot be invoiced if the bp has an invoice schedule 

-  Notes
(0096166)
hgbot (developer)
2017-04-25 17:44

Repository: erp/backports/3.0PR17Q1.1
Changeset: 46c32862b234e5a9aeb12f6b82388bd9859c00e4
Author: Mark <markmm82 <at> gmail.com>
Date: Wed Apr 12 12:53:42 2017 -0400
URL: http://code.openbravo.com/erp/backports/3.0PR17Q1.1/rev/46c32862b234e5a9aeb12f6b82388bd9859c00e4 [^]

Fixes issue 35784: Orders with Invoice Terms different from Customer Schedule
After Delivery cannot be invoiced if the bp has an invoice schedule

Sales Orders with Invoice Terms different from Customer Schedule After Delivery
(Immediate, After Delivery, After Order Delivered) cannot be invoiced if the business
partner has an invoice schedule defined and the order does not fill its requirement

The problem is that the order is not returned by the C_INVOICE_CANDIDATE_V view.
To avoid it was fixed the condition that takes into account the invoice rule of
the order and the sales invoice frequency.

---
M src-db/database/model/views/C_INVOICE_CANDIDATE_V.xml
---
(0096168)
aferraz (developer)
2017-04-25 17:45

Code review + Testing OK
(0096178)
hgbot (developer)
2017-04-25 19:01

Repository: erp/backports/3.0PR17Q1.1
Changeset: 96d5a6df7326106c9dc8948e63d28c9b85af7704
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Apr 25 18:26:55 2017 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR17Q1.1/rev/96d5a6df7326106c9dc8948e63d28c9b85af7704 [^]

Related to issue 35784: Fix dbcons failure

---
M src-db/database/model/views/C_INVOICE_CANDIDATE_V.xml
---

- Issue History
Date Modified Username Field Change
2017-04-12 18:59 markmm82 Type defect => backport
2017-04-12 18:59 markmm82 Target Version => 3.0PR17Q1.1
2017-04-25 17:44 hgbot Checkin
2017-04-25 17:44 hgbot Note Added: 0096166
2017-04-25 17:44 hgbot Status scheduled => resolved
2017-04-25 17:44 hgbot Resolution open => fixed
2017-04-25 17:44 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q1.1/rev/46c32862b234e5a9aeb12f6b82388bd9859c00e4 [^]
2017-04-25 17:45 aferraz Review Assigned To => aferraz
2017-04-25 17:45 aferraz Note Added: 0096168
2017-04-25 17:45 aferraz Status resolved => closed
2017-04-25 17:45 aferraz Fixed in Version => 3.0PR17Q1.1
2017-04-25 19:01 hgbot Checkin
2017-04-25 19:01 hgbot Note Added: 0096178


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker