Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035341
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2017-02-22 15:522017-03-15 20:22
ReporterJONHMView Statuspublic 
Assigned Tomcobas 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision9df1ba7871bb
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarkmm82
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2016-12-02
Regression introduced in releasemain
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/daca5e5e260e [^]
Triggers an Emergency PackNo
Summary

0035341: Wrong orders shown in "Create Invoices From Orders" window

DescriptionWrong orders shown in "Create Invoices From Orders" window when an order is of type 'POS Order'. Those orders are invoiced by the cashup and must not be returned by this process. Before the update on the view c_invoice_candidate_v those orders were not shown.
Steps To Reproduce1) Create a new Sales Order:
  - Transaction Document: POS Order
  - Business Partner: Alimentos y Supermercados
  - Invoice Terms: Immediate
1.1) Create a new line for the Sales Order (Cerveza ale 0'5L)
1.2) Book the Sales Order

2) Open it's Inovice (Open the 'cerveza ale' record in form mode and select Linked items/Sales Invoice - Lines and open the invoice)
2.1) Reactivate the invoice and delete a line.
2.3) Then complete the invoice (Complete button)

3) Open the window [Create Invoices From Orders]

--> You can see the POS Order there
Proposed SolutionThe part of the c_invoice_candidate_v query
...
AND dt.docbasetype = 'SOO'
       AND ( dt.docsubtypeso <> 'ON'
              OR dt.docsubtypeso <> 'OB'
              OR dt.docsubtypeso <> 'WR' )
...
must be replaced for
...
AND dt.docbasetype = 'SOO'
       AND ( dt.docsubtypeso <> 'ON'
              AND dt.docsubtypeso <> 'OB'
              AND dt.docsubtypeso <> 'WR' )
...
to behave the same as before
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0035393 closedplatform IN clause in view not properly exported using postgresql 
depends on backport 00353713.0PR17Q1 closedcollazoandy4 Wrong orders shown in "Create Invoices From Orders" window 
depends on design defect 0029492 closedalostale Wrong export of a view 
caused by defect 0034205 closedAtulOpenbravo View c_invoice_candidate_v has performance problem when having lots of unpaid invoices 
related to backport 00354673.0PR17Q1 closedalostale Wrong export of a view 
causes defect 0035772 closedmarkmm82 Orders with Invoice Terms different from Customer Schedule After Delivery cannot be invoiced if the bp has an invoice schedule 

-  Notes
(0094638)
vmromanos (developer)
2017-02-27 13:38
edited on: 2017-02-27 13:45

This seems to be a regression. Please create backport for 17Q1 and fill the required fields.

Proposed solution should be:
WHERE o.docstatus IN ('CO','CL','IP') // This should be fixed too
AND dt.docbasetype = 'SOO'
AND dt.docsubtypeso NOT IN ('ON', 'OB', 'WR')

(0094667)
markmm82 (developer)
2017-02-28 20:27

Test plan 1:
- Create a new Sales Order:
  - Transaction Document: POS Order
  - Business Partner: Alimentos y Supermercados
  - Invoice Terms: Immediate
- Create a new line for the Sales Order (Cerveza ale 0'5L).
- Book the Sales Order.
- Open the new invoice created from the previously created Order.
  - Reactivate the invoice and delete a line.
  - Then complete the invoice.
- Go to the window [Create Invoices From Orders].
  - Notice that the POS Order is not show there.

Test cases related to issue 34205:
Test Plan A
- Go to F&B International Group Admin.
- Create a Invoice Schedule with name Daily and frequancy as Daily.
- For business partner "Hoteles Buenas Noches, S.A.", in Customer Tab using invoice term as "Customer Schedule After Delivery" set Invoice Schedule as Daily.
- Keeping Invoice Schedule as Daily set invoice term as blank.
- Create a Order for business partner "Hoteles Buenas Noches, S.A." with Immediate Invoice Term. Add Line/s to it. Complete it.
- Create a Sales Invoice Header. Using Create Lines From, try to select above order.
- Above order appears in the drop down list.

Test Plan B
- Create a Order with invoice term 'Do Not Invoice'. Add line and Complete it.
- Create a Shipment for above order.
- Create a Sales Invoice Header and using Create Lines From, check Shipment Combo.
- Above shipment does not appear in drop down list.

Test Plan C
- Create Sales Order with Invoice Term as "Do Not Invoice". Add line/s to it. Book it.
- Create a Sales invoice Header, using Create Lines From button process check Order combo.
- Above order does not appear in the list.
- Go to Create Invoices From Order process.
- Try to search above order, it wont appear in the grid.
- Create a Shipment for above Order.
- Go to Create Invoices From Order process.
- Try to search above order, it wont appear in the grid.
- Go to Sales Invoice created above, using Create Lines From button process check Order combo.
- Above order does not appear in the list.
- Check Shipment combo, above created shipment does not appear in the list.

Test Plan D
- Create Sales Order's with Invoice Term as "Immediate".
- Go to Create Invoice From Order process.
- Try to search above order, it appears in the grid.
- Create Sales Invoice and Using Create Lines From button process, Check Order Combo.
- Above order appears in the list.

Test Plan E
- Create Sales Order's with Invoice Term as "Customer Schedule After Delivery" or "After Delivery" or "After Order Delivered"
- Create Sales Invoice and Using Create Lines From button process, Check Order Combo.
- Above order does not appears in the list.
- Go to Create Invoices From Orders process.
- Check above order does not appears in the grid.
- Create Shipment for above order.
- Go back to Sales Invoice created and Using Create Lines From button process, Check Order Combo.
- Above order appears in the list.
- Go to Create Invoices From Orders process.
- Check above order appears in the grid.

Test Plan F
- Create a Shipment for any business partner. Add line and process it.
- Create a Invoice Header for same business partner.
- Using Create Lines From button, check Shipment Combo.
- Above Shipment should appear in the list.
(0094961)
hgbot (developer)
2017-03-12 16:58

Repository: erp/devel/pi
Changeset: 9df1ba7871bb6ef8d170452f94134d77edc06ba8
Author: Miguel <martencobasmiguel <at> gmail.com>
Date: Thu Mar 09 14:22:29 2017 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/9df1ba7871bb6ef8d170452f94134d77edc06ba8 [^]

Fixes issue 35341: Wrong orders shown in "Create Invoices From Orders" window

Fixed the C_INVOICE_CANDIDATE_V view, changing the condition to not take into account
the sales orders different than 'ON' AND 'OB' AND 'WR' instead of using an incorrect
OR condition as suggested in the proposed solution.

Also were included some performances in the view replacing OR and AND conditions with they
respectively translations to IN and NOT IN clauses.

---
M src-db/database/model/views/C_INVOICE_CANDIDATE_V.xml
---
(0094963)
markmm82 (developer)
2017-03-12 16:59

Code review + Testing OK
(0095291)
hudsonbot (developer)
2017-03-15 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-02-22 15:52 JONHM New Issue
2017-02-22 15:52 JONHM Assigned To => Triage Finance
2017-02-22 15:52 JONHM Modules => Core
2017-02-22 15:52 JONHM Regression date => 2017-03-12
2017-02-22 15:52 JONHM Triggers an Emergency Pack => No
2017-02-22 16:02 JONHM Regression level => QA functional test
2017-02-22 16:08 JONHM Reproducibility have not tried => always
2017-02-22 16:37 Practics Issue Monitored: Practics
2017-02-22 16:39 heccam Issue Monitored: heccam
2017-02-22 17:18 markmm82 Assigned To Triage Finance => collazoandy4
2017-02-23 10:25 aferraz Relationship added related to 0034205
2017-02-27 12:44 maite Regression level QA functional test =>
2017-02-27 12:44 maite Regression date 2017-03-12 =>
2017-02-27 13:38 vmromanos Note Added: 0094638
2017-02-27 13:45 vmromanos Note Edited: 0094638 View Revisions
2017-02-27 17:18 markmm82 Relationship deleted related to 0034205
2017-02-27 17:18 markmm82 Relationship added caused by 0034205
2017-02-27 17:24 markmm82 Regression date => 2016-12-02
2017-02-27 17:24 markmm82 Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/daca5e5e260e [^]
2017-02-27 19:14 markmm82 Regression level => Pre packaging ( pi )
2017-02-27 19:14 markmm82 Regression introduced in release => pi
2017-02-27 19:15 markmm82 Status new => scheduled
2017-02-28 20:27 markmm82 Note Added: 0094667
2017-03-01 10:28 aferraz Relationship added related to 0035393
2017-03-09 11:29 aferraz Regression level Pre packaging ( pi ) => Packaging and release
2017-03-09 11:29 aferraz Regression introduced in release pi => main
2017-03-09 12:34 vmromanos Relationship added depends on 0029492
2017-03-09 12:53 alostale Relationship added related to 0035467
2017-03-12 16:39 markmm82 Assigned To collazoandy4 => mcobas
2017-03-12 16:58 hgbot Checkin
2017-03-12 16:58 hgbot Note Added: 0094961
2017-03-12 16:58 hgbot Status scheduled => resolved
2017-03-12 16:58 hgbot Resolution open => fixed
2017-03-12 16:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9df1ba7871bb6ef8d170452f94134d77edc06ba8 [^]
2017-03-12 16:59 markmm82 Review Assigned To => markmm82
2017-03-12 16:59 markmm82 Note Added: 0094963
2017-03-12 16:59 markmm82 Status resolved => closed
2017-03-12 16:59 markmm82 Fixed in Version => 3.0PR17Q2
2017-03-15 20:22 hudsonbot Checkin
2017-03-15 20:22 hudsonbot Note Added: 0095291
2017-04-12 14:04 ngarcia Relationship added causes 0035772


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker