Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035313
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2017-02-20 18:402017-03-15 20:19
ReportermalsasuaView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision24eba52754e3
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-04-18
Regression introduced in release3.0PR16Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/82f27ac1b1497b3a82646b140ab1b6e048f2b766 [^]
Triggers an Emergency PackNo
Summary

0035313: invoice PDF is not attached from "email" button in sales invoice window

Descriptionin sales invoice window, it is possible to send one email with the PDF invoice, clicking in "email" button (in toolbar).

From 16Q3, the email is sent, but the PDF is not attached
Steps To Reproducein "Client" window, "Email Configuration" tab, configure it
in Sales Invoice window, select one record, and click in "email" button. Click in option "Archive" (see attachment)
send email

the email is sent, but PDF is not attached to the email
TagsNo tags attached.
Attached Filespng file icon email.png [^] (325,747 bytes) 2017-02-20 18:41

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00353173.0PR16Q3.6 closedcaristu invoice PDF is not attached from "email" button in sales invoice window 
depends on backport 00353183.0PR17Q1 closedcaristu invoice PDF is not attached from "email" button in sales invoice window 
depends on backport 00353193.0PR16Q4.3 closedcaristu invoice PDF is not attached from "email" button in sales invoice window 
caused by feature request 0029771 closednaiaramartinez different attachment method infrastructure 
has duplicate defect 0035332 closedplatform Process send documents by email only send attachments if 'Archive' checkbox is not checked 
related to defect 0035356 closedcaristu print & attach doc logs error using (old) commons jdbc pool 

-  Notes
(0094508)
hgbot (developer)
2017-02-21 13:40

Repository: erp/devel/pi
Changeset: 24eba52754e38628d78c943c3b8892acdb0c6462
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Feb 21 13:39:12 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/24eba52754e38628d78c943c3b8892acdb0c6462 [^]

fixes issue 35313: documents were not being attached after send them by e-mail

The CoreAttachImplementation class is deleting the original report file after completing the upload process. When attaching a document using the e-mail pop-up this is done before attaching the document into the e-mail. This explains why the document was not being received on the e-mail.

To avoid this problem, now a copy of the original document is sent to the AttachImplementationManager, this way the original file will never be deleted by an upload process handler.

Together with this, now when attaching a document after printing (not by e-mail) we have to delete the original file because in other case it will be kept on disk.

---
M src/org/openbravo/erpCommon/utility/reporting/ReportManager.java
M src/org/openbravo/erpCommon/utility/reporting/printing/PrintController.java
---
(0094598)
alostale (developer)
2017-02-24 09:56

code reviewed + tested
(0094603)
caristu (developer)
2017-02-24 10:11

Added test case into TestLink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10557 [^]
(0095200)
hudsonbot (developer)
2017-03-15 20:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-02-20 18:40 malsasua New Issue
2017-02-20 18:40 malsasua Assigned To => platform
2017-02-20 18:40 malsasua Modules => Core
2017-02-20 18:40 malsasua Regression level => Production - Confirmed Stable
2017-02-20 18:40 malsasua Triggers an Emergency Pack => No
2017-02-20 18:41 malsasua File Added: email.png
2017-02-21 09:33 caristu Regression date => 2016-04-18
2017-02-21 09:33 caristu Regression introduced in release => 3.0PR16Q3
2017-02-21 09:33 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/82f27ac1b1497b3a82646b140ab1b6e048f2b766 [^]
2017-02-21 09:34 caristu Status new => scheduled
2017-02-21 09:38 caristu Steps to Reproduce Updated View Revisions
2017-02-21 09:38 caristu Relationship added caused by 0029771
2017-02-21 13:39 caristu Assigned To platform => caristu
2017-02-21 13:40 hgbot Checkin
2017-02-21 13:40 hgbot Note Added: 0094508
2017-02-21 13:40 hgbot Status scheduled => resolved
2017-02-21 13:40 hgbot Resolution open => fixed
2017-02-21 13:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/24eba52754e38628d78c943c3b8892acdb0c6462 [^]
2017-02-21 16:00 caristu Review Assigned To => alostale
2017-02-21 19:32 caristu Relationship added has duplicate 0035332
2017-02-24 09:56 alostale Note Added: 0094598
2017-02-24 09:56 alostale Status resolved => closed
2017-02-24 09:56 alostale Fixed in Version => 3.0PR17Q2
2017-02-24 10:11 caristu Note Added: 0094603
2017-02-24 10:30 alostale Relationship added related to 0035356
2017-03-15 20:19 hudsonbot Checkin
2017-03-15 20:19 hudsonbot Note Added: 0095200


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker