Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035319
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2017-02-20 18:402017-02-24 09:58
ReportermalsasuaView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q4.3
StatusclosedFix in branchFixed in SCM revision2808d4063ad6
ProjectionnoneETAnoneTarget Version3.0PR16Q4.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-04-18
Regression introduced in release3.0PR16Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/82f27ac1b1497b3a82646b140ab1b6e048f2b766 [^]
Triggers an Emergency PackNo
Summary

0035319: invoice PDF is not attached from "email" button in sales invoice window

Descriptionin sales invoice window, it is possible to send one email with the PDF invoice, clicking in "email" button (in toolbar).

From 16Q3, the email is sent, but the PDF is not attached
Steps To Reproducein "Client" window, "Email Configuration" tab, configure it
in Sales Invoice window, select one record, and click in "email" button. Click in option "attached document" (see attachment)
sent email

the email is sent, but PDF is not attached to the email
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0035313 closedcaristu invoice PDF is not attached from "email" button in sales invoice window 

-  Notes
(0094513)
hgbot (developer)
2017-02-21 14:13

Repository: erp/backports/3.0PR16Q4.3
Changeset: 2808d4063ad656f223cf261900a27eaed1d9bd34
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Feb 21 14:12:18 2017 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR16Q4.3/rev/2808d4063ad656f223cf261900a27eaed1d9bd34 [^]

fixes issue 35319: documents were not being attached after send them by e-mail

The CoreAttachImplementation class is deleting the original report file after completing the upload process. When attaching a document using the e-mail pop-up this is done before attaching the document into the e-mail. This explains why the document was not being received on the e-mail.

To avoid this problem, now a copy of the original document is sent to the AttachImplementationManager, this way the original file will never be deleted by an upload process handler.

Together with this, now when attaching a document after printing (not by e-mail) we have to delete the original file because in other case it will be kept on disk.

---
M src/org/openbravo/erpCommon/utility/reporting/ReportManager.java
M src/org/openbravo/erpCommon/utility/reporting/printing/PrintController.java
---
(0094600)
alostale (developer)
2017-02-24 09:58

code reviewed + tested

- Issue History
Date Modified Username Field Change
2017-02-21 09:34 caristu Type defect => backport
2017-02-21 09:34 caristu Target Version => 3.0PR16Q4.5
2017-02-21 14:13 hgbot Checkin
2017-02-21 14:13 hgbot Note Added: 0094513
2017-02-21 14:13 hgbot Status scheduled => resolved
2017-02-21 14:13 hgbot Resolution open => fixed
2017-02-21 14:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q4.3/rev/2808d4063ad656f223cf261900a27eaed1d9bd34 [^]
2017-02-21 14:13 caristu Target Version 3.0PR16Q4.5 => 3.0PR16Q4.3
2017-02-21 16:03 caristu Review Assigned To => alostale
2017-02-21 16:04 caristu Assigned To platform => caristu
2017-02-24 09:58 alostale Note Added: 0094600
2017-02-24 09:58 alostale Status resolved => closed
2017-02-24 09:58 alostale Fixed in Version => 3.0PR16Q4.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker