Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035136
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2017-02-02 11:292018-01-03 12:38
ReporterngarciaView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision24a9c90c9189
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035136: Line seems to be saved with error when editing and saving the header

DescriptionLine seems to be saved with error when editing and saving the header
Steps To ReproduceAs group admin role:
   Create a Sales Order
   Add a product with stock to it
   Book it
   Create a goods shipment
   Select the previously created order line in the Create Lines From process
   Increase the Movement Quantity in form view
   Check the following error message is shown
      Saving failed. Movement Quantity is greater than the Ordered Quantity
   Increase the Movement Quantity in grid view
   Check the following error message is shown
      One or more rows could not be saved. Fix the problem or cancel all pending changes to return to the last saved state.
   Go to header, edit the Description and save it
   The error message is removed from the line and it seems to be saved
   Complete the shipment and check the movement quantity remains modified
   Cancel changes and check the first value is shown in the movement quantity field
TagsNo tags attached.
Attached Filesdiff file icon issue35136.diff [^] (1,880 bytes) 2017-09-28 10:06 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0036970 closedcaristu Focus placed at wrong place when editing with errors and saving the parent record 

-  Notes
(0099731)
hgbot (developer)
2017-10-03 16:51

Repository: erp/devel/pi
Changeset: 24a9c90c9189579484d0f1f25406b7dbb3c174b8
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Sep 28 09:47:25 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/24a9c90c9189579484d0f1f25406b7dbb3c174b8 [^]

fixes bug 35136: Line seems to be saved with error after saving the header

  When saving a record, the content of its child tabs is automatically refreshed. In case we leave a child record in error status and then we edit and save its parent record, the content of the child record is automatically refreshed with the server data and the error state in the UI disappears, nevertheless, the problem was that the edits was not being discarded properly causing the record to show outdated information.

  Now when the tab is refreshed if it contains records with errors, then the edits are discarded allowing to show the real contents of the records.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0099821)
alostale (developer)
2017-10-09 10:07

reviewed + tested
(0101313)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-02-02 11:29 ngarcia New Issue
2017-02-02 11:29 ngarcia Assigned To => platform
2017-02-02 11:29 ngarcia Modules => Core
2017-02-02 11:29 ngarcia Triggers an Emergency Pack => No
2017-02-10 09:13 alostale Priority high => urgent
2017-02-10 09:13 alostale Status new => acknowledged
2017-09-27 12:37 caristu Assigned To platform => caristu
2017-09-27 12:37 caristu Status acknowledged => scheduled
2017-09-28 10:06 caristu File Added: issue35136.diff
2017-09-28 13:02 caristu Relationship added related to 0036970
2017-10-03 16:51 hgbot Checkin
2017-10-03 16:51 hgbot Note Added: 0099731
2017-10-03 16:51 hgbot Status scheduled => resolved
2017-10-03 16:51 hgbot Resolution open => fixed
2017-10-03 16:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/24a9c90c9189579484d0f1f25406b7dbb3c174b8 [^]
2017-10-03 16:52 caristu Review Assigned To => alostale
2017-10-09 10:07 alostale Note Added: 0099821
2017-10-09 10:07 alostale Status resolved => closed
2017-10-09 10:07 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101313


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker