Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036970
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2017-09-28 13:012018-01-03 12:38
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision4fc9045d89db
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036970: Focus placed at wrong place when editing with errors and saving the parent record

DescriptionWhen editing a child record in grid view and leaving it with errors to do changes in the parent record, it leaves to an inconsistent state because the focus is placed at the parent record but still the active view still is child view.
Steps To ReproduceAs group admin role:
1) Create a Sales Order
2) Add a product with stock to it
3) Book it
   
4) Create a goods shipment
5) Select the previously created order line in the Create Lines From process
6) Open the header in form view
7) Move to the lines tab

8A)Increase the Movement Quantity in form view
   Without saving, click in the Description field at the header
   Check the following error message is shown
      Saving failed. Movement Quantity is greater than the Ordered Quantity
      Notice that the active view is the Lines tab. The focus is placed in the Lines tab form --> OK
   
8B) Increase the Movement Quantity in grid view
   Without saving, click in the Description field at the header
   Check the following error message is shown
      One or more rows could not be saved. Fix the problem or cancel all pending changes to return to the last saved state.
   Notice that the active view is the Lines tab. The focus is placed at the header --> ERROR
TagsNo tags attached.
Attached Filesdiff file icon issue36970.diff [^] (2,805 bytes) 2017-09-28 13:46 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0035136 closedcaristu Line seems to be saved with error when editing and saving the header 

-  Notes
(0099732)
hgbot (developer)
2017-10-03 17:10

Repository: erp/devel/pi
Changeset: 4fc9045d89dbb16a1f860c380b51f14e769f9f33
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Sep 28 13:19:06 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4fc9045d89dbb16a1f860c380b51f14e769f9f33 [^]

fixes bug 36970: Return focus to the record if failed to be edited in grid view

  When a record failed to be edited in grid view right after moving to the form view of its parent record, the window ended in an inconsitent state:
    - The focus was placed at the header
    - The active view still was the child tab

  This was not happening when editing the child record in form view, because the focus was always returned to the form. To fix the problem now the same behavior has been implemented in grid view: in the described scenario the focus is returned to the edit form of the grid.

  Besides, the "editRow" and "editSession" variables were unused in the editFailed() function. Thus, both have been removed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0099820)
alostale (developer)
2017-10-09 10:04

reviewed + tested
(0101314)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-09-28 13:01 caristu New Issue
2017-09-28 13:01 caristu Assigned To => caristu
2017-09-28 13:01 caristu Modules => Core
2017-09-28 13:01 caristu Triggers an Emergency Pack => No
2017-09-28 13:01 caristu Status new => scheduled
2017-09-28 13:02 caristu Steps to Reproduce Updated View Revisions
2017-09-28 13:02 caristu Steps to Reproduce Updated View Revisions
2017-09-28 13:02 caristu Relationship added related to 0035136
2017-09-28 13:03 caristu Summary Focus placed at wrong place when editing with errors and saving the header => Focus placed at wrong place when editing with errors and saving the parent record
2017-09-28 13:43 caristu File Added: issue36970.diff
2017-09-28 13:45 caristu File Deleted: issue36970.diff
2017-09-28 13:45 caristu File Added: issue36970.diff
2017-09-28 13:46 caristu File Deleted: issue36970.diff
2017-09-28 13:46 caristu File Added: issue36970.diff
2017-10-03 17:10 hgbot Checkin
2017-10-03 17:10 hgbot Note Added: 0099732
2017-10-03 17:10 hgbot Status scheduled => resolved
2017-10-03 17:10 hgbot Resolution open => fixed
2017-10-03 17:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4fc9045d89dbb16a1f860c380b51f14e769f9f33 [^]
2017-10-03 17:10 caristu Review Assigned To => alostale
2017-10-09 10:04 alostale Note Added: 0099820
2017-10-09 10:04 alostale Status resolved => closed
2017-10-09 10:04 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101314


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker