Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034485
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-11-14 12:062016-12-16 18:38
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q1
StatusclosedFix in branchFixed in SCM revisionb728814d55b8
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-03-18
Regression introduced in release3.0PR16Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/a160b826335735b762cb0a8cbfb81c40a71383fe [^]
Triggers an Emergency PackNo
Summary

0034485: Record marked as changed after clicking on the print button in grid view

DescriptionRecord marked as changed after clicking on the print button in grid view.

With the fix for issue 0032491, it was prevented to refresh the whole grid by refreshing just the current printed record.

This way of refreshing causes that the form is detecting changes on its values.
Steps To Reproduce1) Go to the [Sales Invoice] window.
2) In grid view, select an existing record.
2) Click on the print button
3) Open the record in form view, notice that the form is opened as if there were changes present.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00345583.0PR16Q4 closedcaristu Record marked as changed after clicking on the print button in grid view 
depends on backport 00345593.0PR16Q3.4 closedcaristu Record marked as changed after clicking on the print button in grid view 
depends on backport 00345603.0PR16Q2.5 closedcaristu Record marked as changed after clicking on the print button in grid view 
caused by defect 00324913.0PR16Q2 closedalostale Lines information lost after printing record in Sales Order with filter applied 

-  Notes
(0091618)
hgbot (developer)
2016-11-17 09:27

Repository: erp/devel/pi
Changeset: dcce34325eae2e9956ad97f6dd8eedce0bdf574e
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Nov 17 09:26:43 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/dcce34325eae2e9956ad97f6dd8eedce0bdf574e [^]

related to issue 34485: clean up unused variable

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0091642)
hgbot (developer)
2016-11-18 08:24

Repository: erp/devel/pi
Changeset: b728814d55b8d7883d0f28b6281b3920449e31a5
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Nov 18 08:22:42 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b728814d55b8d7883d0f28b6281b3920449e31a5 [^]

fixes issue 34485: Record marked as changed after printing in grid view

After printing, just the selected record is refreshed with the refreshCurrentRecord function. The problem was caused because that function was retrieving all the properties instead of just the required grid properties. Eventually, this was causing that some extra fields where being compared when opening the form (in recordHasActualChanges function) causing a wrong detection of changes.

To solve the problem now, when refreshCurrentRecord function is executed in grid view, it retrieves just the grid selected properties. Note that this is the behavior when refreshing the whole grid.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0091807)
alostale (developer)
2016-11-25 09:25

code reviewed + tested
(0092638)
hudsonbot (developer)
2016-12-16 18:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/dc8bf00badd0 [^]
Maturity status: Test
(0092642)
hudsonbot (developer)
2016-12-16 18:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/dc8bf00badd0 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-11-14 12:06 caristu New Issue
2016-11-14 12:06 caristu Assigned To => platform
2016-11-14 12:06 caristu Modules => Core
2016-11-14 12:06 caristu Triggers an Emergency Pack => No
2016-11-14 12:06 caristu Priority high => immediate
2016-11-14 12:06 caristu Relationship added caused by 0032491
2016-11-14 12:08 caristu Regression level => Production - Confirmed Stable
2016-11-14 12:08 caristu Regression date => 2016-03-18
2016-11-14 12:08 caristu Regression introduced in release => 3.0PR16Q2
2016-11-14 12:08 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/a160b826335735b762cb0a8cbfb81c40a71383fe [^]
2016-11-15 18:28 caristu Assigned To platform => caristu
2016-11-17 09:27 hgbot Checkin
2016-11-17 09:27 hgbot Note Added: 0091618
2016-11-17 13:29 caristu Status new => scheduled
2016-11-18 08:24 hgbot Checkin
2016-11-18 08:24 hgbot Note Added: 0091642
2016-11-18 08:24 hgbot Status scheduled => resolved
2016-11-18 08:24 hgbot Resolution open => fixed
2016-11-18 08:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b728814d55b8d7883d0f28b6281b3920449e31a5 [^]
2016-11-18 08:30 caristu Review Assigned To => alostale
2016-11-18 08:54 caristu Description Updated View Revisions
2016-11-25 09:25 alostale Note Added: 0091807
2016-11-25 09:25 alostale Status resolved => closed
2016-11-25 09:25 alostale Fixed in Version => 3.0PR17Q1
2016-12-16 18:38 hudsonbot Checkin
2016-12-16 18:38 hudsonbot Note Added: 0092638
2016-12-16 18:38 hudsonbot Checkin
2016-12-16 18:38 hudsonbot Note Added: 0092642


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker