Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032491
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajoralways2016-03-16 11:212016-03-21 14:02
ReporterJONHMView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revisiona160b8263357
ProjectionnoneETAnoneTarget Version3.0PR16Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032491: Lines information lost after printing record in Sales Order with filter applied

DescriptionLines information lost after printing record in Sales Order while grid filtering critery is not matched
Steps To Reproduce1) Access Sales Order window and apply filter Organization to "F&B España - Región Sur"
2) Create a new record in form view having organization "F&B España - Región Norte" and create some product line
3) Click the print record button and choose the "No, Just Print It" button

Result: Previous filter have been applied and it shows only the sales order record in form mode but not the lines.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0032508 acknowledgedplatform Attachments counter is not refreshed the first time a record is printed and attached 
causes defect 0034485 closedcaristu Record marked as changed after clicking on the print button in grid view 

-  Notes
(0085221)
hgbot (developer)
2016-03-18 11:10

Repository: erp/devel/pi
Changeset: a160b826335735b762cb0a8cbfb81c40a71383fe
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Mar 18 11:09:24 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a160b826335735b762cb0a8cbfb81c40a71383fe [^]

fixed bug 32491: lines removed after printing header with a non-matching filter

  After printing a document that does not match grid's current filter, its lines
  were removed from grid.

  After printing a refresh is done, the problem is the refresh was done not for
  the current printed record but for the whole grid, being discarded current if
  not matching filter crieria.

  Now in case a single record is selected, it is refreshed only this one regardless
  applied filtering criteria.

---
M src/org/openbravo/erpCommon/utility/reporting/printing/PrintOptions.html
---
(0085223)
caristu (developer)
2016-03-18 13:24

Code review + testing OK.

The created record is not lost when switching between grid/form view after printing it.
Working fine also having 'Attach by Default' and 'Direct Print' preferences.
(0085249)
hudsonbot (developer)
2016-03-21 14:02

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ee80ac4a1a50 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-03-16 11:21 JONHM New Issue
2016-03-16 11:21 JONHM Assigned To => platform
2016-03-16 11:21 JONHM Modules => Core
2016-03-16 11:21 JONHM Triggers an Emergency Pack => No
2016-03-18 10:34 alostale Assigned To platform => alostale
2016-03-18 10:35 alostale Review Assigned To => caristu
2016-03-18 11:10 hgbot Checkin
2016-03-18 11:10 hgbot Note Added: 0085221
2016-03-18 11:10 hgbot Status new => resolved
2016-03-18 11:10 hgbot Resolution open => fixed
2016-03-18 11:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a160b826335735b762cb0a8cbfb81c40a71383fe [^]
2016-03-18 13:24 caristu Note Added: 0085223
2016-03-18 13:24 caristu Status resolved => closed
2016-03-18 13:24 caristu Fixed in Version => 3.0PR16Q2
2016-03-18 13:38 caristu Relationship added related to 0032508
2016-03-21 14:02 hudsonbot Checkin
2016-03-21 14:02 hudsonbot Note Added: 0085249
2016-11-14 12:06 caristu Relationship added causes 0034485


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker