Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033482
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminorhave not tried2016-07-14 10:102016-07-22 11:33
ReporteralostaleView Statuspublic 
Assigned ToNaroaIriarte 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revisiona9de7947f68d
ProjectionnoneETAnoneTarget Version3.0PR16Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2016-04-13
Regression introduced in releasemain
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/4bc26a30e2966fc212fa9b336a9e36f4e1a042c6 [^]
Triggers an Emergency PackNo
Summary

0033482: implicit filters not applied in updated instances with grid configuration

DescriptionInstances updated from a previous release that had "Grid Configuration" preferences with transactional filters applied, do not apply transactional filters when fetching data though in the UI the message informing the transactional filter is applied is seen.

The problem is caused because old grid configuration saved in their state whereClause as string and now the code expects it to be a boolean

filterClause:\" ( e.updated > @transactionalRange@ or e.processed = 'N' ) \"
Steps To Reproduce1. Install a fresh Openbravo in PR16Q2
2. Activate this instance
3. Open Sales Order window
4. Change grid layout: ie. sort by Document Number
5. Check in Preferences window there is a "Grid Configuration" preference for this window.
6. Update to PR16Q3
7. Open sales order window
  * Transactional implicit filter message appears as applied in UI -> OK
  * The request to populate the datasource has the isImplicitFilterApplied set to false, which causes the grid not to be filtered -> ERROR


== Alternativelly ==

1. In a pi professional instance, emulate steps 1 to 6 by:
1.1 Create a new preference
   - Property: Grid Configuration
   - Visibility: Current session settings
   - Value: http://pastebin.com/RqA6e3Dc [^]
1.2 Relogin
2. Issue explained in step 7 can be reproduced
Proposed SolutionBe consistent both when displaying message and applying filtering on how it is determined whether the filter clause is applied.

When setting grid configuration detect this case, and set filterClause as true in case it was not null/empty string.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0033478 closedNaroaIriarte implicit filters not applied in updated instances with grid configuration 

-  Notes
(0088570)
hgbot (developer)
2016-07-19 09:09

Repository: erp/backports/3.0PR16Q3
Changeset: a9de7947f68df317890a38f0686ae421bf8b7254
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Fri Jul 15 23:25:35 2016 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR16Q3/rev/a9de7947f68df317890a38f0686ae421bf8b7254 [^]

Fixed issue 33482: Implicit filters were not working fine on updated instances

When a grid configuration was done in one instance and after that the instance was updated, the implicit filters were not working fine. The blue popup expressing that a filter is applied appeared but there was no filter applied.
The problem was in the isFilterClauseApplied function of ob-grid.js. There only was taking into account boolean values. Now, it takes into account any value.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
---
(0088631)
alostale (developer)
2016-07-22 11:33

code reviewed + tested

- Issue History
Date Modified Username Field Change
2016-07-14 12:53 alostale Type defect => backport
2016-07-14 12:53 alostale Target Version => 3.0PR16Q3
2016-07-19 09:02 NaroaIriarte Review Assigned To => alostale
2016-07-19 09:09 hgbot Checkin
2016-07-19 09:09 hgbot Note Added: 0088570
2016-07-19 09:09 hgbot Status scheduled => resolved
2016-07-19 09:09 hgbot Resolution open => fixed
2016-07-19 09:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q3/rev/a9de7947f68df317890a38f0686ae421bf8b7254 [^]
2016-07-22 11:33 alostale Note Added: 0088631
2016-07-22 11:33 alostale Status resolved => closed
2016-07-22 11:33 alostale Fixed in Version => 3.0PR16Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker