Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033478
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2016-07-14 10:102016-08-11 18:40
ReporteralostaleView Statuspublic 
Assigned ToNaroaIriarte 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q4
StatusclosedFix in branchFixed in SCM revisionfcfdf220cf0e
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2016-04-13
Regression introduced in releasemain
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/4bc26a30e2966fc212fa9b336a9e36f4e1a042c6 [^]
Triggers an Emergency PackNo
Summary

0033478: implicit filters not applied in updated instances with grid configuration

DescriptionInstances updated from a previous release that had "Grid Configuration" preferences with transactional filters applied, do not apply transactional filters when fetching data though in the UI the message informing the transactional filter is applied is seen.

The problem is caused because old grid configuration saved in their state whereClause as string and now the code expects it to be a boolean

filterClause:\" ( e.updated > @transactionalRange@ or e.processed = 'N' ) \"
Steps To Reproduce1. Install a fresh Openbravo in PR16Q2
2. Activate this instance
3. Open Sales Order window
4. Change grid layout: ie. sort by Document Number
5. Check in Preferences window there is a "Grid Configuration" preference for this window.
6. Update to PR16Q3
7. Open sales order window
  * Transactional implicit filter message appears as applied in UI -> OK
  * The request to populate the datasource has the isImplicitFilterApplied set to false, which causes the grid not to be filtered -> ERROR


== Alternativelly ==

1. In a pi professional instance, emulate steps 1 to 6 by:
1.1 Create a new preference
   - Property: Grid Configuration
   - Visibility: Current session settings
   - Value: http://pastebin.com/raw/RqA6e3Dc [^]
1.2 Relogin
2. Issue explained in step 7 can be reproduced
Proposed SolutionBe consistent both when displaying message and applying filtering on how it is determined whether the filter clause is applied.

When setting grid configuration detect this case, and set filterClause as true in case it was not null/empty string.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00334823.0PR16Q3 closedNaroaIriarte implicit filters not applied in updated instances with grid configuration 
caused by feature request 00326103.0PR16Q3 closedNaroaIriarte standard datasources shouldn't accept where parameter by default 

-  Notes
(0088569)
hgbot (developer)
2016-07-19 09:09

Repository: erp/devel/pi
Changeset: fcfdf220cf0ee14e5b670fd60435be7c92189e3d
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Fri Jul 15 08:49:04 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/fcfdf220cf0ee14e5b670fd60435be7c92189e3d [^]

Fixed issue 33478: Implicit filters were not working fine on updated instances

When a grid configuration was done in one instance and after that the instance was updated, the implicit filters were not working fine. The blue popup expressing that a filter is applied appeared but there was no filter applied.
The problem was in the isFilterClauseApplied function of ob-grid.js. There only was taking into account boolean values. Now, it takes into account any value.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
---
(0088629)
alostale (developer)
2016-07-22 11:33

code reviewed + tested
(0089021)
hudsonbot (developer)
2016-08-11 18:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/edaa05b1fb18 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-07-14 10:10 alostale New Issue
2016-07-14 10:10 alostale Assigned To => platform
2016-07-14 10:10 alostale Modules => Core
2016-07-14 10:10 alostale Triggers an Emergency Pack => No
2016-07-14 10:10 alostale Relationship added caused by 0032610
2016-07-14 10:12 alostale Regression level => Packaging and release
2016-07-14 10:12 alostale Regression date => 2016-04-13
2016-07-14 10:12 alostale Regression introduced in release => main
2016-07-14 10:12 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/4bc26a30e2966fc212fa9b336a9e36f4e1a042c6 [^]
2016-07-14 10:12 alostale Assigned To platform => NaroaIriarte
2016-07-14 10:13 alostale Status new => scheduled
2016-07-14 12:34 alostale Status scheduled => acknowledged
2016-07-14 12:40 alostale Summary transactional filters not applied in some cases => transactional filters not applied in updated instances with grid configuration
2016-07-14 12:40 alostale Description Updated View Revisions
2016-07-14 12:40 alostale Steps to Reproduce Updated View Revisions
2016-07-14 12:52 alostale Summary transactional filters not applied in updated instances with grid configuration => implicit filters not applied in updated instances with grid configuration
2016-07-14 12:52 alostale Description Updated View Revisions
2016-07-14 12:52 alostale Steps to Reproduce Updated View Revisions
2016-07-14 12:52 alostale Proposed Solution updated
2016-07-14 12:53 alostale Status acknowledged => scheduled
2016-07-14 12:54 alostale Steps to Reproduce Updated View Revisions
2016-07-19 09:02 NaroaIriarte Review Assigned To => alostale
2016-07-19 09:09 hgbot Checkin
2016-07-19 09:09 hgbot Note Added: 0088569
2016-07-19 09:09 hgbot Status scheduled => resolved
2016-07-19 09:09 hgbot Resolution open => fixed
2016-07-19 09:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/fcfdf220cf0ee14e5b670fd60435be7c92189e3d [^]
2016-07-22 11:33 alostale Note Added: 0088629
2016-07-22 11:33 alostale Status resolved => closed
2016-07-22 11:33 alostale Fixed in Version => 3.0PR16Q4
2016-08-11 18:40 hudsonbot Checkin
2016-08-11 18:40 hudsonbot Note Added: 0089021


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker