Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033288
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersminoralways2016-06-16 12:212016-06-22 23:13
ReportermaiteView Statuspublic 
Assigned Tomarkmm82 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revisiona745d6a99abb
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression levelProduction - Confirmed Stable
Regression date2015-05-29
Regression introduced in release3.0PR15Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/15dbf5983411 [^]
Triggers an Emergency PackNo
Summary

0033288: Linked items error in Payment Plan window when invoice is not paid

DescriptionWhen invoice is unpaid no records should appear in linked items section
Steps To Reproduce1. Access Sales Invoice window and filter by "Payment Complete"=No
2. Go to Payment Plan tab and open "Linked Items" section
3. Realize that 2 items are shown when does not exist any related payment document

Problem seems to be that HQL Where clause defined for Lines tab in Payment window is not executed from Linked Items.
Proposed SolutionTo define SQL Where Clause for Lines tab in Payment In and Payment Out window
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00333093.0PR16Q2.1 closedmarkmm82 Linked items error in Payment Plan window when invoice is not paid 
depends on backport 00333103.0PR16Q1.4 closedmarkmm82 Linked items error in Payment Plan window when invoice is not paid 
caused by design defect 0025355 closedfsoto82 Long time to show the lines on the payment in/out windows 
related to design defect 0033305 newplatform Linked Items do not take into account HQL where clause 

-  Notes
(0087682)
markmm82 (developer)
2016-06-20 16:25
edited on: 2016-06-20 16:56

Test Plan:
    1. Access Sales Invoice window and filter by "Payment Complete"=No
    2. Select any invoice.
    3. Go to Payment Plan tab and open "Linked Items" section
    3. Realize that no items are shown. It is correct!

(0087707)
hgbot (developer)
2016-06-21 10:36

Repository: erp/devel/pi
Changeset: a745d6a99abbdf519b449822347371ddf29b5704
Author: Mark <markmm82 <at> gmail.com>
Date: Mon Jun 20 11:25:12 2016 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/a745d6a99abbdf519b449822347371ddf29b5704 [^]

Fixes issue 33288: Linked items corrected in Payment Plan when unpaid invoice

Defined SQL Where Clause for Lines tab in Payment In and Payment Out window due that that HQL Where clause defined for Lines tab in Payment window is not executed from Linked Items correctly.

---
M src-db/database/sourcedata/AD_TAB.xml
---
(0087712)
aferraz (developer)
2016-06-21 11:09

Code review + Testing OK
(0087827)
hudsonbot (developer)
2016-06-22 18:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/468afe624cc8 [^]
Maturity status: Test
(0087831)
hgbot (developer)
2016-06-22 18:29

Repository: erp/devel/pi
Changeset: 4fcce5e429cef22f1a436091bb7817af92334b2a
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Jun 22 18:18:48 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4fcce5e429cef22f1a436091bb7817af92334b2a [^]

Related to issue 33288: Code review improvements

Use FIN_Payment_ScheduleDetail instead of e to avoid errors when compiling in 2.50 mode.

---
M src-db/database/sourcedata/AD_TAB.xml
---
(0087838)
hudsonbot (developer)
2016-06-22 23:13

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f80830d152e3 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-06-16 12:21 maite New Issue
2016-06-16 12:21 maite Assigned To => Triage Finance
2016-06-16 12:21 maite Modules => Advanced Payables and Receivables Mngmt
2016-06-16 12:21 maite Triggers an Emergency Pack => No
2016-06-16 12:22 maite Issue Monitored: networkb
2016-06-17 15:06 caristu Relationship added related to 0033305
2016-06-17 15:40 markmm82 Assigned To Triage Finance => markmm82
2016-06-17 15:41 markmm82 Status new => acknowledged
2016-06-20 10:11 aferraz Relationship added caused by 0025355
2016-06-20 10:13 aferraz Regression level => Production - Confirmed Stable
2016-06-20 10:13 aferraz Regression date => 2015-05-29
2016-06-20 10:13 aferraz Regression introduced in release => 3.0PR15Q3
2016-06-20 10:13 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/15dbf5983411 [^]
2016-06-20 10:14 aferraz Status acknowledged => scheduled
2016-06-20 16:25 markmm82 Note Added: 0087682
2016-06-20 16:56 markmm82 Note Edited: 0087682 View Revisions
2016-06-21 10:36 hgbot Checkin
2016-06-21 10:36 hgbot Note Added: 0087707
2016-06-21 10:36 hgbot Status scheduled => resolved
2016-06-21 10:36 hgbot Resolution open => fixed
2016-06-21 10:36 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a745d6a99abbdf519b449822347371ddf29b5704 [^]
2016-06-21 11:09 aferraz Review Assigned To => aferraz
2016-06-21 11:09 aferraz Note Added: 0087712
2016-06-21 11:09 aferraz Status resolved => closed
2016-06-21 11:09 aferraz Fixed in Version => 3.0PR16Q3
2016-06-22 18:10 hudsonbot Checkin
2016-06-22 18:10 hudsonbot Note Added: 0087827
2016-06-22 18:29 hgbot Checkin
2016-06-22 18:29 hgbot Note Added: 0087831
2016-06-22 23:13 hudsonbot Checkin
2016-06-22 23:13 hudsonbot Note Added: 0087838


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker