Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033309
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] Z. Othersminoralways2016-06-16 12:212016-06-22 18:31
ReportermaiteView Statuspublic 
Assigned Tomarkmm82 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2.1
StatusclosedFix in branchFixed in SCM revisionc1c80746036e
ProjectionnoneETAnoneTarget Version3.0PR16Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression levelProduction - Confirmed Stable
Regression date2015-05-29
Regression introduced in release3.0PR15Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/15dbf5983411 [^]
Triggers an Emergency PackNo
Summary

0033309: Linked items error in Payment Plan window when invoice is not paid

DescriptionWhen invoice is unpaid no records should appear in linked items section
Steps To Reproduce1. Access Sales Invoice window and filter by "Payment Complete"=No
2. Go to Payment Plan tab and open "Linked Items" section
3. Realize that 2 items are shown when does not exist any related payment document

Problem seems to be that HQL Where clause defined for Lines tab in Payment window is not executed from Linked Items.
Proposed SolutionTo define SQL Where Clause for Lines tab in Payment In and Payment Out window
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0033288 closedmarkmm82 Linked items error in Payment Plan window when invoice is not paid 

-  Notes
(0087710)
hgbot (developer)
2016-06-21 11:01

Repository: erp/backports/3.0PR16Q2.1
Changeset: c1c80746036eb9fe3d0aaa8361ecf6a93e4495b0
Author: Mark <markmm82 <at> gmail.com>
Date: Mon Jun 20 11:25:12 2016 -0400
URL: http://code.openbravo.com/erp/backports/3.0PR16Q2.1/rev/c1c80746036eb9fe3d0aaa8361ecf6a93e4495b0 [^]

Fixes issue 33309: Linked items corrected in Payment Plan when unpaid invoice

Defined SQL Where Clause for Lines tab in Payment In and Payment Out window due that that HQL Where clause defined for Lines tab in Payment window is not executed from Linked Items correctly.

---
M src-db/database/sourcedata/AD_TAB.xml
---
(0087713)
aferraz (developer)
2016-06-21 11:09

Code review + Testing OK
(0087832)
hgbot (developer)
2016-06-22 18:31

Repository: erp/backports/3.0PR16Q2.1
Changeset: 76ac05891177a65202a82c2e51198ead6116f81c
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Jun 22 18:18:48 2016 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR16Q2.1/rev/76ac05891177a65202a82c2e51198ead6116f81c [^]

Related to issue 33309: Code review improvements

Use FIN_Payment_ScheduleDetail instead of e to avoid errors when compiling in 2.50 mode.

---
M src-db/database/sourcedata/AD_TAB.xml
---

- Issue History
Date Modified Username Field Change
2016-06-20 10:14 aferraz Type defect => backport
2016-06-20 10:14 aferraz Target Version => 3.0PR16Q2.1
2016-06-21 11:01 hgbot Checkin
2016-06-21 11:01 hgbot Note Added: 0087710
2016-06-21 11:01 hgbot Status scheduled => resolved
2016-06-21 11:01 hgbot Resolution open => fixed
2016-06-21 11:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q2.1/rev/c1c80746036eb9fe3d0aaa8361ecf6a93e4495b0 [^]
2016-06-21 11:09 aferraz Review Assigned To => aferraz
2016-06-21 11:09 aferraz Note Added: 0087713
2016-06-21 11:09 aferraz Status resolved => closed
2016-06-21 11:09 aferraz Fixed in Version => 3.0PR16Q2.1
2016-06-22 18:31 hgbot Checkin
2016-06-22 18:31 hgbot Note Added: 0087832


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker