Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033012
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2016-05-20 10:502016-06-17 19:37
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision4a39b44ed6d0
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-11-23
Regression introduced in release3.0PR16Q1
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/0533c8d6569d7ca75ba77ecb7bcb224b1ff681a1 [^]
Triggers an Emergency PackNo
Summary

0033012: error in Instance Activation window when using an expired license

DescriptionWhen an instance is activated with an expired license, Instance Activation window displays an internal error in UI instead of the correct one notifying the license has expired.
Steps To ReproduceTry to activate an instance with an expired license.
  1. In UI you get the error attached as screenshot
  2. The following trace appears in log:
  java.lang.IllegalArgumentException: No enum constant org.openbravo.erpCommon.obps.ModuleLicenseRestrictions.MsgSeverity.Error
        at java.lang.Enum.valueOf(Enum.java:236)
        at org.openbravo.erpCommon.obps.ModuleLicenseRestrictions$MsgSeverity.valueOf(ModuleLicenseRestrictions.java:52)
        at org.openbravo.erpCommon.obps.ActivationKey.getActivationMessage(ActivationKey.java:842)
        at org.openbravo.erpCommon.ad_forms.InstanceManagement.printPageActive(InstanceManagement.java:326)
        at org.openbravo.erpCommon.ad_forms.InstanceManagement.doPost(InstanceManagement.java:67)
Proposed SolutionIf suffering this situation, please contact Openbravo support.
TagsNo tags attached.
Attached Filespng file icon 16Q1.2.png [^] (73,266 bytes) 2016-05-20 10:56

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00330133.0PR16Q2 closedalostale error in Instance Activation window when using an expired license 
depends on backport 00330143.0PR16Q1.2 closedalostale error in Instance Activation window when using an expired license 
caused by feature request 00310903.0PR16Q1 closedalostale Implement Retail licensing model 

-  Notes
(0086597)
hgbot (developer)
2016-05-20 11:12

Repository: erp/devel/pi
Changeset: 4a39b44ed6d01b477cadc514d77d8672531b752a
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri May 20 11:08:28 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4a39b44ed6d01b477cadc514d77d8672531b752a [^]

fixed bug 33012: error in Instance Activation when using an expired license

  When using a license within an erroneous state (such as expired), message severity
  was incorrectly obtained from the enum, causing an exception to be thrown.

  Fixed by using MsgSeverity.forType method instead of valueOf. forType method
  was designed with this purpose.

  In addition, some other changes have been done on MsgSeverity enum:
   * valueOf method is static so no need to invoke it on an instance (to may be
     another one, which is weird).
   * checking with actual type rather than with toString (which might change)
   * reversed comparision order to prevent NPE in case param in null

---
M src/org/openbravo/erpCommon/obps/ActivationKey.java
M src/org/openbravo/erpCommon/obps/ModuleLicenseRestrictions.java
---
(0086602)
alostale (developer)
2016-05-20 12:20

Added test case to TestLink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10026 [^]
(0086621)
AugustoMauch (developer)
2016-05-20 15:12

Code reviewed and verified in pi@4a39b44ed6d0
(0087546)
hudsonbot (developer)
2016-06-17 19:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-05-20 10:50 alostale New Issue
2016-05-20 10:50 alostale Assigned To => alostale
2016-05-20 10:50 alostale Modules => Core
2016-05-20 10:50 alostale Regression level => Production - QA Approved
2016-05-20 10:50 alostale Regression date => 2015-11-23
2016-05-20 10:50 alostale Regression introduced in release => 3.0PR16Q1
2016-05-20 10:50 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/0533c8d6569d7ca75ba77ecb7bcb224b1ff681a1 [^]
2016-05-20 10:50 alostale Triggers an Emergency Pack => No
2016-05-20 10:51 alostale Steps to Reproduce Updated View Revisions
2016-05-20 10:51 alostale Proposed Solution updated
2016-05-20 10:51 alostale Relationship added caused by 0031090
2016-05-20 10:52 alostale Status new => scheduled
2016-05-20 10:56 alostale File Added: 16Q1.2.png
2016-05-20 10:56 alostale Review Assigned To => caristu
2016-05-20 11:12 hgbot Checkin
2016-05-20 11:12 hgbot Note Added: 0086597
2016-05-20 11:12 hgbot Status scheduled => resolved
2016-05-20 11:12 hgbot Resolution open => fixed
2016-05-20 11:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4a39b44ed6d01b477cadc514d77d8672531b752a [^]
2016-05-20 11:24 alostale Review Assigned To caristu => AugustoMauch
2016-05-20 12:20 alostale Note Added: 0086602
2016-05-20 15:12 AugustoMauch Note Added: 0086621
2016-05-20 15:12 AugustoMauch Status resolved => closed
2016-05-20 15:12 AugustoMauch Fixed in Version => 3.0PR16Q3
2016-06-17 19:37 hudsonbot Checkin
2016-06-17 19:37 hudsonbot Note Added: 0087546


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker