Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032238
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] B. User interfaceminoralways2016-02-15 14:032016-03-04 09:26
ReporterngarciaView Statuspublic 
Assigned Toinigosanchez 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q4.5
StatusclosedFix in branchFixed in SCM revision869c7c4e3fc4
ProjectionnoneETAnoneTarget Version3.0PR15Q4.5
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032238: Payment In and Payment Out lines are not exported to CSV

DescriptionPayment In and Payment Out lines are not exported to CSV
Steps To ReproduceAs group admin role:
   Go to Payment In window
   Select a record
   Go to Lines tab and click on Export to Spreadsheet
   Check the file does not have any line apart from the column names
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0032233 closedinigosanchez Payment In and Payment Out lines are not exported to CSV 

-  Notes
(0084706)
hgbot (developer)
2016-03-04 08:52

Repository: erp/backports/3.0PR15Q4.5
Changeset: 869c7c4e3fc4414bdcef00b5a09a310fa9483a3d
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Mar 04 08:51:49 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q4.5/rev/869c7c4e3fc4414bdcef00b5a09a310fa9483a3d [^]

Fixes issue 32238: Payment In and Payment Out lines are not exported to CSV.

The problem was that export to CSV does not work properly in some subtabs without
link to parent column (e.g.Lines subtab of Payment In/Out). Before, It was used
"tabId" to obtaing data for export to CSV and the value of the "tabId" was sent
in a variable called "tab". The Criteria that is run when it is displayed the tab
uses a property named "tabId" instead of "tab".

The solution for this case (and other related cases) is to adapt the code that exports
to CSV to use the same Criteria run when displaying the tab. Now export to CSV uses
tabId property. Besides it has been refactored some piece of code related with export
data in DataSourceServlet to use "tabId" instead of "tab".

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/DataSourceServlet.java
---
(0084712)
alostale (developer)
2016-03-04 09:26

code reviewed and tested in different windows

- Issue History
Date Modified Username Field Change
2016-02-15 18:12 inigosanchez Type defect => backport
2016-02-15 18:12 inigosanchez Target Version => 3.0PR15Q4.4
2016-02-26 10:43 alostale Severity major => minor
2016-02-26 10:47 alostale Target Version 3.0PR15Q4.4 => 3.0PR15Q4.5
2016-02-29 23:54 inigosanchez Target Version 3.0PR15Q4.5 => 3.0PR15Q4.4
2016-03-01 00:08 inigosanchez Target Version 3.0PR15Q4.4 => 3.0PR15Q4.5
2016-03-04 08:52 hgbot Checkin
2016-03-04 08:52 hgbot Note Added: 0084706
2016-03-04 08:52 hgbot Status scheduled => resolved
2016-03-04 08:52 hgbot Resolution open => fixed
2016-03-04 08:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q4.5/rev/869c7c4e3fc4414bdcef00b5a09a310fa9483a3d [^]
2016-03-04 08:53 inigosanchez Issue Monitored: alostale
2016-03-04 08:53 inigosanchez Review Assigned To => alostale
2016-03-04 09:26 alostale Note Added: 0084712
2016-03-04 09:26 alostale Status resolved => closed
2016-03-04 09:26 alostale Fixed in Version => 3.0PR15Q4.5


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker