Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032233
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2016-02-15 14:032016-03-17 10:56
ReporterngarciaView Statuspublic 
Assigned Toinigosanchez 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision8c53c9e9c26f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-02-13
Regression introduced in release3.0PR15Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/15dbf5983411271754cdb97c5d993a241b395601 [^]
Triggers an Emergency PackNo
Summary

0032233: Payment In and Payment Out lines are not exported to CSV

DescriptionPayment In and Payment Out lines are not exported to CSV
Steps To ReproduceAs group admin role:
   Go to Payment In window
   Select a record
   Go to Lines tab and click on Export to Spreadsheet
   Check the file does not have any line apart from the column names
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00322373.0PR16Q1 closedinigosanchez Payment In and Payment Out lines are not exported to CSV 
depends on backport 00322383.0PR15Q4.5 closedinigosanchez Payment In and Payment Out lines are not exported to CSV 
depends on backport 00322393.0PR15Q3.6 closedinigosanchez Payment In and Payment Out lines are not exported to CSV 
depends on defect 0032248 closedplatform Improve consistency when export to csv from a subtab 
caused by design defect 0025355 closedfsoto82 Long time to show the lines on the payment in/out windows 
has duplicate defect 0032318 closedplatform [SERQA 728] No data exported to excel in tab Payment In || Lines 
causes defect 0032838 closedalostale Cannot export CSV from Widgets 

-  Notes
(0084263)
inigosanchez (developer)
2016-02-16 16:33

FYI: The problem is related with parentProperty. It is not possible to obtain the parentProperty. Link to parent column in this new table (FIN_Payment_ScheduleDetail) should be set properly to allow obtain the parentProperty.
(0084287)
vmromanos (developer)
2016-02-17 14:09

This table doesn't have a fin_payment_id column, so it's not possible to use the link to parent column feature.

Adding a physical column in this table is not a possibility because it would have a big impact in the APRM flows.

Neither a computed column nor a property field would work here because the code that exports the CSV requires to have a physical column.


The only solution for this case (and other related cases) is to adapt the code that exports to CSV to use the same Criteria run when displaying the tab.

As a workaround for the customer, the old Lines tab can be activated to export to CSV.

Decreased severity to minor, assigned to platform and set as blocked by 0032248


(0084510)
alostale (developer)
2016-02-25 14:25

updated SLA to the more restrictive one set in duplicated issue 0032318
(0084602)
inigosanchez (developer)
2016-02-29 16:15

Test plan: Check query and downloaded file. Export to CSV from:
- Payment In > Lines subtab
- Payment In > Lines subtab + Filter
- Assets > Asset Amortization subtab
- Assets > Asset Amortization subtab + Filter
- Organization grid view > Warehouse subtab
- Organization grid view > Warehouse subtab + Filter
- Organization tree view > Warehouse subtab
- Organization tree view > Warehouse subtab + Filter
(0084605)
inigosanchez (developer)
2016-02-29 16:23

Added a test in TestLink > Platform > [EDA] Export Data > [EDAa] Export to CSV > [EDAa010] Export in subtab without link to parent.
(0084609)
hgbot (developer)
2016-03-01 00:02

Repository: erp/devel/pi
Changeset: 8c53c9e9c26febf892a11cd30f5f5f81342cb2c2
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Feb 29 23:49:20 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/8c53c9e9c26febf892a11cd30f5f5f81342cb2c2 [^]

Fixes issue 32233: Payment In and Payment Out lines are not exported to CSV.

The problem was that export to CSV does not work properly in some subtabs without
link to parent column (e.g.Lines subtab of Payment In/Out). Before, It was used
"tabId" to obtaing data for export to CSV and the value of the "tabId" was sent
in a variable called "tab". The Criteria that is run when it is displayed the tab
uses a property named "tabId" instead of "tab".

The solution for this case (and other related cases) is to adapt the code that
exports to CSV to use the same Criteria run when displaying the tab. Now export
to CSV uses tabId property. Besides it has been refactored some piece of code
related with export data in DataSourceServlet to use "tabId" instead of "tab".

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/DataSourceServlet.java
---
(0084704)
alostale (developer)
2016-03-04 07:51

code reviewed and tested in different windows
(0085173)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-02-15 14:03 ngarcia New Issue
2016-02-15 14:03 ngarcia Assigned To => platform
2016-02-15 14:03 ngarcia Modules => Core
2016-02-15 14:03 ngarcia Triggers an Emergency Pack => No
2016-02-15 14:07 ngarcia Issue Monitored: networkb
2016-02-15 18:05 inigosanchez Assigned To platform => inigosanchez
2016-02-15 18:12 inigosanchez Status new => scheduled
2016-02-16 15:03 inigosanchez Regression level => Production - Confirmed Stable
2016-02-16 15:03 inigosanchez Regression date => 2015-02-13
2016-02-16 15:03 inigosanchez Regression introduced in release => 3.0PR15Q3
2016-02-16 15:03 inigosanchez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/15dbf5983411271754cdb97c5d993a241b395601 [^]
2016-02-16 16:01 inigosanchez Relationship added caused by 0025355
2016-02-16 16:02 inigosanchez Assigned To inigosanchez => Triage Finance
2016-02-16 16:33 inigosanchez Note Added: 0084263
2016-02-16 16:53 aferraz Status scheduled => acknowledged
2016-02-16 16:53 aferraz Status acknowledged => scheduled
2016-02-16 16:54 aferraz Status scheduled => feedback
2016-02-16 16:54 aferraz Status feedback => new
2016-02-16 17:11 inigosanchez Relationship added related to 0032248
2016-02-17 13:55 vmromanos Relationship deleted related to 0032248
2016-02-17 13:55 vmromanos Relationship added depends on 0032248
2016-02-17 14:09 vmromanos Note Added: 0084287
2016-02-17 14:09 vmromanos Assigned To Triage Finance => platform
2016-02-17 14:09 vmromanos Severity major => minor
2016-02-23 15:50 caristu Relationship added duplicate of 0032318
2016-02-25 14:23 alostale Status new => scheduled
2016-02-25 14:23 alostale Assigned To platform => inigosanchez
2016-02-25 14:25 alostale Note Added: 0084510
2016-02-25 14:25 alostale Relationship replaced has duplicate 0032318
2016-02-29 16:15 inigosanchez Note Added: 0084602
2016-02-29 16:23 inigosanchez Note Added: 0084605
2016-03-01 00:02 hgbot Checkin
2016-03-01 00:02 hgbot Note Added: 0084609
2016-03-01 00:02 hgbot Status scheduled => resolved
2016-03-01 00:02 hgbot Resolution open => fixed
2016-03-01 00:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8c53c9e9c26febf892a11cd30f5f5f81342cb2c2 [^]
2016-03-01 00:03 inigosanchez Review Assigned To => alostale
2016-03-04 07:51 alostale Note Added: 0084704
2016-03-04 07:51 alostale Status resolved => closed
2016-03-04 07:51 alostale Fixed in Version => 3.0PR16Q2
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085173
2016-05-23 11:37 caristu Relationship added causes 0032838


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker