Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032237
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] B. User interfaceminoralways2016-02-15 14:032016-03-04 09:27
ReporterngarciaView Statuspublic 
Assigned Toinigosanchez 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revisionf5044f52a09c
ProjectionnoneETAnoneTarget Version3.0PR16Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032237: Payment In and Payment Out lines are not exported to CSV

DescriptionPayment In and Payment Out lines are not exported to CSV
Steps To ReproduceAs group admin role:
   Go to Payment In window
   Select a record
   Go to Lines tab and click on Export to Spreadsheet
   Check the file does not have any line apart from the column names
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0032233 closedinigosanchez Payment In and Payment Out lines are not exported to CSV 

-  Notes
(0084611)
hgbot (developer)
2016-03-01 00:14

Repository: erp/backports/3.0PR16Q1
Changeset: f5044f52a09c5c63d5f1c8964b90fbce96f31d00
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Feb 29 23:51:51 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/f5044f52a09c5c63d5f1c8964b90fbce96f31d00 [^]

Fixes issue 32237: Payment In and Payment Out lines are not exported to CSV.

The problem was that export to CSV does not work properly in some subtabs without
link to parent column (e.g.Lines subtab of Payment In/Out). Before, It was used
"tabId" to obtaing data for export to CSV and the value of the "tabId" was sent
in a variable called "tab". The Criteria that is run when it is displayed the tab
uses a property named "tabId" instead of "tab".

The solution for this case (and other related cases) is to adapt the code that
exports to CSV to use the same Criteria run when displaying the tab. Now export to
CSV uses tabId property. Besides it has been refactored some piece of code related
with export data in DataSourceServlet to use "tabId" instead of "tab".

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/DataSourceServlet.java
---
(0084713)
alostale (developer)
2016-03-04 09:27

code reviewed and tested in different windows

- Issue History
Date Modified Username Field Change
2016-02-15 18:12 inigosanchez Type defect => backport
2016-02-15 18:12 inigosanchez Target Version => 3.0PR16Q1
2016-02-26 10:43 alostale Severity major => minor
2016-03-01 00:14 hgbot Checkin
2016-03-01 00:14 hgbot Note Added: 0084611
2016-03-01 00:14 hgbot Status scheduled => resolved
2016-03-01 00:14 hgbot Resolution open => fixed
2016-03-01 00:14 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/f5044f52a09c5c63d5f1c8964b90fbce96f31d00 [^]
2016-03-01 00:14 inigosanchez Review Assigned To => alostale
2016-03-04 09:27 alostale Note Added: 0084713
2016-03-04 09:27 alostale Status resolved => closed
2016-03-04 09:27 alostale Fixed in Version => 3.0PR16Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker