Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031835
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementmajoralways2016-01-08 08:552016-03-17 10:54
ReporterVictorVillarView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisione3220d26e44f
ProjectionnoneETAnoneTarget Version3.0PR16Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031835: Not possible to change the product definition to Stocked under some circumstancies

DescriptionNot possible to change the product definition to Stocked under some circumstancies
Steps To ReproduceAs group admin role,
 Go to Product window:
   Create a new one. Item and stocked = Y
   Org: *
  Price list: Bebidas alegres

Go to physical inventory:
 add 1 unit of this product
Process it.

Go to Goods Shipment window and add 1 unit of this product.
Process it.

Change the definition of the product as Service.

Try to change the definition to Item and Stocked again. You can not do that.

Error: You cannot change the product to stocked because it has completed documents which would generate inventory transactions
Proposed SolutionIf there is a warehouse/sales order document related with a product it should not be possible to change the stocked flag.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00318483.0PR16Q1 closedaferraz Not possible to change the product definition to Stocked under some circumstancies 
depends on backport 00318493.0PR15Q4.2 closedaferraz Not possible to change the product definition to Stocked under some circumstancies 
caused by defect 0025930 closedaferraz It should not be possible to change the product definition 
related to defect 0031833 closedaferraz Inconsistent data in M_STORAGE_PENDING table if the product is changed from Not Stocked to Stocked having pending orders 
related to defect 0032364 closedAtulOpenbravo NullPointerException when posting a Physical Inventory with a line without an associated transaction (not stocked product) 

-  Notes
(0083225)
aferraz (developer)
2016-01-13 11:16

Test plan I:

- Create a stocked product.
- Create a purchase order for that product but do not book it.
- Try to change the product to no stocked.
  An error is shown: "You cannot change the product stocked flag because it has related documents"
- Book the purchase order.
- Try to change the product to no stocked.
  An error is shown: "You cannot change the product stocked flag because it has related documents"

Test plan II:

- Create a no stocked product.
- Create a purchase order for that product but do not book it.
- Try to change the product to stocked.
  An error is shown: "You cannot change the product stocked flag because it has related documents"
- Book the purchase order.
- Try to change the product to stocked.
  An error is shown: "You cannot change the product stocked flag because it has related documents"

Repeat test I and II using sales order, purchase invoice, sales invoice, goods receipt, goods shipment, goods movement, internal consumption, physical inventory and bill of materials production instead of purchase order.
(0083249)
hgbot (developer)
2016-01-13 16:22

Repository: erp/devel/pi
Changeset: e3220d26e44f380077a80496a883e07c7f4a1b9e
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Jan 11 17:23:56 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e3220d26e44f380077a80496a883e07c7f4a1b9e [^]

Fixes issue 31835: Not possible to change product to stocked

Stocked flag in Product window will not be updatable in case product is present in any order, invoice or warehouse document.

---
M src-db/database/model/triggers/M_PRODUCT_TRG.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0083250)
hgbot (developer)
2016-01-13 16:22

Repository: erp/devel/pi
Changeset: 8d9510cd867e959b53fec9be671e3370bc33050f
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Jan 13 15:31:26 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/8d9510cd867e959b53fec9be671e3370bc33050f [^]

Related to issue 31835: code review improvements

The old messages have been reverted because it could be used by external modules, so it could be considered as a functional API Change.
Create a new message instead and improve it to be more descriptive.

Modified pl/sql comment to reflect the new behavior and to avoid confusions in the future

---
M src-db/database/model/triggers/M_PRODUCT_TRG.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0083254)
vmromanos (developer)
2016-01-13 16:32

Code review + testing OK
(0085037)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085038)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-01-08 08:55 VictorVillar New Issue
2016-01-08 08:55 VictorVillar Assigned To => Triage Finance
2016-01-08 08:55 VictorVillar Modules => Core
2016-01-08 08:55 VictorVillar Triggers an Emergency Pack => No
2016-01-08 08:56 VictorVillar Relationship added caused by 0025930
2016-01-08 08:56 VictorVillar Issue Monitored: networkb
2016-01-08 09:05 aferraz Assigned To Triage Finance => aferraz
2016-01-08 15:03 aferraz Status new => scheduled
2016-01-11 13:39 aferraz Relationship added related to 0031833
2016-01-12 18:22 gorka_gil Target Version 3.0PR15Q4.2 => 3.0PR16Q2
2016-01-13 10:19 ngarcia Issue Monitored: ngarcia
2016-01-13 11:16 aferraz Note Added: 0083225
2016-01-13 16:22 hgbot Checkin
2016-01-13 16:22 hgbot Note Added: 0083249
2016-01-13 16:22 hgbot Status scheduled => resolved
2016-01-13 16:22 hgbot Resolution open => fixed
2016-01-13 16:22 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e3220d26e44f380077a80496a883e07c7f4a1b9e [^]
2016-01-13 16:22 hgbot Checkin
2016-01-13 16:22 hgbot Note Added: 0083250
2016-01-13 16:32 vmromanos Review Assigned To => vmromanos
2016-01-13 16:32 vmromanos Note Added: 0083254
2016-01-13 16:32 vmromanos Status resolved => closed
2016-02-26 14:00 ngarcia Relationship added related to 0032364
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085037
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085038


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker