Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031849
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 02. Master data managementmajoralways2016-01-08 08:552016-01-13 16:21
ReporterVictorVillarView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision338ed6567ec8
ProjectionnoneETAnoneTarget Version3.0PR15Q4.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031849: Not possible to change the product definition to Stocked under some circumstancies

DescriptionNot possible to change the product definition to Stocked under some circumstancies
Steps To ReproduceAs group admin role,
 Go to Product window:
   Create a new one. Item and stocked = Y
   Org: *
  Price list: Bebidas alegres

Go to physical inventory:
 add 1 unit of this product
Process it.

Go to Goods Shipment window and add 1 unit of this product.
Process it.

Change the definition of the product as Service.

Try to change the definition to Item and Stocked again. You can not do that.

Error: You cannot change the product to stocked because it has completed documents which would generate inventory transactions
Proposed SolutionIf there is a warehouse/sales order document related with a product it should not be possible to change the stocked flag.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00318353.0PR16Q2 closedaferraz Not possible to change the product definition to Stocked under some circumstancies 

-  Notes
(0083246)
hgbot (developer)
2016-01-13 16:20

Repository: erp/backports/3.0PR15Q4.2
Changeset: 338ed6567ec897047241d0ceac48bcb987d38b5b
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Jan 11 17:23:56 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q4.2/rev/338ed6567ec897047241d0ceac48bcb987d38b5b [^]

Fixes issue 31849: Not possible to change product to stocked

Stocked flag in Product window will not be updatable in case product is present in any order, invoice or warehouse document.

---
M src-db/database/model/triggers/M_PRODUCT_TRG.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0083247)
hgbot (developer)
2016-01-13 16:20

Repository: erp/backports/3.0PR15Q4.2
Changeset: af90ae22aecc87fe790fc8a30de502c8db2eee3c
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Jan 13 15:31:26 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q4.2/rev/af90ae22aecc87fe790fc8a30de502c8db2eee3c [^]

Related to issue 31849: code review improvements

The old messages have been reverted because it could be used by external modules, so it could be considered as a functional API Change.
Create a new message instead and improve it to be more descriptive.

Modified pl/sql comment to reflect the new behavior and to avoid confusions in the future

---
M src-db/database/model/triggers/M_PRODUCT_TRG.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0083248)
vmromanos (developer)
2016-01-13 16:21

Code review + testing OK

- Issue History
Date Modified Username Field Change
2016-01-08 15:03 aferraz Type defect => backport
2016-01-13 16:20 hgbot Checkin
2016-01-13 16:20 hgbot Note Added: 0083246
2016-01-13 16:20 hgbot Status scheduled => resolved
2016-01-13 16:20 hgbot Resolution open => fixed
2016-01-13 16:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q4.2/rev/338ed6567ec897047241d0ceac48bcb987d38b5b [^]
2016-01-13 16:20 hgbot Checkin
2016-01-13 16:20 hgbot Note Added: 0083247
2016-01-13 16:21 vmromanos Review Assigned To => vmromanos
2016-01-13 16:21 vmromanos Note Added: 0083248
2016-01-13 16:21 vmromanos Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker