Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031848
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 02. Master data managementmajoralways2016-01-08 08:552016-01-13 16:31
ReporterVictorVillarView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision0a9e8acc986c
ProjectionnoneETAnoneTarget Version3.0PR16Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031848: Not possible to change the product definition to Stocked under some circumstancies

DescriptionNot possible to change the product definition to Stocked under some circumstancies
Steps To ReproduceAs group admin role,
 Go to Product window:
   Create a new one. Item and stocked = Y
   Org: *
  Price list: Bebidas alegres

Go to physical inventory:
 add 1 unit of this product
Process it.

Go to Goods Shipment window and add 1 unit of this product.
Process it.

Change the definition of the product as Service.

Try to change the definition to Item and Stocked again. You can not do that.

Error: You cannot change the product to stocked because it has completed documents which would generate inventory transactions
Proposed SolutionIf there is a warehouse/sales order document related with a product it should not be possible to change the stocked flag.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00318353.0PR16Q2 closedaferraz Not possible to change the product definition to Stocked under some circumstancies 

-  Notes
(0083251)
hgbot (developer)
2016-01-13 16:31

Repository: erp/backports/3.0PR16Q1
Changeset: 0a9e8acc986c7686d8123310a9d65fbbee5b5be3
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Jan 11 17:23:56 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/0a9e8acc986c7686d8123310a9d65fbbee5b5be3 [^]

Fixes issue 31848: Not possible to change product to stocked

Stocked flag in Product window will not be updatable in case product is present in any order, invoice or warehouse document.

---
M src-db/database/model/triggers/M_PRODUCT_TRG.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0083252)
hgbot (developer)
2016-01-13 16:31

Repository: erp/backports/3.0PR16Q1
Changeset: dd627520447d3c303a87b75b3ead7a933ede3b42
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Jan 13 15:31:26 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/dd627520447d3c303a87b75b3ead7a933ede3b42 [^]

Related to issue 31848: code review improvements

The old messages have been reverted because it could be used by external modules, so it could be considered as a functional API Change.
Create a new message instead and improve it to be more descriptive.

Modified pl/sql comment to reflect the new behavior and to avoid confusions in the future

---
M src-db/database/model/triggers/M_PRODUCT_TRG.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0083253)
vmromanos (developer)
2016-01-13 16:31

Code review + testing OK

- Issue History
Date Modified Username Field Change
2016-01-08 15:03 aferraz Type defect => backport
2016-01-08 15:03 aferraz Target Version 3.0PR15Q4.2 => 3.0PR16Q1
2016-01-13 16:31 hgbot Checkin
2016-01-13 16:31 hgbot Note Added: 0083251
2016-01-13 16:31 hgbot Status scheduled => resolved
2016-01-13 16:31 hgbot Resolution open => fixed
2016-01-13 16:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/0a9e8acc986c7686d8123310a9d65fbbee5b5be3 [^]
2016-01-13 16:31 hgbot Checkin
2016-01-13 16:31 hgbot Note Added: 0083252
2016-01-13 16:31 vmromanos Review Assigned To => vmromanos
2016-01-13 16:31 vmromanos Note Added: 0083253
2016-01-13 16:31 vmromanos Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker