Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031006
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2015-10-01 13:402015-11-23 21:16
ReportermaiteView Statuspublic 
Assigned Toaferraz 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision2671931ccb1a
ProjectionnoneETAnoneTarget Version3.0PR16Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031006: Credit consumed although payment is not completed due to "payment currency should map business partner currency" error

DescriptionCredit consumed although payment is not completed due to "payment currency should map business partner currency" error
Steps To Reproduce1. Register Payment Out for bebidas alegres and set generated credit=150. Process payment
2. Register Purchase Invoice for bebidas alegres, add any line and process. Do NOT consume credit when processing invoice
3. Access Business Partner window and run "Set new currency" process. Select MXN currency, check "set amount" option and set 200
4. Register Payment Out for bebidas alegres, run "Add details", select credit to be consumed and pending invoice
5. Process payment and error "For credit generation and/or credit consumption payment currency should map business partner currency: MXN" will be raised
6. Run "add details" rocess again and realize that available credit is not 150 but invoice amount has been substracted
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00310233.0PR15Q3.2 closedaferraz Credit consumed although payment is not completed due to "payment currency should map business partner currency" error 
depends on backport 00310243.0PR15Q2.6 closedaferraz Credit consumed although payment is not completed due to "payment currency should map business partner currency" error 
depends on backport 00310313.0PR15Q4 closedaferraz Credit consumed although payment is not completed due to "payment currency should map business partner currency" error 

-  Notes
(0080803)
aferraz (developer)
2015-10-02 12:38

1. Register Payment Out for bebidas alegres and set generated credit=150. Process payment
2. Register Purchase Invoice for bebidas alegres, add any line and process. Do NOT consume credit when processing invoice
3. Access Business Partner window and run "Set new currency" process. Select MXN currency, check "set amount" option and set 200
4. Register Payment Out for bebidas alegres, run "Add details", select credit to be consumed and pending invoice
5. Process payment and error "For credit generation and/or credit consumption payment currency should map business partner currency: MXN" will be raised
6. Run "add details" process again and realize that available credit is still being 150
(0080815)
hgbot (developer)
2015-10-05 11:28

Repository: erp/devel/pi
Changeset: 2671931ccb1ae3a0908e2eac9d6bb7ebf4ee2138
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Oct 02 12:24:48 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2671931ccb1ae3a0908e2eac9d6bb7ebf4ee2138 [^]

Fixes issue 31006: Credit consumed although payment not completed

When consuming a credit with a currency different than Business Partner's currency, an error is shown but credit was also consumed, which was wrong.
Now, this check will be also done before consuming credit in AddPaymentActionHandler addCredit method, as it was done in FIN_PaymentProcess doProcessPayment method.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/AddPaymentActionHandler.java
---
(0080821)
vmromanos (developer)
2015-10-05 11:32

Code review + testing OK
(0082109)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-10-01 13:40 maite New Issue
2015-10-01 13:40 maite Assigned To => Triage Finance
2015-10-01 13:40 maite Modules => Core
2015-10-01 13:40 maite Triggers an Emergency Pack => No
2015-10-01 13:40 maite Issue Monitored: networkb
2015-10-02 12:17 aferraz Assigned To Triage Finance => aferraz
2015-10-02 12:18 aferraz Status new => scheduled
2015-10-02 12:38 aferraz Note Added: 0080803
2015-10-02 13:30 vmromanos Status scheduled => acknowledged
2015-10-02 13:31 vmromanos Status acknowledged => scheduled
2015-10-05 11:28 hgbot Checkin
2015-10-05 11:28 hgbot Note Added: 0080815
2015-10-05 11:28 hgbot Status scheduled => resolved
2015-10-05 11:28 hgbot Resolution open => fixed
2015-10-05 11:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2671931ccb1ae3a0908e2eac9d6bb7ebf4ee2138 [^]
2015-10-05 11:32 vmromanos Review Assigned To => vmromanos
2015-10-05 11:32 vmromanos Note Added: 0080821
2015-10-05 11:32 vmromanos Status resolved => closed
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082109


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker