Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031024
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] Z. Othersmajoralways2015-10-01 13:402015-10-05 11:31
ReportermaiteView Statuspublic 
Assigned Toaferraz 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision189d99a30959
ProjectionnoneETAnoneTarget Version3.0PR15Q2.6
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031024: Credit consumed although payment is not completed due to "payment currency should map business partner currency" error

DescriptionCredit consumed although payment is not completed due to "payment currency should map business partner currency" error
Steps To Reproduce1. Register Payment Out for bebidas alegres and set generated credit=150. Process payment
2. Register Purchase Invoice for bebidas alegres, add any line and process. Do NOT consume credit when processing invoice
3. Access Business Partner window and run "Set new currency" process. Select MXN currency, check "set amount" option and set 200
4. Register Payment Out for bebidas alegres, run "Add details", select credit to be consumed and pending invoice
5. Process payment and error "For credit generation and/or credit consumption payment currency should map business partner currency: MXN" will be raised
6. Run "add details" rocess again and realize that available credit is not 150 but invoice amount has been substracted
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00310063.0PR16Q1 closedaferraz Credit consumed although payment is not completed due to "payment currency should map business partner currency" error 

-  Notes
(0080817)
hgbot (developer)
2015-10-05 11:29

Repository: erp/backports/3.0PR15Q2.6
Changeset: 189d99a30959fe0c135c8b22f62fd3306be08003
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Oct 02 12:24:48 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.6/rev/189d99a30959fe0c135c8b22f62fd3306be08003 [^]

Fixes issue 31024: Credit consumed although payment not completed

When consuming a credit with a currency different than Business Partner's currency, an error is shown but credit was also consumed, which was wrong.
Now, this check will be also done before consuming credit in AddPaymentActionHandler addCredit method, as it was done in FIN_PaymentProcess doProcessPayment method.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/AddPaymentActionHandler.java
---
(0080819)
vmromanos (developer)
2015-10-05 11:31

Code review + testing OK

- Issue History
Date Modified Username Field Change
2015-10-02 12:18 aferraz Type defect => backport
2015-10-02 12:18 aferraz Target Version 3.0PR16Q1 => 3.0PR15Q2.6
2015-10-02 12:19 aferraz Tag Attached: Approved
2015-10-05 11:29 hgbot Checkin
2015-10-05 11:29 hgbot Note Added: 0080817
2015-10-05 11:29 hgbot Status scheduled => resolved
2015-10-05 11:29 hgbot Resolution open => fixed
2015-10-05 11:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.6/rev/189d99a30959fe0c135c8b22f62fd3306be08003 [^]
2015-10-05 11:31 vmromanos Review Assigned To => vmromanos
2015-10-05 11:31 vmromanos Note Added: 0080819
2015-10-05 11:31 vmromanos Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker