Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030948
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2015-09-28 12:292015-11-23 21:16
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revisionf1f0e628b7d9
ProjectionnoneETAnoneTarget Version3.0PR16Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030948: auxiliary input used to default a FK doesn't display FK's value identifier

DescriptionWhen an auxiliary input is used to set a default value for a FK field, it is correctly calculated but the identifier does not appear in the UI.
Steps To Reproduce-Backout changeset for issue 0030495, so auxiliary input for C_BPartner_ID in Purchase Invoice > Lines tab is @C_BPartner_ID@
-Go to Purchase Invoice and create a new Header
-In grid view show BP field in Lines tab
-Create a new record in grid view
   -> INCORRECT: check BP field is empty -> expected header's BP to be shown
-Save
   -> Check the BP field shows the Header's BP, which is correct as it was defaulted by the Auxiliary input
TagsNo tags attached.
Attached Files? file icon 30948.export [^] (4,415 bytes) 2015-09-29 07:45

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0030927 closedalostale Auxiliary Input value is shown in Form view if its name is the same than the column associated to the field of the tab 
related to defect 0030495 closedaferraz Business Partner dimension is overwritten in Invoice Lines if another field is updated after changing it 
related to defect 00309933.0PR16Q1 closedalostale It is not possible to define a preference as default value when column has a default defined in ad_column 

-  Notes
(0080679)
alostale (developer)
2015-09-29 07:46

fix attached
(0080810)
hgbot (developer)
2015-10-05 10:12

Repository: erp/devel/pi
Changeset: f1f0e628b7d9b85f8804fb67cb15d1c2de86fb81
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Sep 28 13:17:45 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f1f0e628b7d9b85f8804fb67cb15d1c2de86fb81 [^]

fixed bug 30948: auxiliary input to default a FK doesn't display identifier

  When an auxiliary input is used to default a FK value, its value was correctly
  calculated but it's identifier was not, this made the UI not to display the
  identifier on NEW, but to correctly set it being visible after save.

  This has been fixed by detecting this special case, when in this situation:

    - Value is calculated in computeAuxiliaryInputs method, including also its
      identifier (obtained from field's ui defintion)
    - Value is not calculated in computeColumnValues method because it has already
      been computed

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/FormInitializationComponent.java
---
(0081141)
AugustoMauch (developer)
2015-10-20 17:02

Code reviewed and verified in pi@6a34fdef3d70
(0082108)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-09-28 12:29 alostale New Issue
2015-09-28 12:29 alostale Assigned To => platform
2015-09-28 12:29 alostale Modules => Core
2015-09-28 12:29 alostale Triggers an Emergency Pack => No
2015-09-28 12:29 alostale Relationship added related to 0030927
2015-09-28 12:29 alostale Relationship added related to 0030495
2015-09-28 13:18 alostale Status new => scheduled
2015-09-28 13:18 alostale Assigned To platform => alostale
2015-09-28 13:19 alostale Review Assigned To => AugustoMauch
2015-09-29 07:45 alostale File Added: 30948.export
2015-09-29 07:46 alostale Note Added: 0080679
2015-09-29 13:14 alostale Target Version => 3.0PR16Q1
2015-10-05 09:55 alostale Relationship added related to 0030993
2015-10-05 10:12 hgbot Checkin
2015-10-05 10:12 hgbot Note Added: 0080810
2015-10-05 10:12 hgbot Status scheduled => resolved
2015-10-05 10:12 hgbot Resolution open => fixed
2015-10-05 10:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f1f0e628b7d9b85f8804fb67cb15d1c2de86fb81 [^]
2015-10-20 17:02 AugustoMauch Note Added: 0081141
2015-10-20 17:02 AugustoMauch Status resolved => closed
2015-10-20 17:02 AugustoMauch Fixed in Version => 3.0PR16Q1
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082108


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker