Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030927
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-09-25 09:332015-10-01 03:36
ReporterngarciaView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q4
StatusclosedFix in branchFixed in SCM revisione1c8609a0602
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030927: Auxiliary Input value is shown in Form view if its name is the same than the column associated to the field of the tab

DescriptionAuxiliary Input value is shown in Form view if its name is the same than the column associated to the field of the tab
Steps To ReproduceAs group admin role:
   Go to Client window and set the Business Partner dimension to be shown in lines
   Remove the exceptions for that dimension and AP Invoice in the Dimension tab for AP Invoice
   Go to Purchase Invoice window, show the Business Partner column in grid view in the Lines tab
   Open one record without value in the Business Partner field in Form view and check the business partner of the header is shown there
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0030495 closedaferraz Business Partner dimension is overwritten in Invoice Lines if another field is updated after changing it 
related to defect 0030944 closeddmiguelez some auxiliary inputs might be useless 
related to defect 00309483.0PR16Q1 closedalostale auxiliary input used to default a FK doesn't display FK's value identifier 

-  Notes
(0080661)
alostale (developer)
2015-09-28 09:12

Query to get all auxiliary inputs for this same case: they have the same name as a field in the tab they are defined in


select w.name, t.name, f.name, i.code
from ad_auxiliarinput i, ad_field f, ad_column c, ad_window w, ad_tab t
where f.ad_tab_id = i.ad_tab_id
and f.ad_column_id = c.ad_column_id
and c.columnname ilike i.name
and t.ad_tab_id = f.ad_tab_id
and w.ad_window_id = t.ad_window_id
(0080665)
hgbot (developer)
2015-09-28 12:24

Repository: erp/devel/pi
Changeset: e1c8609a060289500ad4a00f93891d87c5a27f14
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Sep 28 09:01:38 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e1c8609a060289500ad4a00f93891d87c5a27f14 [^]

fixed bug 30927: editting a record with aux input, actual value is overwritten

  When a tab has an auxiliary input having the same name than one of its fields,
  the value of that auxiliary input is used to set the value for that field. This
  is correct and as it is the manner to define different defaults for the same
  column in different tabs.

  The problem is this is calculated even when editing an existent record, which is
  not correct, in this case the current value for that record should prevail over
  the auxiliary input.

  This case is now taken into account, not calculating auxiliary inputs in FIC in
  modes EDIT and CHANGE when there is a field with the same column name.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/FormInitializationComponent.java
---
(0080677)
hudsonbot (developer)
2015-09-28 19:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/e823cc35e61e [^]
Maturity status: Test
(0080698)
hgbot (developer)
2015-09-29 13:06

Repository: erp/devel/pi
Changeset: 47ec5cda846f4c8230dd4173b51ec7fe033842a2
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Sep 29 13:06:08 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/47ec5cda846f4c8230dd4173b51ec7fe033842a2 [^]

related to bug 30927, related to bug 30495: change mode calculates aux input

  Previous changeset for issue 0030927 didn't work correctly in CHANGE modee, in
  this case auxiliary inputs named like a column in the tab were recalculted.

  This was caused because the code relied on allColumns variable to hold a list
  of all existent columns in the tab, this was the case for NEW mode but not for
  CHANGE where allColumns only contains the list of modified columns.

  Fixed by calculating list of all columns externally.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/FormInitializationComponent.java
---
(0080710)
AugustoMauch (developer)
2015-09-29 16:39

Code reviewed and verified in pi@9ee648f47df5

Now the FIC returns null for the value of the conflicting auxiliary input. This does not have consequences because if the auxiliary input was reference (for instance in a display logic), the value of the column will be used.
(0080713)
hgbot (developer)
2015-09-29 16:46

Repository: erp/devel/pi
Changeset: 1bd0b0e1846f5c8d5531ced3dacd6c622bd8afb6
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Tue Sep 29 16:46:01 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1bd0b0e1846f5c8d5531ced3dacd6c622bd8afb6 [^]

Fixes Issue 30944. Reverts fix done in Issue 30495 since it is no
longer needed due to a fix for Issue 30927 done by platform team.

---
M src-db/database/sourcedata/AD_AUXILIARINPUT.xml
---
(0080725)
hudsonbot (developer)
2015-09-29 22:42

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ebe9ebd06ddd [^]
Maturity status: Test
(0080765)
hudsonbot (developer)
2015-10-01 03:36

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f63a11a49473 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-09-25 09:33 ngarcia New Issue
2015-09-25 09:33 ngarcia Assigned To => platform
2015-09-25 09:33 ngarcia Modules => Core
2015-09-25 09:33 ngarcia Triggers an Emergency Pack => No
2015-09-25 09:34 ngarcia Issue Monitored: networkb
2015-09-25 09:41 ngarcia Relationship added related to 0030495
2015-09-25 10:07 ngarcia Priority immediate => urgent
2015-09-28 08:46 alostale Status new => scheduled
2015-09-28 08:46 alostale Assigned To platform => alostale
2015-09-28 09:12 alostale Note Added: 0080661
2015-09-28 09:55 alostale Relationship added related to 0030944
2015-09-28 12:24 alostale Review Assigned To => AugustoMauch
2015-09-28 12:24 hgbot Checkin
2015-09-28 12:24 hgbot Note Added: 0080665
2015-09-28 12:24 hgbot Status scheduled => resolved
2015-09-28 12:24 hgbot Resolution open => fixed
2015-09-28 12:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e1c8609a060289500ad4a00f93891d87c5a27f14 [^]
2015-09-28 12:29 alostale Relationship added related to 0030948
2015-09-28 19:49 hudsonbot Checkin
2015-09-28 19:49 hudsonbot Note Added: 0080677
2015-09-29 13:06 hgbot Checkin
2015-09-29 13:06 hgbot Note Added: 0080698
2015-09-29 16:39 AugustoMauch Note Added: 0080710
2015-09-29 16:39 AugustoMauch Status resolved => closed
2015-09-29 16:39 AugustoMauch Fixed in Version => 3.0PR15Q4
2015-09-29 16:46 hgbot Checkin
2015-09-29 16:46 hgbot Note Added: 0080713
2015-09-29 22:42 hudsonbot Checkin
2015-09-29 22:42 hudsonbot Note Added: 0080725
2015-10-01 03:36 hudsonbot Checkin
2015-10-01 03:36 hudsonbot Note Added: 0080765


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker