Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030495
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-08-04 12:522015-10-01 03:36
ReporterngarciaView Statuspublic 
Assigned Toaferraz 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionbf045d72ec64
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030495: Business Partner dimension is overwritten in Invoice Lines if another field is updated after changing it

DescriptionBusiness Partner dimension is overwritten in Invoice Lines if another field is updated after changing it
Steps To ReproduceAs group admin role:
   Remove the exception in Client - Dimensions tab in order to show Business Partner dimension in AP Invoice window
   Log out and log in
   Create a Purchase Invoice for a Business Partner
   Add a line to it
   Select another Business Partner in that line and save it
   Edit the quantity of that line and check the Business Partner is overwritten with the header value
Proposed SolutionCheck if the Auxiliary Input should be applied every time a record is updated
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0030927 closedalostale Auxiliary Input value is shown in Form view if its name is the same than the column associated to the field of the tab 
related to defect 0030944 closeddmiguelez some auxiliary inputs might be useless 
related to defect 00309483.0PR16Q1 closedalostale auxiliary input used to default a FK doesn't display FK's value identifier 

-  Notes
(0079400)
aferraz (developer)
2015-08-18 08:42

Test plan:

As F&B Admin:

- Remove the exception in Client - Dimensions tab in order to show Business Partner dimension in AP Invoice window
- Log out and log in
- Create a Purchase Invoice for a Business Partner
- Add a line to it and save it
- Edit the quantity of that line and check the Business Partner is overwritten with the header value
- Select another Business Partner in that line and save it
- Edit the quantity of that line and check the Business Partner is not overwritten with the header value

Repeat the same flow with Outgoing Shipment, Incoming Shipment, Goods Shipment, Goods Receipt and Sales Invoice windows.
(0079405)
hgbot (developer)
2015-08-18 13:05

Repository: erp/devel/pi
Changeset: bf045d72ec64b1f4e24872d285a48bb5c796b40e
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Aug 17 16:07:34 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/bf045d72ec64b1f4e24872d285a48bb5c796b40e [^]

Fixes issue 30495: BP dimension overwritten from Header to Lines

Business Partner dimension was overwritten from Header to Lines tab although Business Partner field was setted in Lines tab.
To fix it Auxiliary Input for Outgoing Shipment, Incoming Shipment, Goods Shipment, Goods Receipt, Purchase Invoice and Sales Invoice windows have been updated.
Now, Business Partner dimension will be overwritten only if Business Partner field is null in Lines tab.

---
M src-db/database/sourcedata/AD_AUXILIARINPUT.xml
---
(0079406)
dmiguelez (developer)
2015-08-18 13:05

Code Review + Testing Ok
(0079556)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0080699)
hgbot (developer)
2015-09-29 13:06

Repository: erp/devel/pi
Changeset: 47ec5cda846f4c8230dd4173b51ec7fe033842a2
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Sep 29 13:06:08 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/47ec5cda846f4c8230dd4173b51ec7fe033842a2 [^]

related to bug 30927, related to bug 30495: change mode calculates aux input

  Previous changeset for issue 0030927 didn't work correctly in CHANGE modee, in
  this case auxiliary inputs named like a column in the tab were recalculted.

  This was caused because the code relied on allColumns variable to hold a list
  of all existent columns in the tab, this was the case for NEW mode but not for
  CHANGE where allColumns only contains the list of modified columns.

  Fixed by calculating list of all columns externally.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/FormInitializationComponent.java
---
(0080712)
hgbot (developer)
2015-09-29 16:46

Repository: erp/devel/pi
Changeset: 1bd0b0e1846f5c8d5531ced3dacd6c622bd8afb6
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Tue Sep 29 16:46:01 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1bd0b0e1846f5c8d5531ced3dacd6c622bd8afb6 [^]

Fixes Issue 30944. Reverts fix done in Issue 30495 since it is no
longer needed due to a fix for Issue 30927 done by platform team.

---
M src-db/database/sourcedata/AD_AUXILIARINPUT.xml
---
(0080726)
hudsonbot (developer)
2015-09-29 22:42

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ebe9ebd06ddd [^]
Maturity status: Test
(0080764)
hudsonbot (developer)
2015-10-01 03:36

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f63a11a49473 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-08-04 12:52 ngarcia New Issue
2015-08-04 12:52 ngarcia Assigned To => Triage Finance
2015-08-04 12:52 ngarcia Modules => Core
2015-08-04 12:52 ngarcia Triggers an Emergency Pack => No
2015-08-04 12:55 ngarcia Issue Monitored: networkb
2015-08-17 09:28 aferraz Assigned To Triage Finance => aferraz
2015-08-18 08:42 aferraz Note Added: 0079400
2015-08-18 13:05 hgbot Checkin
2015-08-18 13:05 hgbot Note Added: 0079405
2015-08-18 13:05 hgbot Status new => resolved
2015-08-18 13:05 hgbot Resolution open => fixed
2015-08-18 13:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/bf045d72ec64b1f4e24872d285a48bb5c796b40e [^]
2015-08-18 13:05 dmiguelez Review Assigned To => dmiguelez
2015-08-18 13:05 dmiguelez Note Added: 0079406
2015-08-18 13:05 dmiguelez Status resolved => closed
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079556
2015-09-25 09:41 ngarcia Relationship added related to 0030927
2015-09-28 10:14 alostale Relationship added related to 0030944
2015-09-28 12:29 alostale Relationship added related to 0030948
2015-09-29 13:06 hgbot Checkin
2015-09-29 13:06 hgbot Note Added: 0080699
2015-09-29 16:46 hgbot Checkin
2015-09-29 16:46 hgbot Note Added: 0080712
2015-09-29 22:42 hudsonbot Checkin
2015-09-29 22:42 hudsonbot Note Added: 0080726
2015-10-01 03:36 hudsonbot Checkin
2015-10-01 03:36 hudsonbot Note Added: 0080764


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker