Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030063
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminorhave not tried2015-06-01 13:522015-06-15 10:14
ReporteralostaleView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2.2
StatusclosedFix in branchFixed in SCM revision32495ca01568
ProjectionnoneETAnoneTarget Version3.0PR15Q2.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-11-19
Regression introduced in release3.0PR15Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/3221fd5a8661d7f9dfbfd6d4255bace9834e6535 [^]
Triggers an Emergency PackNo
Summary

0030063: grid is not completely loaded after refresh in some cases

DescriptionGrid is not completely loaded after refreshing it having a record selected and scrolling down to a different page.
Steps To Reproduce1. Open Country and Region window (check grid is sorted by ISO code)
2. Select first country in the list (Andorra)
3. Scroll down until next page is requested
4. Click the refresh button. Grid is scrolled up again to display selected country -> OK
5. Scroll down till last record in the current page (India), there are 2 problems:
  -> grid shows to empty lines after India
  -> there is no extra request to continue loading missing records
   
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by design defect 0025811 closedAugustoMauch unnecessary request on grid refresh 
blocks defect 0030062 closedAugustoMauch grid is not completely loaded after refresh in some cases 

-  Notes
(0078078)
hgbot (developer)
2015-06-04 15:38

Repository: erp/backports/3.0PR15Q2.2
Changeset: 32495ca01568ccb55bfcbe1357510afc9cf4c35a
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Jun 04 14:54:06 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.2/rev/32495ca01568ccb55bfcbe1357510afc9cf4c35a [^]

Fixes issue 30063: Grid is properly loaded after refreshing with a selected row

The problem was caused by this code (the this attribute is a ResultSet), which is contained in the fetchRemoteData function:

      } else if (this.grid.refreshingWithSelectedRecord) {
        // if the grid was refreshed with a record selected, use the range that contained that record
        // instead of using targetRecordId to improve the performance
        startRow = this.grid.selectedRecordInitInterval;
        endRow = this.grid.selectedRecordEndInterval;
      }

If the grid is refreshed while one of its records is selected, then the startRow and endRow will be set so that the requested page contains the selected record. The problem was that the ResultSet.localData attribute was not being properly set, as at this points it was expected to contain the 'loading' value for all the rows that are being requested. As a result of this the localData attribute became malformed when the response was processed, and this caused the grid to misbehave.

To fix this, the localData is configured to wait for the proper records:

        this.localData = [];
        this.setRangeLoading(startRow, endRow);

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0078284)
alostale (developer)
2015-06-15 10:14

code reviewed and tested

- Issue History
Date Modified Username Field Change
2015-06-01 13:55 alostale Type defect => backport
2015-06-01 13:55 alostale Target Version => 3.0PR15Q2.2
2015-06-01 14:00 alostale Assigned To platform => AugustoMauch
2015-06-03 10:38 dmitry_mezentsev Tag Attached: Approved
2015-06-04 15:14 AugustoMauch Issue Monitored: alostale
2015-06-04 15:14 AugustoMauch Review Assigned To => alostale
2015-06-04 15:38 hgbot Checkin
2015-06-04 15:38 hgbot Note Added: 0078078
2015-06-04 15:38 hgbot Status scheduled => resolved
2015-06-04 15:38 hgbot Resolution open => fixed
2015-06-04 15:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.2/rev/32495ca01568ccb55bfcbe1357510afc9cf4c35a [^]
2015-06-10 15:30 alostale Relationship added caused by 0025811
2015-06-15 10:14 alostale Note Added: 0078284
2015-06-15 10:14 alostale Status resolved => closed
2015-06-15 10:14 alostale Fixed in Version => 3.0PR15Q2.2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker