Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030062
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2015-06-01 13:522015-06-10 15:36
ReporteralostaleView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision82e40910201d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-11-19
Regression introduced in release3.0PR15Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/3221fd5a8661d7f9dfbfd6d4255bace9834e6535 [^]
Triggers an Emergency PackNo
Summary

0030062: grid is not completely loaded after refresh in some cases

DescriptionGrid is not completely loaded after refreshing it having a record selected and scrolling down to a different page.

Workaround: to get the full grid again unselect selected record and refresh it again
Steps To Reproduce1. Open Country and Region window (check grid is sorted by ISO code)
2. Select first country in the list (Andorra)
3. Scroll down until next page is requested
4. Click the refresh button. Grid is scrolled up again to display selected country -> OK
5. Scroll down till last record in the current page (India), there are 2 problems:
  -> grid shows to empty lines after India
  -> there is no extra request to continue loading missing records
   
TagsNo tags attached.
Attached Filespng file icon Selection_217.png [^] (74,746 bytes) 2015-06-01 13:54

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00300633.0PR15Q2.2 closedAugustoMauch grid is not completely loaded after refresh in some cases 
depends on backport 00300643.0PR15Q1.5 closedAugustoMauch grid is not completely loaded after refresh in some cases 
caused by design defect 0025811 closedAugustoMauch unnecessary request on grid refresh 

-  Notes
(0078076)
hgbot (developer)
2015-06-04 14:59

Repository: erp/devel/pi
Changeset: 82e40910201df9cf2a2e79a285b61407a6fefcea
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Jun 04 14:54:06 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/82e40910201df9cf2a2e79a285b61407a6fefcea [^]

Fixes issue 30062: Grid is properly loaded after refreshing with a selected row

The problem was caused by this code (the this attribute is a ResultSet), which is contained in the fetchRemoteData function:

      } else if (this.grid.refreshingWithSelectedRecord) {
        // if the grid was refreshed with a record selected, use the range that contained that record
        // instead of using targetRecordId to improve the performance
        startRow = this.grid.selectedRecordInitInterval;
        endRow = this.grid.selectedRecordEndInterval;
      }

If the grid is refreshed while one of its records is selected, then the startRow and endRow will be set so that the requested page contains the selected record. The problem was that the ResultSet.localData attribute was not being properly set, as at this points it was expected to contain the 'loading' value for all the rows that are being requested. As a result of this the localData attribute became malformed when the response was processed, and this caused the grid to misbehave.

To fix this, the localData is configured to wait for the proper records:

        this.localData = [];
        this.setRangeLoading(startRow, endRow);

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0078106)
hudsonbot (developer)
2015-06-05 01:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/aa05c3f56c97 [^]
Maturity status: Test
(0078180)
alostale (developer)
2015-06-10 15:36

code reviewed

tested with single and multiple records selected

- Issue History
Date Modified Username Field Change
2015-06-01 13:52 alostale New Issue
2015-06-01 13:52 alostale Assigned To => platform
2015-06-01 13:52 alostale Modules => Core
2015-06-01 13:52 alostale Regression level => Production - Confirmed Stable
2015-06-01 13:52 alostale Regression date => 2014-11-19
2015-06-01 13:52 alostale Regression introduced in release => 3.0PR15Q1
2015-06-01 13:52 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/3221fd5a8661d7f9dfbfd6d4255bace9834e6535 [^]
2015-06-01 13:52 alostale Triggers an Emergency Pack => No
2015-06-01 13:52 alostale Relationship added caused by 0025811
2015-06-01 13:54 alostale File Added: Selection_217.png
2015-06-01 13:55 alostale Status new => scheduled
2015-06-01 13:55 alostale Assigned To platform => AugustoMauch
2015-06-01 13:55 alostale Description Updated View Revisions
2015-06-04 14:57 AugustoMauch Issue Monitored: alostale
2015-06-04 14:57 AugustoMauch Review Assigned To => alostale
2015-06-04 14:59 hgbot Checkin
2015-06-04 14:59 hgbot Note Added: 0078076
2015-06-04 14:59 hgbot Status scheduled => resolved
2015-06-04 14:59 hgbot Resolution open => fixed
2015-06-04 14:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/82e40910201df9cf2a2e79a285b61407a6fefcea [^]
2015-06-05 01:33 hudsonbot Checkin
2015-06-05 01:33 hudsonbot Note Added: 0078106
2015-06-10 15:36 alostale Note Added: 0078180
2015-06-10 15:36 alostale Status resolved => closed
2015-06-10 15:36 alostale Fixed in Version => 3.0PR15Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker