Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029854
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2015-05-12 16:272015-08-28 11:45
ReportershuehnerView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q4
StatusclosedFix in branchFixed in SCM revisioneae81cf322cb
ProjectionnoneETAnoneTarget Version3.0PR15Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029854: Weld,integration.google & json modules does not pass 'ant validate.modules'

DescriptionRunning this command in pi shows errors in that module:


ant validate.modules -Dmodule=org.openbravo.service.json

[validateModules] Errors for Validation type: MODULE_ERROR
[validateModules] +++++++++++++++++++++++++++++++++++++++++++++++++++
[validateModules] Module JSON REST Webservice has UI Artifacts, translation required should be set to 'Y', it is now 'N'.

similar for weld & integration.google modules
Steps To Reproduceant validate.modules -Dmodule=org.openbravo.service.json
ant validate.modules -Dmodule=org.openbravo.base.weld
ant validate.modules -Dmodule=org.openbravo.service.integration.google
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0029855 closedshuehner ant validate modules reads excludeFilter.xml from wrong folder 
related to defect 00306803.0PR16Q3 closedalostale Weld module does not pass 'ant validate.modules' 

-  Notes
(0077343)
shuehner (administrator)
2015-05-12 16:30

Again but unnoticed meaning -> test not run in normal junit run.

Looks like that part is only running when modules are marked as in development

So that should be reviewed as well.
(0079758)
caristu (developer)
2015-08-26 14:31

Fixed for integration.google & json modules. A new issue (0030680) has been raised for the weld module, as it requires a more complex solution to be discussed.
(0079759)
hgbot (developer)
2015-08-26 14:33

Repository: erp/devel/pi
Changeset: eae81cf322cbcf0b89c80795de585512d8ce8465
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Aug 26 14:25:52 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/eae81cf322cbcf0b89c80795de585512d8ce8465 [^]

fixes issue 29854: google & json modules does not pass 'ant validate.modules'

---
M modules/org.openbravo.service.integration.google/src-db/database/sourcedata/AD_MODULE.xml
M modules/org.openbravo.service.json/src-db/database/sourcedata/AD_MODULE.xml
---
(0079763)
hudsonbot (developer)
2015-08-26 21:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d7da276db20c [^]
Maturity status: Test
(0079791)
AugustoMauch (developer)
2015-08-28 11:45

Code reviewed and verified in pi@c86e5f2b1bef

- Issue History
Date Modified Username Field Change
2015-05-12 16:27 shuehner New Issue
2015-05-12 16:27 shuehner Assigned To => platform
2015-05-12 16:27 shuehner Modules => Core
2015-05-12 16:27 shuehner Triggers an Emergency Pack => No
2015-05-12 16:29 shuehner Relationship added related to 0029855
2015-05-12 16:30 shuehner Note Added: 0077343
2015-05-12 16:44 shuehner Summary Weld module does not pass 'ant validate.modules' => Weld,integration.google & json modules does not pass 'ant validate.modules'
2015-05-12 16:44 shuehner Description Updated View Revisions
2015-05-12 16:44 shuehner Steps to Reproduce Updated View Revisions
2015-05-13 08:23 alostale Status new => acknowledged
2015-08-26 08:47 caristu Assigned To platform => caristu
2015-08-26 08:47 caristu Status acknowledged => scheduled
2015-08-26 14:30 caristu Relationship added related to 0030680
2015-08-26 14:31 caristu Note Added: 0079758
2015-08-26 14:32 caristu Review Assigned To => AugustoMauch
2015-08-26 14:32 caristu Fixed in Version => 3.0PR15Q4
2015-08-26 14:32 caristu Target Version => 3.0PR15Q4
2015-08-26 14:33 hgbot Checkin
2015-08-26 14:33 hgbot Note Added: 0079759
2015-08-26 14:33 hgbot Status scheduled => resolved
2015-08-26 14:33 hgbot Resolution open => fixed
2015-08-26 14:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/eae81cf322cbcf0b89c80795de585512d8ce8465 [^]
2015-08-26 14:33 caristu Issue Monitored: AugustoMauch
2015-08-26 21:54 hudsonbot Checkin
2015-08-26 21:54 hudsonbot Note Added: 0079763
2015-08-28 11:45 AugustoMauch Note Added: 0079791
2015-08-28 11:45 AugustoMauch Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker