Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029709
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-04-27 16:422015-06-01 13:02
ReporterngarciaView Statuspublic 
Assigned ToNaroaIriarte 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisionfdb573cffe5f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029709: Cannot save a physical inventory line with a negative small number in the Book Quantity field

DescriptionCannot save a physical inventory line with a negative small number in the Book Quantity field
Steps To ReproduceChange the Format.xml as follow:

   <Number name="qtyRelation"
       decimal="." grouping="," formatOutput="#,##0.#######" formatInternal="#0.0000000" />
   <Number name="qtyEdition"
       decimal="." grouping="," formatOutput="#0.#######" formatInternal="#0.0000000" />
   <Number name="qtyExcel"
       decimal="." grouping="," formatOutput="#,##0.#######" formatInternal="#0.0000000" />

As group admin role:
   Go to Client window and in the Information tab, check the "Allow Negative Stock" checkbox.
   Create a new product
   Create a goods shipment for that product with the following quantity: 0.0003655
   Create a Physical Inventory and add the previously created product and a Quantity Count of 0
   The following error is shown:
      "Saving failed. Exception while trying to convert value:-->0.000-3655<-- null"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00261323.0PR14Q3 closedguillermogil wrong visualization value of quantity fields with very small numbers 
related to defect 00285523.0PR15Q2 closedalostale Purchase Invoice amount gets truncated upon saving, when the amount is big 
related to defect 0028720 closedalostale System is not saving big numbers properly 
related to defect 00257103.0PR14Q2 closedAugustoMauch Big numbers are not properly managed in amount fields 
related to defect 0030014 closedNaroaIriarte The function OB.Utilities.Number.OBMaskedToOBPlain is not working properly with negative big numbers 

-  Notes
(0077716)
hgbot (developer)
2015-05-25 16:22

Repository: erp/devel/pi
Changeset: fdb573cffe5fff9d54cfbaef5c83e539a7126947
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Mon May 25 16:18:51 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/fdb573cffe5fff9d54cfbaef5c83e539a7126947 [^]

Fixed issue 29709: Physical inventory cannot be created.

The problem was that if it was a very small negative Book Quantity number, it was not
possible to create a Physical Inventory line.

It was because the "ScientificToDecimal" function was not working properly with negative
numbers. The '-' sign was taken as a number instead of as a sign, that was the reason of
obtaining a value like 0.000-3655 when -0.0003655 was expected.

To fix this, a condition has been added which takes into account the fact of having
the '-' sign and to deal with the sign as a sign and not as a number.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities-number.js
---
(0077761)
hudsonbot (developer)
2015-05-26 15:08

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b0c5594df387 [^]
Maturity status: Test
(0077820)
hgbot (developer)
2015-05-27 16:07

Repository: erp/devel/pi
Changeset: 56a6bfc4e4c726767bad25f5bb4606727406653f
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Wed May 27 16:05:43 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/56a6bfc4e4c726767bad25f5bb4606727406653f [^]

Related with issue 29709: Some test cases have been created.

Some test have been created for testing the correct behaviour of the OB.Utilities.Number.roundJSNumber,
OB.Utilities.Number.ScientificToDecimal and OB.Utilities.Number.OBMaskedToOBPlain functions.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/ApplicationComponentProvider.java
M modules/org.openbravo.client.kernel/web/org.openbravo.client.kernel/ui-test-suite/index.html
A modules/org.openbravo.client.application/web/org.openbravo.client.application/js/test/ob-utilities-number-test.js
---
(0077844)
hudsonbot (developer)
2015-05-28 01:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ae25da3bd47f [^]
Maturity status: Test
(0077928)
alostale (developer)
2015-06-01 13:02

code reviewed:

Tested issues:
0026132
0029709
0028552
0028720
0025710
0030014

- Issue History
Date Modified Username Field Change
2015-04-27 16:42 ngarcia New Issue
2015-04-27 16:42 ngarcia Assigned To => platform
2015-04-27 16:42 ngarcia Modules => Core
2015-04-27 16:42 ngarcia Triggers an Emergency Pack => No
2015-04-27 16:43 ngarcia Relationship added related to 0026132
2015-04-27 16:43 ngarcia Issue Monitored: networkb
2015-04-27 18:33 ahernandezgil Issue Monitored: ahernandezgil
2015-04-28 07:57 alostale Status new => acknowledged
2015-05-22 10:19 alostale Status acknowledged => scheduled
2015-05-22 10:19 alostale Assigned To platform => NaroaIriarte
2015-05-22 12:58 NaroaIriarte Steps to Reproduce Updated View Revisions
2015-05-25 16:00 NaroaIriarte Review Assigned To => alostale
2015-05-25 16:01 NaroaIriarte Issue Monitored: alostale
2015-05-25 16:22 hgbot Checkin
2015-05-25 16:22 hgbot Note Added: 0077716
2015-05-25 16:22 hgbot Status scheduled => resolved
2015-05-25 16:22 hgbot Resolution open => fixed
2015-05-25 16:22 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/fdb573cffe5fff9d54cfbaef5c83e539a7126947 [^]
2015-05-26 09:29 NaroaIriarte Relationship added related to 0028552
2015-05-26 09:30 NaroaIriarte Relationship added related to 0028720
2015-05-26 09:32 NaroaIriarte Relationship added related to 0025710
2015-05-26 13:22 NaroaIriarte Relationship added related to 0030014
2015-05-26 15:08 hudsonbot Checkin
2015-05-26 15:08 hudsonbot Note Added: 0077761
2015-05-27 16:07 hgbot Checkin
2015-05-27 16:07 hgbot Note Added: 0077820
2015-05-28 01:10 hudsonbot Checkin
2015-05-28 01:10 hudsonbot Note Added: 0077844
2015-06-01 13:02 alostale Note Added: 0077928
2015-06-01 13:02 alostale Status resolved => closed
2015-06-01 13:02 alostale Fixed in Version => 3.0PR15Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker