Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028552
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformcriticalhave not tried2015-01-09 13:042015-02-04 20:33
ReporterjonalegriaesarteView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revisione5465c5925cf
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-04-08
Regression introduced in release3.0PR14Q3
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/28afef8656512aeae764101425d2e46cd7b9d051 [^]
Triggers an Emergency PackYes
Summary

0028552: Purchase Invoice amount gets truncated upon saving, when the amount is big

DescriptionPurchase Invoice amount gets truncated upon saving, when the amount is big
Steps To Reproduce1. Create Purchase Invoice
2. Create a new line
- enter unit price = 1200
- enter quantity = 29 900 000
3. Move away from the fields, and the Line Net Amount shows = 35,988,000,000.00 (CORRECT)
4. Click Save to save the line
The Line Net Amount shows 35.9 (INCORRECT)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00257103.0PR14Q2 closedAugustoMauch Big numbers are not properly managed in amount fields 
caused by defect 00261323.0PR14Q3 closedguillermogil wrong visualization value of quantity fields with very small numbers 
related to defect 0028561 closedcaristu OB.Utilities.Number.ScientificToDecimal does not work properly with numbers with leading zeros 
related to defect 0028262 acknowledgedplatform Number precision induces some unaccurate results 
related to defect 0029709 closedNaroaIriarte Cannot save a physical inventory line with a negative small number in the Book Quantity field 
related to defect 0030014 closedNaroaIriarte The function OB.Utilities.Number.OBMaskedToOBPlain is not working properly with negative big numbers 
causes defect 0028720 closedalostale System is not saving big numbers properly 

-  Notes
(0073397)
alostale (developer)
2015-01-09 14:13

This issue was reproducible in versions previous to Q2, it was fixed in Q2 and broken again in Q3.
(0073403)
hgbot (developer)
2015-01-09 15:19

Repository: erp/devel/pi
Changeset: e5465c5925cf54475d090258a3832ec8cc9d14ca
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jan 09 15:18:45 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e5465c5925cf54475d090258a3832ec8cc9d14ca [^]

fixed bug 28552: big numbers are changed in some cases

  Big numbers are modified in case their scientific notation represntation ends
  with zeros, trailing zeros were removed. So, ie., 3.5E10 was changed to 3.5E1
  this is: 3.5.

  The problem was caused by fix for 0026132 which tries to transform scientific to
  decimal notation (and then remove trailing zeros, which is correct). But it
  expected 3.5E+10 instead of 3.5E10, so in latter case, which is actually used
  it didn't do the transformation.

  The fix accepts scientific notation with both + and no +.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities-number.js
---
(0073405)
alostale (developer)
2015-01-09 15:40

Tested for big amounts and small ones (see 0026132)
(0073411)
AugustoMauch (developer)
2015-01-12 11:08

Code reviewed and verified in pi@5f64300e4811
(0074132)
hudsonbot (developer)
2015-02-04 20:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-01-09 13:04 jonalegriaesarte New Issue
2015-01-09 13:04 jonalegriaesarte Assigned To => AugustoMauch
2015-01-09 13:04 jonalegriaesarte Modules => Core
2015-01-09 13:04 jonalegriaesarte Triggers an Emergency Pack => No
2015-01-09 14:10 alostale Regression level => Production - Confirmed Stable
2015-01-09 14:10 alostale Regression date => 2014-04-08
2015-01-09 14:10 alostale Regression introduced in release => 3.0PR14Q3
2015-01-09 14:10 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/28afef8656512aeae764101425d2e46cd7b9d051 [^]
2015-01-09 14:10 alostale Triggers an Emergency Pack No => Yes
2015-01-09 14:10 alostale Assigned To AugustoMauch => alostale
2015-01-09 14:10 alostale Relationship added caused by 0026132
2015-01-09 14:12 alostale Relationship added related to 0025710
2015-01-09 14:13 alostale Note Added: 0073397
2015-01-09 15:19 alostale Review Assigned To => AugustoMauch
2015-01-09 15:19 hgbot Checkin
2015-01-09 15:19 hgbot Note Added: 0073403
2015-01-09 15:19 hgbot Status new => resolved
2015-01-09 15:19 hgbot Resolution open => fixed
2015-01-09 15:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e5465c5925cf54475d090258a3832ec8cc9d14ca [^]
2015-01-09 15:40 alostale Note Added: 0073405
2015-01-12 11:07 AugustoMauch Relationship added related to 0028561
2015-01-12 11:08 AugustoMauch Note Added: 0073411
2015-01-12 11:08 AugustoMauch Status resolved => closed
2015-01-12 11:08 AugustoMauch Fixed in Version => 3.0PR15Q2
2015-01-20 17:03 alostale Relationship added related to 0028262
2015-01-22 09:27 alostale Relationship added related to 0028720
2015-01-22 10:39 alostale Relationship replaced causes 0028720
2015-02-04 20:33 hudsonbot Checkin
2015-02-04 20:33 hudsonbot Note Added: 0074132
2015-05-26 09:29 NaroaIriarte Relationship added related to 0029709
2015-05-26 13:20 NaroaIriarte Relationship added related to 0030014


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker