Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025710
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2014-02-12 10:542014-02-13 07:16
ReporterjonalegriaesarteView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revision9d50bf45a6c9
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025710: Big numbers are not properly managed in amount fields

DescriptionBig numbers are not properly managed in amount fields. If the user adds the amount 10,123,494,348.67 the sytem is managing it as 10.12
Steps To Reproduce- G/L Journal window
- Create a Batch
- Create a Header
- New line. Add the amount 10,123,494,348.67 in debit field, the amount stored is 10.12
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 0025949 closeddmiguelez Amount is not properly displayed in windows Payment In and out 
related to defect 00285523.0PR15Q2 closedalostale Purchase Invoice amount gets truncated upon saving, when the amount is big 
related to defect 0029709 closedNaroaIriarte Cannot save a physical inventory line with a negative small number in the Book Quantity field 
related to defect 0030014 closedNaroaIriarte The function OB.Utilities.Number.OBMaskedToOBPlain is not working properly with negative big numbers 

-  Notes
(0064075)
jonalegriaesarte (reporter)
2014-02-12 10:55

The same is happening when using small numbers 0.0000001
In this case, you can change the price precision to 7 and store this number in one order line for example. The system is not managing it correctly
(0064187)
hgbot (developer)
2014-02-12 18:44

Repository: erp/devel/pi
Changeset: 9d50bf45a6c90939c02d59d24caba57bd769c216
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Feb 12 18:42:08 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/9d50bf45a6c90939c02d59d24caba57bd769c216 [^]

Fixes issue 25710: Big numbers are not properly managed in amount fields

The problem was that the OB.Utilities.Number.OBMaskedToOBPlain function was removing the '0's after the decimal dot even if the number was being expressed in decimal notation. This way, '1.12E10' was being converted to '1.12E1'.

This has been fixed by not removing the lasting '0's if the number is expressed in decmial notation.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities-number.js
---
(0064188)
AugustoMauch (developer)
2014-02-12 18:44

The problem related to the small numbers will be fixed in a separate issue.
(0064198)
shankarb (developer)
2014-02-13 05:33

Code reviewed and verified in pi changeset 083d67ea235a.
(0064206)
hudsonbot (developer)
2014-02-13 07:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/76fb3237bc3a [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-02-12 10:54 jonalegriaesarte New Issue
2014-02-12 10:54 jonalegriaesarte Assigned To => AugustoMauch
2014-02-12 10:54 jonalegriaesarte Modules => Core
2014-02-12 10:54 jonalegriaesarte Triggers an Emergency Pack => No
2014-02-12 10:55 jonalegriaesarte Note Added: 0064075
2014-02-12 18:39 AugustoMauch Issue Monitored: shankarb
2014-02-12 18:40 AugustoMauch Review Assigned To => shankarb
2014-02-12 18:44 hgbot Checkin
2014-02-12 18:44 hgbot Note Added: 0064187
2014-02-12 18:44 hgbot Status new => resolved
2014-02-12 18:44 hgbot Resolution open => fixed
2014-02-12 18:44 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9d50bf45a6c90939c02d59d24caba57bd769c216 [^]
2014-02-12 18:44 AugustoMauch Note Added: 0064188
2014-02-13 05:33 shankarb Note Added: 0064198
2014-02-13 05:33 shankarb Status resolved => closed
2014-02-13 05:33 shankarb Fixed in Version => 3.0MP32
2014-02-13 07:16 hudsonbot Checkin
2014-02-13 07:16 hudsonbot Note Added: 0064206
2014-03-13 11:04 egoitz Relationship added has duplicate 0025949
2015-01-09 14:12 alostale Relationship added related to 0028552
2015-05-26 09:32 NaroaIriarte Relationship added related to 0029709
2015-05-26 13:19 NaroaIriarte Relationship added related to 0030014


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker