Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029666
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-04-22 11:372015-05-07 22:16
ReporterVictorVillarView Statuspublic 
Assigned Toumartirena 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision038e26600576
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-08-20
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/186b3f5bcf21 [^]
Triggers an Emergency PackNo
Summary

0029666: Null Pointer exception of the Costing Background Process when you are creating a new costing rule (standard)

DescriptionNull Pointer exception of the Costing Background Process when you are creating a new costing rule (standard)
Steps To ReproduceAs group admin role,
 Go to Costing rule:
    create a new costing rule -> type: Standard
    Org: US
    Warehouse dimension: No
    Backdated transactions fixed: Yes (also it happens, if you do not check it)
    Fix Backdated From: Blank
Validate it.

 Go to Process Request window,
    Unschedule the costing background process
    Create a new one: Run inmediately.
Go to Process Monitor window,
   Realise that the process has 'Success' status but there is nothing in the Process Log.

The reason:
867946fe 84026822 [DefaultQuartzScheduler_Worker-8] ERROR org.openbravo.costing.CostingBackground -
java.lang.NullPointerException
    at org.openbravo.costing.StandardAlgorithm.getOpeningInventoryCost(StandardAlgorithm.java:63)
    at org.openbravo.costing.StandardAlgorithm.getTransactionCost(StandardAlgorithm.java:38)
    at org.openbravo.costing.CostingServer.process(CostingServer.java:104)
    at org.openbravo.costing.CostingBackground.doExecute(CostingBackground.java:119)
    at org.openbravo.service.db.DalBaseProcess.execute(DalBaseProcess.java:80)
    at org.openbravo.scheduling.DefaultJob.execute(DefaultJob.java:58)
    at org.quartz.core.JobRunShell.run(JobRunShell.java:202)
    at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:525)

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00296773.0PR15Q2 closedumartirena Null Pointer exception of the Costing Background Process when you are creating a new costing rule (standard) 
depends on backport 00296783.0PR15Q1.4 closedumartirena Null Pointer exception of the Costing Background Process when you are creating a new costing rule (standard) 
caused by feature request 0022855 closeddmiguelez It would be fine to have the cost adjustment functionality implemented 

-  Notes
(0076744)
hgbot (developer)
2015-04-24 11:29

Repository: erp/devel/pi
Changeset: 038e26600576ccd2ed3d23edaf9b91d623c8deba
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Thu Apr 23 10:20:01 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/038e26600576ccd2ed3d23edaf9b91d623c8deba [^]

Fixes bug 29666: Fix NPE in Costing Background with Standard Costing Rule

In Cost Adjustment project new method has been added to calculate an opening inventory cost. This method uses 'CostinUtils.getStandardCostDefinition' method, that tries to get an standard cost for that opening inventory. If it does not found any standard or legacy cost, it returns null. So, in this moment a NPE error was happening. To fix this problem, at this point a controlled error is raised to notify the user that no cost has been found.

---
M src/org/openbravo/costing/StandardAlgorithm.java
---
(0076747)
vmromanos (developer)
2015-04-24 11:31

Code review + testing OK
(0077152)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-22 11:37 VictorVillar New Issue
2015-04-22 11:37 VictorVillar Assigned To => umartirena
2015-04-22 11:37 VictorVillar Modules => Core
2015-04-22 11:37 VictorVillar Regression level => Production - QA Approved
2015-04-22 11:37 VictorVillar Triggers an Emergency Pack => No
2015-04-22 18:08 VictorVillar Steps to Reproduce Updated View Revisions
2015-04-22 18:13 VictorVillar Steps to Reproduce Updated View Revisions
2015-04-23 10:06 umartirena Regression date => 2014-08-20
2015-04-23 10:06 umartirena Regression introduced in release => 3.0PR14Q4
2015-04-23 10:06 umartirena Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/186b3f5bcf21 [^]
2015-04-23 10:07 umartirena Status new => scheduled
2015-04-23 12:49 dmitry_mezentsev Relationship added caused by 0022855
2015-04-23 12:50 dmitry_mezentsev Regression level Production - QA Approved => Production - Confirmed Stable
2015-04-24 11:29 hgbot Checkin
2015-04-24 11:29 hgbot Note Added: 0076744
2015-04-24 11:29 hgbot Status scheduled => resolved
2015-04-24 11:29 hgbot Resolution open => fixed
2015-04-24 11:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/038e26600576ccd2ed3d23edaf9b91d623c8deba [^]
2015-04-24 11:31 vmromanos Review Assigned To => vmromanos
2015-04-24 11:31 vmromanos Note Added: 0076747
2015-04-24 11:31 vmromanos Status resolved => closed
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077152


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker