Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029677
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 04. Warehouse managementmajoralways2015-04-22 11:372015-04-24 11:30
ReporterVictorVillarView Statuspublic 
Assigned Toumartirena 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision1342ece3ecd9
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-08-20
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/186b3f5bcf21 [^]
Triggers an Emergency PackNo
Summary

0029677: Null Pointer exception of the Costing Background Process when you are creating a new costing rule (standard)

DescriptionNull Pointer exception of the Costing Background Process when you are creating a new costing rule (standard)
Steps To ReproduceAs group admin role,
 Go to Costing rule:
    create a new costing rule -> type: Standard
    Org: US
    Warehouse dimension: No
    Backdated transactions fixed: Yes (also it happens, if you do not check it)
    Fix Backdated From: Blank
Validate it.

 Go to Process Request window,
    Unschedule the costing background process
    Create a new one: Run inmediately.
Go to Process Monitor window,
   Realise that the process has 'Success' status but there is nothing in the Process Log.

The reason:
867946fe 84026822 [DefaultQuartzScheduler_Worker-8] ERROR org.openbravo.costing.CostingBackground -
java.lang.NullPointerException
    at org.openbravo.costing.StandardAlgorithm.getOpeningInventoryCost(StandardAlgorithm.java:63)
    at org.openbravo.costing.StandardAlgorithm.getTransactionCost(StandardAlgorithm.java:38)
    at org.openbravo.costing.CostingServer.process(CostingServer.java:104)
    at org.openbravo.costing.CostingBackground.doExecute(CostingBackground.java:119)
    at org.openbravo.service.db.DalBaseProcess.execute(DalBaseProcess.java:80)
    at org.openbravo.scheduling.DefaultJob.execute(DefaultJob.java:58)
    at org.quartz.core.JobRunShell.run(JobRunShell.java:202)
    at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:525)

TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00296663.0PR15Q2 closedumartirena Null Pointer exception of the Costing Background Process when you are creating a new costing rule (standard) 

-  Notes
(0076743)
hgbot (developer)
2015-04-24 11:29

Repository: erp/backports/3.0PR15Q2
Changeset: 1342ece3ecd9ae071ab227b2f6e90f4ab9a8269f
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Thu Apr 23 10:18:37 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2/rev/1342ece3ecd9ae071ab227b2f6e90f4ab9a8269f [^]

Fixes bug 29677: Fix NPE in Costing Background with Standard Costing Rule

In Cost Adjustment project new method has been added to calculate an opening inventory cost. This method uses 'CostinUtils.getStandardCostDefinition' method, that tries to get an standard cost for that opening inventory. If it does not found any standard or legacy cost, it returns null. So, in this moment a NPE error was happening. To fix this problem, at this point a controlled error is raised to notify the user that no cost has been found.

---
M src/org/openbravo/costing/StandardAlgorithm.java
---
(0076746)
vmromanos (developer)
2015-04-24 11:30

Code review + testing OK

- Issue History
Date Modified Username Field Change
2015-04-23 10:07 umartirena Type defect => backport
2015-04-23 12:50 dmitry_mezentsev Tag Attached: Approved
2015-04-24 11:29 hgbot Checkin
2015-04-24 11:29 hgbot Note Added: 0076743
2015-04-24 11:29 hgbot Status scheduled => resolved
2015-04-24 11:29 hgbot Resolution open => fixed
2015-04-24 11:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2/rev/1342ece3ecd9ae071ab227b2f6e90f4ab9a8269f [^]
2015-04-24 11:30 vmromanos Review Assigned To => vmromanos
2015-04-24 11:30 vmromanos Note Added: 0076746
2015-04-24 11:30 vmromanos Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker