Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029496
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajoralways2015-04-01 17:252015-06-26 15:57
ReporterVictorVillarView Statuspublic 
Assigned Tojorge-garcia 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiona111a9e90082
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029496: It is not possible to do a return to vendor using non stocked products

DescriptionIt is not possible to do a return to vendor using non stocked products
Steps To ReproduceAs group admin role,
  Go to Product window,
   create a new one
   Item: Yes
   Stocked= No
 Go to Price tab:
    select the Bebidas alegres price list
    Unit Price:2
    List price: 2
Go to Purchase order (business partner: Bebidas alegres)
   create a new one selecting the product created before.
   qty: 1
Complete it.
 Create a goods Receipt (business partner: Bebidas alegres)related with this Purchase order.
   Use 'Create Lines From' to select the product
Complete it.
 Create the Purchase Invoice (business partner: Bebidas alegres) related with this goods receipt.
Complete it.

 Go to Return to vendor window,
   create a new one (business partner: Bebidas alegres) selecting the goods receipt created before.
 Return qty: 1
Complete it.
  Go to Return to vendor shipment.
     create a new one (business partner: Bebidas alegres) selecting the return to vendor created before.
 Realise that it does not appear any register.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0032520 closedAtulOpenbravo Wrong available quantity is shown in Return To Vendor Shipment Pick and Edit when there is not stock 

-  Notes
(0076461)
jorge-garcia (developer)
2015-04-13 09:21

Test Plan:

As group admin role,
  Go to Product window,
   create a new one
   Item: Yes
   Stocked= No
 Go to Price tab:
    select the Bebidas alegres price list
    Unit Price:2
    List price: 2
Go to Purchase order (business partner: Bebidas alegres)
   create a new one selecting the product created before.
   qty: 1
Complete it.
 Create a goods Receipt (business partner: Bebidas alegres)related with this Purchase order.
   Use 'Create Lines From' to select the product
Complete it.
 Create the Purchase Invoice (business partner: Bebidas alegres) related with this goods receipt.
Complete it.

 Go to Return to vendor window,
   create a new one (business partner: Bebidas alegres) selecting the goods receipt created before.
 Return qty: 1
Complete it.
  Go to Return to vendor shipment.
     create a new one (business partner: Bebidas alegres) selecting the return to vendor created before.
 Realise that it appears the register it's just created.
(0078509)
hgbot (developer)
2015-06-25 15:35

Repository: erp/devel/pi
Changeset: a111a9e90082f9008ca2e2224436f5d260c35326
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Thu Apr 09 11:00:22 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a111a9e90082f9008ca2e2224436f5d260c35326 [^]

Fixed issue 29496: Not possible to do return to vendor using non stocked product

It is not possible to do a return to vendor using non stocked products.

The Pick and Edit window didn't show order from non stocked produts caused by
a Hibernate error when creating the sql from the HQL Where Clause.

The solution is to change the HQL where clause from this window and avoid the
cross join of the m_locator table. A subselect query has been added to the
Where Clause to avoid this error.

In addition, a new constraint has been added to the HQL Where Clause and now
the products without a storage bin are shown as well.

---
M src-db/database/sourcedata/AD_TAB.xml
---
(0078510)
hgbot (developer)
2015-06-25 15:35

Repository: erp/devel/pi
Changeset: 3f6a959095d44c82ff089e7237f432ec37ae2e9c
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Thu May 07 16:18:01 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3f6a959095d44c82ff089e7237f432ec37ae2e9c [^]

Related to issue 29496: Not possible to do a return with non stocked product

Not possible to do return to vendor using non stocked product.

The problem here was that the Return to Vendor line of a non stocked product
appears in the Pick/Edit Lines window in the Return to Vendor Shipment
window, but, when selected, a error message appears and it's not possible
to done the picking.

Now, we save the property stockable of the product, and we check if the product
is non stockable. Now, the Pick/Edit Lines works fine and it is possible to
process the Return to Vendor Shipment.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/return-material/ob-return-material.js
M src-db/database/model/views/M_RM_SHIPMENT_PICK_EDIT.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_FIELD.xml
---
(0078511)
hgbot (developer)
2015-06-25 15:35

Repository: erp/devel/pi
Changeset: 405ac3729ec74f3954b4fa361ed1f271fdaa6918
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Thu Jun 25 15:32:39 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/405ac3729ec74f3954b4fa361ed1f271fdaa6918 [^]

Related to issue 29496: Code review improvements

Added the same AD_Element_ID to the new IsStocked column as in the Product table
Updated copyright and fixed typo

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/return-material/ob-return-material.js
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_FIELD.xml
---
(0078512)
vmromanos (developer)
2015-06-25 15:36

Code review + testing OK
(0078542)
hudsonbot (developer)
2015-06-26 15:57

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/60ba8db95a9d [^]
Maturity status: Test
(0078543)
hudsonbot (developer)
2015-06-26 15:57

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/60ba8db95a9d [^]
Maturity status: Test
(0078544)
hudsonbot (developer)
2015-06-26 15:57

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/60ba8db95a9d [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-01 17:25 VictorVillar New Issue
2015-04-01 17:25 VictorVillar Assigned To => Sandrahuguet
2015-04-01 17:25 VictorVillar Modules => Core
2015-04-01 17:25 VictorVillar Triggers an Emergency Pack => No
2015-04-01 17:25 VictorVillar Issue Monitored: networkb
2015-04-07 16:02 jorge-garcia Status new => scheduled
2015-04-07 16:02 jorge-garcia Assigned To Sandrahuguet => jorge-garcia
2015-04-13 09:21 jorge-garcia Note Added: 0076461
2015-06-15 14:01 vmromanos Assigned To jorge-garcia => Triage Finance
2015-06-25 15:35 hgbot Checkin
2015-06-25 15:35 hgbot Note Added: 0078509
2015-06-25 15:35 hgbot Status scheduled => resolved
2015-06-25 15:35 hgbot Resolution open => fixed
2015-06-25 15:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a111a9e90082f9008ca2e2224436f5d260c35326 [^]
2015-06-25 15:35 hgbot Checkin
2015-06-25 15:35 hgbot Note Added: 0078510
2015-06-25 15:35 hgbot Checkin
2015-06-25 15:35 hgbot Note Added: 0078511
2015-06-25 15:35 vmromanos Assigned To Triage Finance => jorge-garcia
2015-06-25 15:36 vmromanos Review Assigned To => vmromanos
2015-06-25 15:36 vmromanos Note Added: 0078512
2015-06-25 15:36 vmromanos Status resolved => closed
2015-06-26 15:57 hudsonbot Checkin
2015-06-26 15:57 hudsonbot Note Added: 0078542
2015-06-26 15:57 hudsonbot Checkin
2015-06-26 15:57 hudsonbot Note Added: 0078543
2015-06-26 15:57 hudsonbot Checkin
2015-06-26 15:57 hudsonbot Note Added: 0078544
2017-09-28 09:40 aferraz Relationship added related to 0032520


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker