Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032520
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementminoralways2016-03-21 16:512017-10-02 17:58
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision7d2c288c2d47
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032520: Wrong available quantity is shown in Return To Vendor Shipment Pick and Edit when there is not stock

DescriptionWrong available quantity is shown in Return To Vendor Shipment Pick and Edit when there is not stock
Steps To ReproduceAs group admin role:
   Create a Return to Vendor
   Select a product with stock
   Add a returned quantity and complete it
   Create a Return to Vendor Shipment
   Open the Pick/Edit Lines
   Check the line is shown with the Storage Bin field filled and the correct available quantity
   Leave the stock of the product to 0
   Check the line is shown with the Storage Bin field empty and the available quantity shows the quantity in the return to vendor line
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00276263.0PR15Q1 closedreinaldoguerra The Return to Vendor Shipment Pick and Edit should take into account those products without stock 
related to defect 0029496 closedjorge-garcia It is not possible to do a return to vendor using non stocked products 
caused by defect 00237223.0MP26 closedjecharri Products defined as "service" don't appear in Return To Vendor Shipment pick/edit 

-  Notes
(0099647)
hgbot (developer)
2017-09-28 11:32

Repository: erp/devel/pi
Changeset: 7d2c288c2d470f971606243ce4bd450430465de6
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Mon Apr 25 22:33:24 2016 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/7d2c288c2d470f971606243ce4bd450430465de6 [^]

Fixes issue 32520: Wrong available quantity is shown in Return To Vendor Shipment
Pick and Edit when there is not stock

If product is not stockable, available quantity will be return to vendor line quantity.
Otherwise, available quantity will be calculated.

---
M src-db/database/model/views/M_RM_SHIPMENT_PICK_EDIT.xml
---
(0099649)
aferraz (developer)
2017-09-28 11:58

Code review + Testing OK
(0099699)
hudsonbot (developer)
2017-10-02 17:58

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/44a89970274a [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-03-21 16:51 ngarcia New Issue
2016-03-21 16:51 ngarcia Assigned To => Triage Finance
2016-03-21 16:51 ngarcia Modules => Core
2016-03-21 16:51 ngarcia Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/d4cc4d831aa79530e485044d9daeeb68be438f4c [^]
2016-03-21 16:51 ngarcia Triggers an Emergency Pack => No
2016-03-21 16:52 ngarcia Relationship added related to 0027626
2016-03-21 16:52 ngarcia Relationship added caused by 0023722
2016-03-21 16:53 ngarcia Issue Monitored: networkb
2016-03-30 00:07 agarcia_tegik Issue Monitored: agarcia_tegik
2016-04-26 09:50 aferraz Regression introduced by commit https://code.openbravo.com/erp/devel/pi/rev/d4cc4d831aa79530e485044d9daeeb68be438f4c [^] =>
2016-04-26 11:06 aferraz Priority immediate => normal
2016-05-02 21:47 tegik_forge Issue Monitored: tegik_forge
2017-05-30 18:15 nonofrancisco Assigned To Triage Finance => nonofrancisco
2017-05-30 18:16 nonofrancisco Status new => scheduled
2017-09-28 09:40 aferraz Relationship added related to 0029496
2017-09-28 11:32 hgbot Checkin
2017-09-28 11:32 hgbot Note Added: 0099647
2017-09-28 11:32 hgbot Status scheduled => resolved
2017-09-28 11:32 hgbot Resolution open => fixed
2017-09-28 11:32 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7d2c288c2d470f971606243ce4bd450430465de6 [^]
2017-09-28 11:35 aferraz Assigned To nonofrancisco => AtulOpenbravo
2017-09-28 11:58 aferraz Review Assigned To => aferraz
2017-09-28 11:58 aferraz Note Added: 0099649
2017-09-28 11:58 aferraz Status resolved => closed
2017-09-28 11:58 aferraz Fixed in Version => 3.0PR17Q4
2017-10-02 17:58 hudsonbot Checkin
2017-10-02 17:58 hudsonbot Note Added: 0099699


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker