Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029423
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 04. Warehouse managementmajoralways2015-03-26 08:342015-04-01 08:31
ReporterumartirenaView Statuspublic 
Assigned Toumartirena 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiondb2646aeed64
ProjectionnoneETAnoneTarget Version3.0PR15Q1.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029423: [Cost Adjustment] Adjustment amounts of more than 2 decimal precision are being created in costing background

DescriptionWhile running Costing Background process with the functionality of Cost Adjustments, in certain cases adjustment are being created of amount with more than two decimal precision, and this is wrong, as an amount always has to has at most two decimal precision. Two cases detected are while using orphan lines or negative amount shipments.
Steps To ReproduceIn live.builds

As System Admin:
 * Change costing precision and price precision to 4 for EUR Currency.

In F&B:
 * Enable "RM Allow Orphan Line" preference.
 * Have a valid average costing rule for F&B España org.
 * Create a Product
 * Add a Costing Record:
  - Org: F&B España
  - Cost: 5.5555
  - Cost Type: Average
  - Starting Date: 01/01/2014
  - Ending Date: 31/12/9999
 * Create a Goods Shipment:
  - Org: F&B España
  - Business Partner: Alimentos y Supermercados
  - Movement Date: 10/02/2015
 * Add a Line:
  - Product: The new product
  - Qty: 10.257
  - Storage Bin: RN 0-0-0
 * Complete it
 * Go to Return from Customer window
 * Create a Header:
  - Org: F&B España
  - Business Partner: Alimentos y Supermercados
  - Order Date: 05/02/2015
 * Click on "Insert Orphan Line":
  - Product: The new product
  - Returned: 5.236
  - Unit Price: 12.33
  - Tax: Arrendamiento 21% (Cobros) - IVA Normal
 * Click OK and Book it
 * Go to Return Material Receipt:
 * Create a Header:
  - Org: F&B España
  - Business Partner: Alimentos y Supermercados
  - Movement Date: 05/02/2015
 * Click on Pick/Edit Lines:
 * Select the line created in previous Return from Customer
  - Received: 5.236
  - Storage Bin: RN 0-0-0
 * Click Done and Complete it
 * Go to Process Request window
 * Run Costing Background process

 * In pgadmin run the following query: "select * from m_costadjustmentline order by created desc"

 Realize that an adjustment line of amount -0.0045 has been created, what is wrong because it should have been of 0.00 amount.
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00294173.0PR15Q2 closedumartirena [Cost Adjustment] Adjustment amounts of more than 2 decimal precision are being created in costing background 

-  Notes
(0076091)
hgbot (developer)
2015-03-27 14:50

Repository: erp/backports/3.0PR15Q1.2
Changeset: db2646aeed64c352b1ff068074139f0558633d30
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Thu Mar 26 13:11:19 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q1.2/rev/db2646aeed64c352b1ff068074139f0558633d30 [^]

Fixes bug 29423: Round with standard precision cost adjutment amounts

There are certain places in which the amount to be adjusted was being rounded to costing precision, instead of standard precision, and this is wrong because the amounts allways has to be at most of precision 2.

---
M src/org/openbravo/costing/AverageCostAdjustment.java
---
(0076092)
aferraz (developer)
2015-03-27 14:55

Code review + Testing OK
(0076244)
hgbot (developer)
2015-04-01 08:11

Repository: erp/backports/3.0PR15Q2
Changeset: db2646aeed64c352b1ff068074139f0558633d30
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Thu Mar 26 13:11:19 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2/rev/db2646aeed64c352b1ff068074139f0558633d30 [^]

Fixes bug 29423: Round with standard precision cost adjutment amounts

There are certain places in which the amount to be adjusted was being rounded to costing precision, instead of standard precision, and this is wrong because the amounts allways has to be at most of precision 2.

---
M src/org/openbravo/costing/AverageCostAdjustment.java
---
(0076247)
priyam (administrator)
2015-04-01 08:31

closed again, as the status changed due the merge tag of 3.0PR15Q1.2 to backports/3.0PR15Q2

- Issue History
Date Modified Username Field Change
2015-03-26 10:28 umartirena Type defect => backport
2015-03-26 10:28 umartirena Target Version => 3.0PR15Q1.2
2015-03-26 13:32 dmitry_mezentsev Tag Attached: Approved
2015-03-27 14:50 hgbot Checkin
2015-03-27 14:50 hgbot Note Added: 0076091
2015-03-27 14:50 hgbot Status scheduled => resolved
2015-03-27 14:50 hgbot Resolution open => fixed
2015-03-27 14:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q1.2/rev/db2646aeed64c352b1ff068074139f0558633d30 [^]
2015-03-27 14:55 aferraz Review Assigned To => aferraz
2015-03-27 14:55 aferraz Note Added: 0076092
2015-03-27 14:55 aferraz Status resolved => closed
2015-04-01 08:11 hgbot Checkin
2015-04-01 08:11 hgbot Note Added: 0076244
2015-04-01 08:11 hgbot Status closed => resolved
2015-04-01 08:11 hgbot Fixed in SCM revision http://code.openbravo.com/erp/backports/3.0PR15Q1.2/rev/db2646aeed64c352b1ff068074139f0558633d30 [^] => http://code.openbravo.com/erp/backports/3.0PR15Q2/rev/db2646aeed64c352b1ff068074139f0558633d30 [^]
2015-04-01 08:31 priyam Status resolved => closed
2015-04-01 08:31 priyam Note Added: 0076247


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker